Page 76 of 124 FirstFirst ... 2666747576777886 ... LastLast
Results 751 to 760 of 1236

Thread: ALSA Upgrade Script

  1. #751
    Join Date
    Apr 2009
    Beans
    10

    Re: ALSA Upgrade Script

    Quote Originally Posted by yonkiman View Post
    I'm still a bit confused - I thought this would show up in Synaptic after I added the PPA ("sudo add-apt-repository ppa:ubuntu-audio-dev"), but I didn't see anything. Would you mind spelling out exactly what to type to get the repository and the alsa package? I'm not sure what to do with "linux-alsa-driver-modules-`uname -r` (including the -nn-{generic,server}".
    At the console, enter the command 'uname -r'. You'll get something like 2.6.31-20-generic (probably). That's what goes after "linux-alsa-driver-modules-". It's probably easiest just to use aptitude or synaptic to get there. The backticks are a trick you can use from the command line (you'll want to look up what's going on there in a bash tutorial/documentation).

    Quote Originally Posted by yonkiman View Post
    I'm even more confused: This will upgrade alsa to the latest 1.0.23, but the tools stay 1.0.20?
    The packages in the PPA are just Takashi Iwai's latest snapshot of the ALSA drivers, taken from here. The kernel modules do not rely on support from the ALSA userspace tools, as far as I know, so you can update one without touching the other; the PPA does not contain updated versions of the tools, just the modules.

  2. #752
    Join Date
    Dec 2008
    Beans
    180
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: ALSA Upgrade Script

    So I tried the modified 1.0.23 upgrade script (twice).. and then I tried the PPA (couldn't get that to work), so then I went the old-fashioned route of downloading the tarballs and compiling, per http://monespaceperso.org/blog-en/20...ic-koala-9-10/

    cat /proc/asound/version still shows
    Advanced Linux Sound Architecture Driver Version 1.0.22.1.
    Has anyone gotten it to report 1.0.23?

    Looking to make sure the binaries were what I compiled I'm suspcisious that alsa looks old (thos just a wrapper script)
    Code:
    -rwxr-xr-x 1 root root 35445 2010-04-21 22:03 /usr/sbin/alsaconf*
    -rwxr-xr-x 1 root root 5553 2009-10-11 18:07 /sbin/alsa*
    -rwxr-xr-x 1 root root 148188 2010-04-21 22:03 /usr/bin/alsamixer*
    hmm.. I have 2 copies of alsactl
    Code:
    /usr/sbin/alsactl
    /sbin/alsactl
    but the older one reports 1.0.20.. so I'm still not sure where the 1.0.22.1 is still lingering..

    I'm stumped..

  3. #753
    Join Date
    Apr 2010
    Beans
    1

    Re: ALSA Upgrade Script

    Just wanted to say thank you so much, not only did I get my sound back but things are working so much better! Upgraded from 1.0.20.* (Mint 8 LXDE) to 1.0.22.1 on an HP G61-420SO. Solved the very low volume on the internal mic as well I might add for anyone googling it. I'm not sure whether I dare use suspend again though hehe.

  4. #754
    Join Date
    Apr 2010
    Beans
    1

    Re: ALSA Upgrade Script

    Thank you so much, OP! After probably 30 minutes of tinkering, a bit of googling, and some elbow grease, I successfully acquired sound through both my speakers and headphone jack on an ASUS G50Vt; No easy feat! Good luck to everyone else, and thanks again!

  5. #755
    Join Date
    Aug 2006
    Beans
    110

    Re: ALSA Upgrade Script

    after reinstalling mint8 and running the upgrade script (success) but no sound. Worse, if I boot up while my usb headset is plugged in it hangs with

    soft lockup cpu#0 stuck for 61secs

    over and over.

    Unplug headset and machine boots normally. after normal boot I start ryhtmbox there is no sound and pulse volume control shows no application playing. Plug headset in and everything locks up. Have to reboot.

  6. #756
    Join Date
    Apr 2010
    Beans
    1

    Re: ALSA Upgrade Script

    Hi,

    I change the alsa version to 1.0.23 in the shell script and it works fine !

    Mother board : ASUS P7P55D deluxe
    Sound card chipset : VIA VT2020 10 channel High Definition

    Thank you a lot soundcheck !

    Enjoy.
    Attached Files Attached Files

  7. #757
    Join Date
    Dec 2008
    Beans
    180
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: ALSA Upgrade Script

    Quote Originally Posted by syrus31 View Post
    Hi,

    I change the alsa version to 1.0.23 in the shell script and it works fine !

    Mother board : ASUS P7P55D deluxe
    Sound card chipset : VIA VT2020 10 channel High Definition

    Thank you a lot soundcheck !

    Enjoy.
    not working for me
    >cat /proc/asound/version
    Advanced Linux Sound Architecture Driver Version 1.0.22.1.
    Compiled on Mar 25 2010 for kernel 2.6.31-21-generic (SMP).

  8. #758
    Join Date
    Jan 2008
    Beans
    183

    Re: ALSA Upgrade Script

    Quote Originally Posted by zim2dive View Post
    not working for me
    I had the same problem. I'm not sure exactly what I did that finally worked; I tried a lot of things including:
    • uninstalled the new alsa using the upgrade script ("-r" option, I believe),
    • uninstalled the original alsa using synaptic,
    • reinstalled alsa using the script,
    • other similar flailing about.


    In the end it worked. First I got 1.0.22.1 as you did. I flailed around. Then I got 1.0.23 but no sound. I flailed some more. Then I got 1.0.23 with sound.

    Probably not the most helpful post you'll get; just think of it as encouragement to keep trying.

  9. #759
    Join Date
    May 2007
    Location
    Sweden
    Beans
    11
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: ALSA Upgrade Script

    Quote Originally Posted by soundcheck View Post
    I also run a USB 0404. SPDIF/Toslink should work if you route the traffic
    to plughw:1,1 (I havn't checked it out on 1.0.19 though)

    I set the 0404 to 24/96 under Windows. Now I am feeding it with any material re-sampled to 24/96 through MPD.

    The 0404USB will work in sterero only. No fancy features are supported.

    Cheers
    Hi Soundcheck long time
    Are you still using this E-mu 0404 card ? It seems it stopped working in Alsa 1.0.20 ? I'm currently trying to figure out how to get it working again

  10. #760
    Join Date
    May 2006
    Beans
    Hidden!

    Re: ALSA Upgrade Script

    Ugh, 462mb of packages to upgrade a sound driver?

    What a pile of junk this put on my computer, luckily I control-c'd in the middle. Hopefully -r will remove all that junk it did get on.

    What a terrible implementation. Beware!!! Stay away!

Page 76 of 124 FirstFirst ... 2666747576777886 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •