Page 62 of 124 FirstFirst ... 1252606162636472112 ... LastLast
Results 611 to 620 of 1236

Thread: ALSA Upgrade Script

  1. #611
    Join Date
    Jan 2010
    Location
    65 AD
    Beans
    304
    Distro
    Ubuntu Development Release

    Re: ALSA Upgrade Script

    Thank you for the script. Installed 1.0.22.1 on a Gateway MX3228 with VIA8237 ALC250 sound. I made multiple tries using this script and others and finally this one worked after I removed alsa and pulseaudio from package manager and also deleted /etc/modprobe.d/alsa-base.conf and alsa-base.save.

  2. #612
    Join Date
    Jan 2010
    Beans
    3

    Samsung Netbook Mic Issue

    1. Kubuntu 9.10
    2. Ubuntu, Linux 2.6.31-17-Generic
    3. Alsa 1.0.22.1
    4. AlsaUpgrade-1.0.22.1-2.sh
    5. Speakers and headset speakers have worked from the beginning but when I use the headset mic with Gizmo (Google Voice) there is so much static that no one can understand me. Same with Skype.

    I ran the script and the -s option as well with no improvement. Same equipment works fine on the Windows XP side. I have fiddled with the Mixer settings without success. Nothing seems to get rid of the mic noise. If I can't use Google Voice, I'll need to stay on the Windows side which will be most unfortunate.
    6. alsa-info log attached.

    Thanks for any help you may offer on this excellent thread.
    Attached Files Attached Files

  3. #613
    Join Date
    Jun 2009
    Location
    Alabama
    Beans
    2,232

    Question Re: ALSA Upgrade Script

    Quote Originally Posted by ratcheer View Post
    I just ran the 1.0.22.1 upgrade script and all steps ran with no apparent problems. However, my ALSA driver is now showing that it is version 1.0.21 (it was previously 1.0.20, so it is a step in the right direction. The other parts do show as version 1.0.22. Do I still need to fix something?


    1. Name your Ubuntu revision - 9.10
    2. Kernel revision - 2.6.31-17-generic
    3. Alsa revision - mixed:
    Driver version: 1.0.21
    Library version: 1.0.22
    Utilities version: 1.0.22
    4. Upgrade script revision - 1.0.22.1
    5. A bit of background what you've done resp. done before -
    Everything was working well until I decided I just had to upgrade ALSA from 1.0.20 to 1.0.22.1. I have not changed anything since running the ALSA upgrade script. I am trying to wait for knowledgeable help.
    Any ideas why the 1.0.22.1 upgrade script updated my system to 1.0.21? The specific script I ran is AlsaUpgrade-1.0.22.1-2.sh

    Thank you.
    Tim

  4. #614
    Join Date
    Jun 2007
    Beans
    11,608

    Re: ALSA Upgrade Script

    ratcheer/Tim, can you try the script again and log the process this time?
    Code:
    sudo script -a -c "./AlsaUpgrade-1.0.22.1-2.sh -d" /tmp/Alsa_1.0.22.1_upgrade.log
    sudo script -a -c "./AlsaUpgrade-1.0.22.1-2.sh -c" /tmp/Alsa_1.0.22.1_upgrade.log
    sudo script -a -c "./AlsaUpgrade-1.0.22.1-2.sh -i" /tmp/Alsa_1.0.22.1_upgrade.log
    Then, attach the log.

  5. #615
    Join Date
    Jun 2009
    Location
    Alabama
    Beans
    2,232

    Thumbs up Re: ALSA Upgrade Script

    Quote Originally Posted by Temüjin View Post
    ratcheer/Tim, can you try the script again and log the process this time?
    Then, attach the log.
    Will do. Be back, later.

    Tim

  6. #616
    Join Date
    Jun 2009
    Location
    Alabama
    Beans
    2,232

    Post Re: ALSA Upgrade Script

    Ok, I have rerun the upgrade script and am attaching a zip file with the logs, including the alsa_info script log.

    Thanks, I appreciate your help.

    Tim
    Attached Files Attached Files

  7. #617
    Join Date
    Jun 2007
    Beans
    11,608

    Re: ALSA Upgrade Script

    I looked through the scripts and everything checks out. After reboot, is cat /proc/asound/version still reporting 1.0.21?

  8. #618
    Join Date
    Jun 2009
    Location
    Alabama
    Beans
    2,232

    Post Re: ALSA Upgrade Script

    Yes. This is after rebooting:

    cat /proc/asound/version
    Advanced Linux Sound Architecture Driver Version 1.0.21.
    Compiled on Dec 11 2009 for kernel 2.6.31-17-generic (SMP).

    Someone said in this thread that he only got his to work by first removing PulseAudio and ALSA, then running the ALSA upgrade script. Do you think I need to try that?

    Tim
    Last edited by ratcheer; January 21st, 2010 at 03:05 AM.

  9. #619
    Join Date
    Jun 2007
    Beans
    11,608

    Re: ALSA Upgrade Script

    I think something might be wrong with the script's installation step, more specifically, with the kernel module(s) location.

  10. #620
    Join Date
    Jun 2009
    Location
    Alabama
    Beans
    2,232

    Re: ALSA Upgrade Script

    Quote Originally Posted by Temüjin View Post
    I think something might be wrong with the script's installation step, more specifically, with the kernel module(s) location.
    Ok, if you can tell me what to fix, I can probably do it. I'm turning in for the evening now, though. Thanks for all your help.

    Tim

Page 62 of 124 FirstFirst ... 1252606162636472112 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •