Page 122 of 124 FirstFirst ... 2272112120121122123124 LastLast
Results 1,211 to 1,220 of 1236

Thread: ALSA Upgrade Script

  1. #1211
    Join Date
    Jan 2011
    Beans
    2
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Cool Re: ALSA Upgrade Script

    Hi
    I'm trying to get sound running on my ALC880 Realtek intergrated chip and I get this during the -c part of the upgrade script

    Excerpt from the last few lines

    /usr/src/Alsa-1.0.23/alsa-driver-1.0.23/include/config1.h:175: warning: "CONFIG_SND_HDA_INPUT_BEEP_MODE" redefined
    ./include/generated/autoconf.h:2222: note: this is the location of the previous definition
    /usr/src/Alsa-1.0.23/alsa-driver-1.0.23/acore/pcm_native.c: In function ‘snd_pcm_hw_params’:
    /usr/src/Alsa-1.0.23/alsa-driver-1.0.23/acore/pcm_native.c:489: error: implicit declaration of function ‘pm_qos_remove_requirement’
    /usr/src/Alsa-1.0.23/alsa-driver-1.0.23/acore/pcm_native.c:492: error: implicit declaration of function ‘pm_qos_add_requirement’
    make[3]: *** [/usr/src/Alsa-1.0.23/alsa-driver-1.0.23/acore/pcm_native.o] Error 1
    make[2]: *** [/usr/src/Alsa-1.0.23/alsa-driver-1.0.23/acore] Error 2
    make[1]: *** [_module_/usr/src/Alsa-1.0.23/alsa-driver-1.0.23] Error 2
    make[1]: Leaving directory `/usr/src/linux-headers-2.6.35-25-generic'
    make: *** [compile] Error 2

    ************************************************** *************************
    * alsa-driver-1.0.23 make failed
    ************************************************** *************************

    I've been looking every where and something is saying about missing Linux kernel headers?
    but... Kernel headers for this particular version of the kernel is listed in Synaptic Package manager as already installed!
    Could you clear this up for a newbie, (And where I might find these missing headers?, This deafining silence is very annoying, and I cannot run anything else until basic drivers are installed)
    Thanks.

  2. #1212
    Join Date
    Jan 2011
    Beans
    1

    Re: ALSA Upgrade Script

    its work, perfect!!!!
    I'm have a sony vaio VPCEB13EB with ubuntu 9.10 kernel 2.6.32-27

  3. #1213
    Join Date
    Jan 2011
    Beans
    2
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: ALSA Upgrade Script

    Never mind
    I found out on the Realtek ALC880 That you needn't panic
    just use the default drivers and only the back panel of jacks
    If THAT doesn't work just use sudo apt-get *alsa* or whatever it is.

  4. #1214
    Join Date
    Mar 2006
    Beans
    Hidden!

    Re: ALSA Upgrade Script

    Quote Originally Posted by d_darlac View Post
    exactly the same problem as wingnux - no sound since installed 10.10 - really frustrating...

    here are the last few lines:
    /usr/src/Alsa-1.0.23/alsa-driver-1.0.23/include/config1.h:175: warning: "CONFIG_SND_HDA_INPUT_BEEP_MODE" redefined
    ./include/generated/autoconf.h:2099: note: this is the location of the previous definition
    /usr/src/Alsa-1.0.23/alsa-driver-1.0.23/acore/pcm_native.c: In function ‘snd_pcm_hw_params’:
    /usr/src/Alsa-1.0.23/alsa-driver-1.0.23/acore/pcm_native.c:489: error: implicit declaration of function ‘pm_qos_remove_requirement’
    /usr/src/Alsa-1.0.23/alsa-driver-1.0.23/acore/pcm_native.c:492: error: implicit declaration of function ‘pm_qos_add_requirement’
    make[3]: *** [/usr/src/Alsa-1.0.23/alsa-driver-1.0.23/acore/pcm_native.o] Error 1
    make[2]: *** [/usr/src/Alsa-1.0.23/alsa-driver-1.0.23/acore] Error 2
    make[1]: *** [_module_/usr/src/Alsa-1.0.23/alsa-driver-1.0.23] Error 2
    make[1]: Leaving directory `/usr/src/linux-headers-2.6.35-24-generic'
    make: *** [compile] Error 2

    ************************************************** *************************
    * alsa-driver-1.0.23 make failed
    Try fetching down the latest alsa driver snapshot, and untar it, rename and replace the one downloaded by the script

    http://www.alsa-project.org/snapshot...g4c406.tar.bz2
    No longer participating......

  5. #1215
    Join Date
    May 2009
    Beans
    15

    Re: ALSA Upgrade Script

    Quote Originally Posted by Jose Catre-Vandis View Post
    Try fetching down the latest alsa driver snapshot, and untar it, rename and replace the one downloaded by the script

    http://www.alsa-project.org/snapshot...g4c406.tar.bz2

    Hi,

    sorry i'm a newbie to linux, could you please kindly show me step by step of how to update alsa driver?

    Thanks in advance!!!

  6. #1216
    Join Date
    Mar 2006
    Beans
    Hidden!

    Re: ALSA Upgrade Script

    Quote Originally Posted by solo16 View Post
    Hi,

    sorry i'm a newbie to linux, could you please kindly show me step by step of how to update alsa driver?

    Thanks in advance!!!

    See post number 1 of this thread!

    Download the script and have a read through.

    However, unless you have a really good reason for doing it, and your sound is working OK, it's not work the aggravation of running the script and then finding it has broken your sound!
    No longer participating......

  7. #1217
    Join Date
    May 2009
    Beans
    15

    Re: ALSA Upgrade Script

    Quote Originally Posted by Jose Catre-Vandis View Post
    See post number 1 of this thread!

    Download the script and have a read through.

    However, unless you have a really good reason for doing it, and your sound is working OK, it's not work the aggravation of running the script and then finding it has broken your sound!
    Ok thanks!!! It seems that the new alsa driver for my soundcard has little changes which i assume it is good for the sound quality.

    Thanks!

  8. #1218
    Join Date
    Jun 2007
    Beans
    10,904

    Re: ALSA Upgrade Script

    I've updated the script and made a new thread because the OP is no longer active on this forum. http://ubuntuforums.org/showthread.php?t=1681577

  9. #1219
    Join Date
    Nov 2007
    Beans
    75

    Re: ALSA Upgrade Script

    Hello, please help me! my sounds are aweful! I get this error when compiling:

    Code:
    /usr/src/Alsa-1.0.23/alsa-driver-1.0.23/acore/pcm_native.c:489: error: implicit declaration of function ‘pm_qos_remove_requirement’
    /usr/src/Alsa-1.0.23/alsa-driver-1.0.23/acore/pcm_native.c:492: error: implicit declaration of function ‘pm_qos_add_requirement’
    make[3]: *** [/usr/src/Alsa-1.0.23/alsa-driver-1.0.23/acore/pcm_native.o] Error 1
    make[2]: *** [/usr/src/Alsa-1.0.23/alsa-driver-1.0.23/acore] Error 2
    make[1]: *** [_module_/usr/src/Alsa-1.0.23/alsa-driver-1.0.23] Error 2
    make[1]: Leaving directory `/usr/src/linux-headers-2.6.35-22-generic'
    make: *** [compile] Error 2
    
    ***************************************************************************
    *  alsa-driver-1.0.23 make failed
    I was following this guide: http://ubuntuforums.org/showthread.php?t=1682650

    Thank you so so much if you could help!

  10. #1220
    Join Date
    Jun 2007
    Beans
    10,904

    Re: ALSA Upgrade Script

    I am in the midst of a psychotic breakdown due to family issues. Sorry,,

Page 122 of 124 FirstFirst ... 2272112120121122123124 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •