Results 1 to 6 of 6

Thread: Keep drive icons off desktop

  1. #1
    Join Date
    Sep 2007
    Beans
    9

    Keep drive icons off desktop

    I'm running Gnome. If a CD/DVD/USB drive is inserted, a big icon for it appears on my formerly pristine desktop. Can I set a preference to have them not appear on the desktop? I still want them to appear in the upper panel.

  2. #2
    Join Date
    Oct 2008
    Location
    England
    Beans
    960
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Keep drive icons off desktop


  3. #3
    Join Date
    Sep 2007
    Beans
    9

    Re: Keep drive icons off desktop

    Nope, that doesn't seem to be how Intrepid works. fstab lists my CD/DVD drives, and I changed them to point to /mnt, but it was ignored, even on reboot. The external USB drives are not even in fstab.

  4. #4
    Join Date
    Apr 2005
    Location
    Finland/UK
    Beans
    Hidden!
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Keep drive icons off desktop

    Press Alt-F2 and run "gconf-editor". Use that to browse to apps/nautilus/desktop and disable the "volumes_visible"-key.

    (editing fstab to mount drives to /mnt is used if you want to keep CD and USB drive icons on desktop, but also have some internal drives that you don't want on your desktop)

  5. #5
    Join Date
    Sep 2007
    Beans
    9

    Smile Re: Keep drive icons off desktop

    Thank you, McDuck! That's exactly what I want. Now my desktop artwork is not defaced (it's currently displaying a work by Dali).

  6. #6
    Join Date
    Mar 2008
    Beans
    1

    Re: Keep drive icons off desktop

    it helped me too... thanx

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •