Results 1 to 10 of 10

Thread: Can not resize remote desktop

  1. #1
    Join Date
    Jan 2009
    Beans
    3

    Can not resize remote desktop

    Greetings to the amazing ubuntu community. I'm very new to Ubuntu (installed it only yesterday) and would like some help with an issue I'm facing. I just made a shortcut on my panel for opening rdesktop (it connects to a Win2k pc that I use at work) but for some reason I can not resize the window. It appears on a 800x600 (or similar low res) window and does not even have the little button with the square for me to make it full screen. What can I do to make it bigger?

  2. #2
    Join Date
    Mar 2007
    Beans
    65
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Can not resize remote desktop

    There are some options in display tab that you can change to get resolution you desire. Before connecting!
    Ubuntu rocks!!Now go ahead thank me
    Lenovo 3000 Y410 Ubuntu Interpid / (never) Vista
    Intel GM965/GL960 | 82801H (ICH8 Family) HDA | Bluetooth Dongle (HCI mode) | Intel PRO/Wireless 3945ABG

  3. #3
    Join Date
    Jan 2009
    Beans
    3

    Re: Can not resize remote desktop

    thanks for the quick reply! Unfortunately, I'm not sure which display tab you're referring to. The way I run it is via a shortcut which has the command 'rdesktop server.name.goeshere'. The only solution that I found was adding the line -f after the command in order to make it full screen. However, I'm not sure how to go back to non-full screen mode if I do it that way.

  4. #4
    Join Date
    Mar 2007
    Beans
    65
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Can not resize remote desktop

    I dont know about shortcut thingy.. sorry, but if you goto menu>internet>terminal services client, Thats how I connect to rdp windows, you get a place to enter info and then customize the connection. the first tab take info about the other terminal, the display tab lets you configure the resolution.

    If you have a shortcut, you better paste it here. (remove personal info)
    Ubuntu rocks!!Now go ahead thank me
    Lenovo 3000 Y410 Ubuntu Interpid / (never) Vista
    Intel GM965/GL960 | 82801H (ICH8 Family) HDA | Bluetooth Dongle (HCI mode) | Intel PRO/Wireless 3945ABG

  5. #5
    Join Date
    Jun 2009
    Beans
    1

    Re: Can not resize remote desktop

    Quote Originally Posted by alextz View Post
    thanks for the quick reply! Unfortunately, I'm not sure which display tab you're referring to. The way I run it is via a shortcut which has the command 'rdesktop server.name.goeshere'. The only solution that I found was adding the line -f after the command in order to make it full screen. However, I'm not sure how to go back to non-full screen mode if I do it that way.
    Hey, so the "-g" option may be what you're looking for, it may be used to define the geometry of the window WRT a percentage of your current window i.e. "-g 90%".

  6. #6
    Join Date
    Jun 2009
    Beans
    100

    Re: Can not resize remote desktop

    In Terminal Services client on Ubuntu, you get out of full screen by pressing Control+Alt+Enter.

    -Kirk

  7. #7
    Join Date
    Jan 2009
    Beans
    3

    Re: Can not resize remote desktop

    I'd like to thank everyone for their replies. meUser's suggestion did the trick for me. The command is now "rdesktop ****.******.** -f -g 70%" and it works perfectly.

    Problem solved.

  8. #8
    Join Date
    Nov 2007
    Beans
    2

    Lightbulb Re: Can not resize remote desktop

    this may help you

    -g 'geometry'
    -f 'full'

    i usually use a line like so:

    'rdesktop -g 1024x860 -u <username> -p '<password>' host.domain

    or as mentioned previously you can use a percentage of your desktop with the -g switch

    rdesktop -f 1024x768

    This will work in statically setting the resolution how you want, Im not aware of any switch that makes the desktop resizable, as well AFAIK you exit full screen mode by leaving that rdp session (logging of rdp|shutting down host from rdp). These parameters are set in the call to rdp so rdp knows how to draw the window.

    Best
    Rain

  9. #9
    Join Date
    Aug 2012
    Beans
    1

    Re: Can not resize remote desktop

    try rdesktop -f IP_addressort

    or

    rdesktop -g1200x700 IP

    from your terminal

    BR
    PSARKAR

  10. #10
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    14,845
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Can not resize remote desktop

    Thread closed. Please do not post in old threads.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •