Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: Jaunty equivalent of pcspkr

  1. #11
    Join Date
    Apr 2005
    Beans
    514

    Re: Jaunty equivalent of pcspkr

    I may sound a little bit drastic, but actually I do think the developer team should disable this annoying beep by default. It makes no sense on any modern desktop machine.

  2. #12
    Join Date
    Sep 2008
    Beans
    119

    Re: Jaunty equivalent of pcspkr

    Well that probably won't work much better then.
    Is there anything interesting in ~/.xsession-errors?
    Maybe there is a path problem and
    Code:
    /usr/bin/xset b off && /usr/bin/xset b 0 0 0
    helps.

    Another place to put it in would be ~/.profile.
    Try appending
    Code:
    /usr/bin/xset b off
    /usr/bin/xset b 0 0 0
    there and logout and in again.

  3. #13
    Join Date
    Apr 2005
    Beans
    Hidden!

    Re: Jaunty equivalent of pcspkr

    There is another possibility: unplug speaker's wires from motherboard

  4. #14
    Join Date
    Feb 2007
    Beans
    766
    Distro
    Ubuntu Development Release

    Re: Jaunty equivalent of pcspkr

    Quote Originally Posted by marmuta View Post
    Well that probably won't work much better then.
    Is there anything interesting in ~/.xsession-errors?
    Maybe there is a path problem and
    Code:
    /usr/bin/xset b off && /usr/bin/xset b 0 0 0
    helps.

    Another place to put it in would be ~/.profile.
    Try appending
    Code:
    /usr/bin/xset b off
    /usr/bin/xset b 0 0 0
    there and logout and in again.
    Good call.

    This is in my .xsession -errors (along with a lot of other stuff)
    xset: unknown option &&

    usage: xset [-display host:dpy] option ...
    To turn bell off:
    -b b off b 0
    To set bell volume, pitch and duration:
    b [vol [pitch [dur]]] b on

    I'll try these as well as the option to edit .profile and get back to you all.
    To err is human, but not uniquely so.

  5. #15
    Join Date
    Sep 2008
    Beans
    119

    Re: Jaunty equivalent of pcspkr

    Quote Originally Posted by ubername View Post
    Good call.

    This is in my .xsession -errors (along with a lot of other stuff)
    xset: unknown option &&
    Ha! This should do it then
    Code:
    sh -c "xset b off && xset b 0 0 0"

  6. #16
    Join Date
    Feb 2007
    Beans
    766
    Distro
    Ubuntu Development Release

    Re: Jaunty equivalent of pcspkr

    Quote Originally Posted by marmuta View Post
    Ha! This should do it then
    Code:
    sh -c "xset b off && xset b 0 0 0"
    Many Thanks, job done! (Where's the thanks button gone?! see my other threads!)
    To err is human, but not uniquely so.

  7. #17
    Join Date
    Mar 2007
    Location
    Hempstead, NY
    Beans
    1,694
    Distro
    Ubuntu Development Release

    Re: Jaunty equivalent of pcspkr

    Quote Originally Posted by zolookas View Post
    There is another possibility: unplug speaker's wires from motherboard
    that's a pretty tall order for a laptop owner.

  8. #18
    Join Date
    Feb 2007
    Beans
    32

    Re: Jaunty equivalent of pcspkr

    Sorry to all, but I want to ENABLE the real pc solid speaker on my desktop (not the emulated one in volume control through the sound system).
    The old fashioned solid pc speaker is muted in jaunty.
    How to enable it again?

    I have tried to un-blacklist all the mentioned hints in this thread but nothing helps.

    lsmod|grep spkr
    returns:
    pcspkr 10496 0

    Thanks in advance
    Last edited by m2.g5ru6y7s; April 23rd, 2009 at 01:07 PM. Reason: spell check

  9. #19
    Join Date
    Feb 2007
    Beans
    32

    Re: Jaunty equivalent of pcspkr

    Never mind. I just read that the pc speaker is disabled by default in the Linux kernel.
    http://howto.wikia.com/wiki/Howto_en...e_Linux_kernel

    By default the PC speaker is disabled in the Linux kernel. So you must enable it and recompile you kernel.

    Very lame to recompile the kernel for just to enable a simple speaker
    Bah
    Last edited by m2.g5ru6y7s; April 23rd, 2009 at 02:22 PM. Reason: spelling

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •