Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Restart required for webcam to work; how to manually restart?

  1. #1
    Join Date
    Oct 2008
    Location
    Massachusetts
    Beans
    20
    Distro
    Ubuntu 8.04 Hardy Heron

    Restart required for webcam to work; how to manually restart?

    After some ubuntu update recently, my webcam has stopped working with Skype after my computer has been on for a while. It still works if I restart my computer, then open skype and try to use it, but it has yet to work hours after that (perhaps because I am hibernating in between, not sure).

    It appears that what is happening is that the camera is "busy" but that is just my impression.

    Is there any way to "restart" the webcam via a terminal command while the computer is on? Or alternatively, does anyone know what could be happening with the camera not starting?

  2. #2
    Join Date
    Jun 2008
    Location
    Maryland USA
    Beans
    79
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Restart required for webcam to work; how to manually restart?

    you might try using lshw to figure out which module is running it, then use modprobe -r to unload that, and plain ol' modprobe to reload the module. But i actually have no idea how webcams work (i.e., whether there is a module associated with it).

  3. #3
    Join Date
    Jun 2007
    Location
    Perth - OZ
    Beans
    98
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Restart required for webcam to work; how to manually restart?

    got the same problem here on a DELL inspiron 1525, sometimes, only sometimes, the camera does not work and I have to restart ubuntu to make it work again with skype or cheese...

    so BUMP!
    Ubuntu 64 bit

  4. #4
    Join Date
    Jun 2008
    Beans
    18

    Re: Restart required for webcam to work; how to manually restart?

    I think I have the same problem. The cam used to work but doesn't any anymore (I haven't reboot yet).
    From the kern.log:

    /var/log/kern.log:Jun 13 15:20:31 patricio-laptop kernel: [29606.529587] uvcvideo 2-4:1.1: resume error -5
    /var/log/kern.log:Jun 13 15:26:01 patricio-laptop kernel: [29937.049414] uvcvideo: Failed to query (135) UVC control 2 (unit 3) : -71 (exp. 2).
    /var/log/kern.log:Jun 13 15:32:04 patricio-laptop kernel: [30300.054961] uvcvideo: Failed to query (135) UVC control 2 (unit 3) : -71 (exp. 2).

    lsusb
    Bus 002 Device 002: ID 04f2:b015 Chicony Electronics Co., Ltd VGA 24fps UVC Webcam

  5. #5
    Join Date
    Jun 2008
    Beans
    18

    Re: Restart required for webcam to work; how to manually restart?

    I restarted and the cam works now... it would be great to know how to restart from terminal.

  6. #6
    Join Date
    May 2008
    Beans
    3

    Re: Restart required for webcam to work; how to manually restart?

    Same problem here, with hp dv2600, after suspend, about half the time I get the "uvcvideo resume error 1-4 1:1 -5". Camera is listed by lsusb as "ID 04f2:b016 Chicony Electronics Co., Ltd". Works after restart. That's with ubuntu 9.04 64_bit
    Last edited by piiotr; June 15th, 2009 at 01:33 AM.

  7. #7
    Join Date
    Jun 2008
    Beans
    18

    Re: Restart required for webcam to work; how to manually restart?


  8. #8
    Join Date
    Jun 2009
    Location
    Sydney
    Beans
    1
    Distro
    Kubuntu 9.04 Jaunty Jackalope

    Re: Restart required for webcam to work; how to manually restart?

    Two possibilities to solve your problem:

    In a terminal, try this command:

    sudo modprobe uvcvideo


    If you don't want to use this command everytime, you can modify the file modules in the repository /etc by typing in a terminal:

    sudo gedit /etc/modules

    and add the line uvcvideo at the end of the file. This modification will force the system to load the module uvcvideo even if no webcam is detected at the boot.

    See you.

    Seb

  9. #9
    Join Date
    Aug 2009
    Beans
    2
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Restart required for webcam to work; how to manually restart?

    I have the same problem with a Logitech webcam. Worked fine initially for couple months, then reboot seemed to fix it lately, however that has seemed to stop working as well- have rebooted 3 or 4 times now. I've tried the modprobe uvcvideo command also.

  10. #10
    Join Date
    Aug 2009
    Beans
    2
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Restart required for webcam to work; how to manually restart?

    I just tried a new install of Jaunty and it works...

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •