Page 4 of 35 FirstFirst ... 2345614 ... LastLast
Results 31 to 40 of 344

Thread: mythbuntu-repos, mythtv-updates, mythbuntu-updates - Questions or Issues

  1. #31
    Join Date
    Oct 2007
    Location
    Sweden
    Beans
    205
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Weekly Builds for Hardy, Intrepid, Jaunty

    Quote Originally Posted by superm1 View Post
    <shrug>

    OK, well the build problems were sorted out, that's why these suddenly showed up.

    Try this:

    Code:
    apt-get -f install
    If that doesn't do the trick, can you modify /var/lib/dpkg/info/mythtv-backend.postinst

    and add a
    Code:
    set -x
    Near the top (but after #!/bin/sh)

    Try an apt-get -f install again after you make that change. Please post the output here so we can debug it and get that fixed.
    Did not work. (edit: solution after the paste)

    root@mythtv:/home/niklas# LC_ALL=C apt-get -f install
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
    python-xml libgeoip1
    Use 'apt-get autoremove' to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
    3 not fully installed or removed.
    After this operation, 0B of additional disk space will be used.
    Setting up mythtv-backend (0.21.0+fixes20205-0ubuntu0+mythbuntu1) ...
    + [ ! -e /dev/.devfsd ]
    + . /usr/share/debconf/confmodule
    + [ ! ]
    + PERL_DL_NONLAZY=1
    + export PERL_DL_NONLAZY
    + [ ]
    + exec /usr/share/debconf/frontend /var/lib/dpkg/info/mythtv-backend.postinst co nfigure 0.21.0+fixes19878-0ubuntu0+mythbuntu1
    + [ ! -e /dev/.devfsd ]
    + . /usr/share/debconf/confmodule
    + [ ! 1 ]
    + [ -z ]
    + exec
    + [ ]
    + exec
    + DEBCONF_REDIR=1
    + export DEBCONF_REDIR
    + db_get mythtv/create_v4l_devs
    + _db_cmd GET mythtv/create_v4l_devs
    + IFS= printf %s\n GET mythtv/create_v4l_devs
    + IFS=
    read -r _db_internal_line
    + RET=true
    + return 0
    + [ true = true ]
    + cd /dev
    + MAKEDEV v4l
    udev active, devices will be created in /dev/.static/dev/
    + [ -d /var/log/mythtv ]
    + dpkg-statoverride --list /var/log/mythtv
    + chown mythtv:mythtv /var/log/mythtv
    + chmod 2775 /var/log/mythtv
    + [ -d /var/lib/mythtv/recordings ]
    + dpkg-statoverride --list /var/lib/mythtv/recordings
    + chown mythtv:mythtv /var/lib/mythtv/recordings
    + chmod 2775 /var/lib/mythtv/recordings
    + [ -d /var/cache/mythtv ]
    + dpkg-statoverride --list /var/cache/mythtv
    + chown mythtv:mythtv /var/cache/mythtv
    + chmod 2775 /var/cache/mythtv
    + [ -z 0.21.0+fixes19878-0ubuntu0+mythbuntu1 ]
    + [ -x /etc/init.d/mythtv-backend ]
    + update-rc.d mythtv-backend defaults 24 16
    + which invoke-rc.d
    + [ -x /usr/sbin/invoke-rc.d ]
    + invoke-rc.d mythtv-backend start
    * MythTV server already started; use restart instead.
    invoke-rc.d: initscript mythtv-backend, action "start" failed.
    + exit 1
    dpkg: error processing mythtv-backend (--configure):
    subprocess post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of mythtv:
    mythtv depends on mythtv-backend (= 0.21.0+fixes20205-0ubuntu0+mythbuntu1); how ever:
    Package mythtv-backend is not configured yet.
    dpkg: error processing mythtv (--configure):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of mythtv-backend-master:
    mythtv-backend-master depends on mythtv-backend (= 0.21.0+fixes20205-0ubuntu0+m ythbuntu1); however:
    Package mythtv-backend is not configured yet.
    dpkg: error processing mythtv-backend-master (--configure):
    dependency problems - leaving unconfigured
    Errors were encountered while processing:
    mythtv-backend
    mythtv
    mythtv-backend-master
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    root@mythtv:/home/niklas#
    Edit:
    I had to kill mythtv-backend myself. Worked just fine after that!


    Great work btw!
    Last edited by Nikas; March 13th, 2009 at 06:49 PM.

  2. #32
    Join Date
    Oct 2005
    Location
    Austin, TX
    Beans
    2,983
    Distro
    Ubuntu Development Release

    Re: Weekly Builds for Hardy, Intrepid, Jaunty

    Quote Originally Posted by Nikas View Post
    Did not work. (edit: solution after the paste)



    Edit:
    I had to kill mythtv-backend myself. Worked just fine after that!


    Great work btw!
    OK, well you still might have unearthed a bug here if the postinst can't run with mythtv-backend running. Can you please file a bug on:

    https://bugs.launchpad.net/ubuntu/+source/mythtv

    so that we can track this and it doesn't get forgotten?

  3. #33
    Join Date
    Feb 2008
    Beans
    606
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Weekly Builds for Hardy, Intrepid, Jaunty

    Same problem here, and shutting down the backend and then running apt-get -f install resolved it.

    However, I still got a whole load of errors from rm, mknod and makedev complaining about a read-only file system:


    Setting up mythtv-backend (0.21.0+fixes20205-0ubuntu0+mythbuntu2) ...
    udev active, devices will be created in /dev/.static/dev/
    rm: cannot remove `video0-': Read-only file system
    mknod: `video0-': Read-only file system
    makedev video0 c 81 0 root video 0660: failed
    rm: cannot remove `video0-': Read-only file system
    rm: cannot remove `radio0-': Read-only file system
    mknod: `radio0-': Read-only file system
    makedev radio0 c 81 64 root video 0660: failed

    (etc)

    I tried going to /dev/.static/dev and creating a file there, and it is indeed a read-only file system.

  4. #34
    Join Date
    Mar 2008
    Beans
    10

    Re: Weekly Builds for Hardy, Intrepid, Jaunty

    I've been getting tons of those "read-only file system" errors when updating mythtv-backend for months now. I'm running 8.10, but all of my systems are upgrades from 8.04 (if that matters). I have been ignoring it though because it doesn't seem to affect anything.

  5. #35
    Join Date
    Feb 2008
    Beans
    606
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Weekly Builds for Hardy, Intrepid, Jaunty

    Quote Originally Posted by syphr42 View Post
    I'm running 8.10, but all of my systems are upgrades from 8.04 (if that matters).
    Mine was a fresh 8.10 install a couple of months ago.

  6. #36
    Join Date
    Feb 2008
    Beans
    207

    Re: Weekly Builds for Hardy, Intrepid, Jaunty

    Quote Originally Posted by superm1 View Post

    Try an apt-get -f install again after you make that change. Please post the output here so we can debug it and get that fixed.
    Hi

    The issue is with what's automatically added to mythtv-backend.postinst by dh_install

    # Automatically added by dh_installinit
    if [ -x "/etc/init.d/mythtv-backend" ]; then
    update-rc.d mythtv-backend defaults 24 16 >/dev/null
    if [ -x "`which invoke-rc.d 2>/dev/null`" ]; then
    invoke-rc.d mythtv-backend start || exit $?
    else
    /etc/init.d/mythtv-backend start || exit $?
    fi
    fi

    the mythtv-backend startup script does an exit 1 when started and the mythbackend daemon has already been started.

    It would need to be a "restart" there instead of a "start"

    The work-around right now is to do /etc/init.d/mythtv-backend stop before running apt or synaptic

    In debian/rules, dh_installinit -a -r -- defaults 24 16, should be changed to:
    dh_installinit -a -R -- defaults 24 16

    so it will restart mythbackend rather than simply start it.
    Jean-Yves
    Last edited by jyavenard; March 16th, 2009 at 12:24 PM.

  7. #37
    Join Date
    May 2008
    Beans
    8

    Re: Weekly Builds for Hardy, Intrepid, Jaunty

    Quote Originally Posted by movieman View Post
    I tried going to /dev/.static/dev and creating a file there, and it is indeed a read-only file system.
    Try doing this before you upgrade:

    mount -o remount,rw /dev/.static/dev /dev/.static/dev/

    You need to specify it like that because it's not in fstab.

  8. #38
    Join Date
    Jan 2007
    Beans
    3

    Re: Weekly Builds for Hardy, Intrepid, Jaunty

    I can't seem to get this working.

    I've tried to stop the Backend with
    sudo /etc/init.d/mythtv-backend stop

    ~$ sudo LC_ALL=C apt-get -f install
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    2 not fully installed or removed.
    After this operation, 0B of additional disk space will be used.
    Setting up mythtv-backend (0.21.0+fixes20205-0ubuntu0+mythbuntu1) ...
    dpkg (subprocess): unable to execute post-installation script: Exec format error
    dpkg: error processing mythtv-backend (--configure):
    subprocess post-installation script returned error exit status 2
    dpkg: dependency problems prevent configuration of mythtv-backend-master:
    mythtv-backend-master depends on mythtv-backend (= 0.21.0+fixes20205-0ubuntu0+mythbuntu1); however:
    Package mythtv-backend is not configured yet.
    dpkg: error processing mythtv-backend-master (--configure):
    dependency problems - leaving unconfigured
    Errors were encountered while processing:
    mythtv-backend
    mythtv-backend-master
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    I've tried $ sudo gedit /var/lib/dpkg/info/mythtv-backend.postinst
    and adding set -x (As below)

    #!/bin/sh

    set -x

    case "$1" in
    configure)
    if [ ! -e /dev/.devfsd ]; then
    . /usr/share/debconf

    Still the same error message.
    Can anyone give me some advice.

  9. #39
    Join Date
    Feb 2008
    Beans
    207

    Re: Weekly Builds for Hardy, Intrepid, Jaunty

    Quote Originally Posted by dazzed and confussed View Post
    dpkg (subprocess): unable to execute post-installation script: Exec format error
    You've screwed up something here ; like installing a package for the wrong architecture.

    I would uninstall the package completely and install it again .

    Make sure mythtbackend isn't running in the mean time

  10. #40
    Join Date
    Feb 2008
    Beans
    606
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Weekly Builds for Hardy, Intrepid, Jaunty

    While I was updating today, I noticed an error message about an invalid mysql admin password; any idea where the installer is getting that password from, so I can figure out what's wrong?

Page 4 of 35 FirstFirst ... 2345614 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •