Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: XSane with Epson Workforce 600 through LAN

  1. #1
    Join Date
    Aug 2007
    Location
    Earth Bound Misfit
    Beans
    29
    Distro
    Ubuntu 10.04 Lucid Lynx

    XSane with Epson Workforce 600 through LAN

    I am using Ubuntu 8.04 Hardy Heron and I have an Epson Workforce 600 connected via LAN (Full Duplex) and I am not able to find the scanner with XSane. I have noted that the network connection is not supported, nevertheless, I have followed the manual configuration steps with no luck.

    As a side note I do know that the Workforce is installed properly for I am able to use it completely within my VirtualBox Xp Install. I am also able to print to the device from within Ubuntu with no problems as well as other XP machines from various locations within my home.

    I have 2 questions:

    1) Has anybody had success in getting this Epson All-In-one working with XSane via the network connection? If so, can you guide me to how you have accomplished this?

    2) Is there another application that will work with the scanner via network? If so, what is the name and where can I acquire a installation command for it?

    I have searched for 3rd party application and found one that only supports the USB connection. I would like to use the LAN connection since this is a home office application that requires several PCs to print to it as well as scan.

    Thanks in advance for your help and please let me know if you require any further information.
    If someone asks you to sudo rm -rf anything, don't do it, and don't run any command with rm in it unless you know exactly what you're doing!
    Click here to read more
    Another happy Ubuntu user since 7.10 Gutsy Gibbon.

  2. #2
    Join Date
    May 2008
    Beans
    39

    Re: XSane with Epson Workforce 600 through LAN

    I am thinking about buying one of these, but I need to have scanning working...
    I found this information, which may or may not help you...
    But the XSane site says:
    WorkForce 600 USB 0x04b8/0x0847 good network interface not supported<br>all-in-one
    If you get it working, please let me know, as I will buy one...

    Thanks!
    Last edited by xefialtis; January 6th, 2009 at 11:08 PM.

  3. #3
    Join Date
    Aug 2007
    Location
    Earth Bound Misfit
    Beans
    29
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: XSane with Epson Workforce 600 through LAN

    Quote Originally Posted by xefialtis View Post
    I am thinking about buying one of these, but I need to have scanning working...
    I found this information, which may or may not help you...
    I have downloaded this and gave it a try - still no scanning via network - but the printer seems to like this driver a lot better - so I will keep using it!


    Quote Originally Posted by xefialtis View Post
    But the XSane site says:
    I saw that too. Perhaps in the future it will? I have the XSane site bookmarked so I will keep an eye on it. I might even consider being a beta tester!


    Quote Originally Posted by xefialtis View Post
    If you get it working, please let me know, as I will buy one...
    If you plan on using it via the USB connection everything (including scanning) works great! But alas I have it in a location that will require a very, very long USB cable, or I could run a cat5 cable to it from my network switch- But since it has WiFI built in it is more economical!

    Also worth noting if you are going to use any Window$ machines with it just install the software from the CD and your done - Ubuntu on the other hand not so easy...

    Quote Originally Posted by xefialtis View Post
    Thanks!
    No, Thank You! I have searched all over the place for a alternative for XSane and I never found iscan. Pretty cool utility!

    I will keep this posting updated of any fixes or other useful information for anyone interested.

    I must confess that this Epson is a pretty sweet machine! Just need to figure out the scanning in Ubuntu so I can use it without Window$
    If someone asks you to sudo rm -rf anything, don't do it, and don't run any command with rm in it unless you know exactly what you're doing!
    Click here to read more
    Another happy Ubuntu user since 7.10 Gutsy Gibbon.

  4. #4
    Join Date
    May 2006
    Beans
    61

    Re: XSane with Epson Workforce 600 through LAN

    Quote Originally Posted by olivero1 View Post
    If you plan on using it via the USB connection everything (including scanning) works great!
    Is that so?

    No luck with either 8.04 or 8.10 at my end, using xsane.

    What version of ubuntu are you using? What scanning software are you using?

  5. #5
    Join Date
    Aug 2007
    Location
    Earth Bound Misfit
    Beans
    29
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: XSane with Epson Workforce 600 through LAN

    I am using Ubuntu 8.04 (Hardy Heron) with the latest xsane installed.

    But I have also used a driver from OpenPrinting.

    Here is the link to the site that has the directions to install the driver in Ubuntu. I have linked this paragraph so that you can verify the code.


    Add the line to your /etc/apt/sources.list file

    And then run

    Code:
    sudo apt-get update
    Once you do this go into your printer configuration and add a new printer - it should find the following driver:

    Epson WorkForce 600 - CUPS+Gutenprint (OpenPrinting LSB 3.2) v5.2.2

    That should do it.

    If you have any questions let me know - if I do not know the answer I will help you find one

    BTW - I have never really posted codes before so I am not sure if I have done this properly (that is why I have included the link to the directions).

    Hope this helps!
    If someone asks you to sudo rm -rf anything, don't do it, and don't run any command with rm in it unless you know exactly what you're doing!
    Click here to read more
    Another happy Ubuntu user since 7.10 Gutsy Gibbon.

  6. #6
    Join Date
    Oct 2005
    Location
    NRW-D
    Beans
    361
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: XSane with Epson Workforce 600 through LAN

    Just wanted to let you know I'm trying to get a BX600FW (basically the same as a Workforce 600) to scan via the network (see thread). So far, no good.

    Wish it was Christmas...
    Linux #416781 - Ubuntu #9075
    “The reasonable man adapts himself to the world; the unreasonable one persists in trying to adapt the world to himself. Therefore all progress depends on the unreasonable man.” ―George Bernard Shaw

  7. #7
    Join Date
    Oct 2005
    Location
    NRW-D
    Beans
    361
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: XSane with Epson Workforce 600 through LAN

    Found some more info in the following thread: here

    But somehow, I can't get it working...

    Help would be greatly appreciated
    Last edited by robenroute; March 8th, 2009 at 07:39 PM.
    Linux #416781 - Ubuntu #9075
    “The reasonable man adapts himself to the world; the unreasonable one persists in trying to adapt the world to himself. Therefore all progress depends on the unreasonable man.” ―George Bernard Shaw

  8. #8
    Join Date
    Aug 2007
    Location
    Earth Bound Misfit
    Beans
    29
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: XSane with Epson Workforce 600 through LAN

    Quote Originally Posted by robenroute View Post
    Found some more info in the following thread: here

    But somehow, I can't get it working...

    Help would be greatly appreciated
    I will see if I can find some time and look into that. Be patient it may be a week before I can get to it.

    Also - the link you provided above had the extra http:/ in the address.
    http://ubuntuforums.org/showthread.php?t=199147 is the correct address based on your link - is it the right one? It is talking about SQL.

    If so, i may have retyped it wrong.

    I have opted to hook up the printer wireless and have a XP machine setup for scanning. So I am very interested in getting Ubuntu scanning - but as I mentioned before I have a lot on my plate right now and as soon as I get some time I will start looking into what you have found.

    If you happen to find anything else please post it here and I will look into it.

    BTW - I know networking and so I can most likely figure it out.

    Thanks for posting!
    If someone asks you to sudo rm -rf anything, don't do it, and don't run any command with rm in it unless you know exactly what you're doing!
    Click here to read more
    Another happy Ubuntu user since 7.10 Gutsy Gibbon.

  9. #9
    Join Date
    Oct 2005
    Location
    NRW-D
    Beans
    361
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: XSane with Epson Workforce 600 through LAN

    Hi there Olivero1,

    Sorry for the typo, I've corrected it. I have found a few more web pages with additional information. I will collect the urls and post them here.

    Thanks for your efforts.
    Linux #416781 - Ubuntu #9075
    “The reasonable man adapts himself to the world; the unreasonable one persists in trying to adapt the world to himself. Therefore all progress depends on the unreasonable man.” ―George Bernard Shaw

  10. #10
    Join Date
    Oct 2005
    Location
    NRW-D
    Beans
    361
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: XSane with Epson Workforce 600 through LAN

    Hi Olivero,

    I found these pages (mind you, the first one is a google translation from German into English). I have no problems reading German, so if you need help, don't hesitate.

    http://translate.google.com/translat...fficejet-6310/

    http://ubuntuforums.org/showthread.p...light=sane-net

    Regards,
    Rob
    Last edited by robenroute; March 12th, 2009 at 06:15 PM. Reason: typo
    Linux #416781 - Ubuntu #9075
    “The reasonable man adapts himself to the world; the unreasonable one persists in trying to adapt the world to himself. Therefore all progress depends on the unreasonable man.” ―George Bernard Shaw

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •