Results 1 to 9 of 9

Thread: Totem not playing nicely with PulseAudio

  1. #1
    Join Date
    Jun 2008
    Location
    Ballard
    Beans
    2,317
    Distro
    Ubuntu 10.04 Lucid Lynx

    Totem not playing nicely with PulseAudio

    I have gone through the PA fix-yer-problems page:

    http://ubuntuforums.org/showthread.php?t=789578

    Everything seems to be working well with one exception. For instance, I am able to hear a ring and connect in Skype while listening to Amarok. Also, I can open and use Amarok if I am already on a call in Skype.

    However, if I am listening to Totem Skype cannot ring and it is not possible to connect a call (audio error).

    I suspect that I merely need to point Totem at PA, but I was not able to find anywhere in the application to accomplish that.

    Anybody know how to fix this?

  2. #2
    Join Date
    Jun 2008
    Location
    Ballard
    Beans
    2,317
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Totem not playing nicely with PulseAudio

    Anybody?

  3. #3
    Join Date
    May 2008
    Beans
    2,525

    Re: Totem not playing nicely with PulseAudio

    I believe skype uses OSS check the first link I saw skype there quite a bit.

    Here are a few options to choose from from fixing pulse to disabling it and using asla, or replacing pulse with esound.

    First fixing pulse (there are fixes in this thread for skype)
    http://ubuntuforums.org/showthread.php?p=4928900

    Disabling pulse and using alsa (Before deciding to remove pulse you should read the warning here as to what the result could be).
    http://forumubuntusoftware.info/view...st=0&sk=t&sd=a
    and another one going the same route here
    http://ubuntuforums.org/showthread.p...02#post6370902

    Replacing pulse with esound
    http://ubuntuforums.org/showthread.php?t=885437
    A short version here. I suspect it will be modified.
    http://ubuntuextreme.blogspot.com/20...epid-ibex.html

    There are more but this gives you some fixes that are being used.

    Ultimate Edition Links

  4. #4
    Join Date
    Jun 2008
    Location
    Ballard
    Beans
    2,317
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Totem not playing nicely with PulseAudio

    The page I linked to in my original post does a great job of explaining how to get PA set up correctly. It is working great. So is Skype.

    I really believe the problem is that Totem (Movie Player) is not pointing at PA, so Totem is not able to use audio while another application is using it.

    I'm hoping to find out where Totem keeps its preferred audio settings.

  5. #5
    Join Date
    Jun 2008
    Location
    Ballard
    Beans
    2,317
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Totem not playing nicely with PulseAudio

    A little help here?

  6. #6
    Join Date
    Jun 2008
    Location
    Ballard
    Beans
    2,317
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Totem not playing nicely with PulseAudio

    Please?

  7. #7
    Join Date
    Jun 2008
    Location
    Ballard
    Beans
    2,317
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Totem not playing nicely with PulseAudio

    Bueller?

  8. #8
    Join Date
    Sep 2007
    Location
    Belo Horizonte/Brazil
    Beans
    573
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Totem not playing nicely with PulseAudio

    I'm not familiar with Totem's inner workings, but I too followed that same guide you linked to and MPlayer works great for me. Try using it instead to play your videos. It's a better app anyways, IMHO.

  9. #9
    Join Date
    Jun 2008
    Location
    Ballard
    Beans
    2,317
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Totem not playing nicely with PulseAudio

    Thanks, but in a totally unrelated excursion into folly I have really hosed my system. Not sure how as yet. I have made a post here on a related thread:

    http://ubuntuforums.org/showthread.php?p=6490548

    I'm not clear where to go from here, but I know I cannot fix the Totem thing until I resolve this other issue.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •