Page 3 of 3 FirstFirst 123
Results 21 to 28 of 28

Thread: [SOLVED] Problem with atheros wifi AR242x in 8.10

  1. #21
    Join Date
    Feb 2009
    Beans
    6

    Re: Problem with atheros wifi AR242x in 8.10

    It totally worked for me and my LG E500 with am atheros 5007eg with the ar2425 chipset. I disabled the original driver thru system>administration>hardware drivers, rebooted the system, then i followed your instructions with the sudo.... thing, rebooted and it worked. i can't get it to connect (something about the password), but it's a great leap forward. Thanx so much luk911!

  2. #22
    Join Date
    Oct 2004
    Beans
    49

    Re: Problem with atheros wifi AR242x in 8.10

    Thanks, this also solved my problem with an Acer eMachines D620-261G16Mi.

  3. #23
    Join Date
    Feb 2009
    Location
    Natchitoches, Louisiana
    Beans
    9
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Problem with atheros wifi AR242x in 8.10

    VOILA! Luks911 was on the money. I've spent hours on this and his solution did the trick. Many thanks! I usually have difficulty wading through forums for solutions. Got lucky this time.
    Last edited by drjimm; February 17th, 2009 at 05:50 PM.

  4. #24
    Join Date
    Dec 2008
    Beans
    27

    Re: [SOLVED] Problem with atheros wifi AR242x in 8.10

    Ok, with Ubuntu 8.10, I,ve got a new Acer Aspire 5515 with this seemingly very difficult wifi card, AR242X. I've tried everything in these posts with no results for wifi. WICD is loaded and works with hard wire but no wifi. Drivers checked show that the card is using the driver 5xxxx for AR242X. The origional driver was deactivated. My other notebook shows a wifi station present but this one can't see it.
    iwconfig shows:
    mashid@ubuntu:~$ iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    wmaster0 no wireless extensions.

    wlan1 IEEE 802.11bg ESSID:""
    Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
    Tx-Power=0 dBm
    Retry min limit:7 RTS thrff Fragment thr=2352 B
    Power Managementff
    Link Quality:0 Signal level:0 Noise level:0
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    pan0 no wireless extensions.
    What should I do next?
    Thanks, <> Jim

  5. #25
    Join Date
    Apr 2008
    Location
    Buenos Aires y cercanías
    Beans
    539
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: [SOLVED] Problem with atheros wifi AR242x in 8.10

    Quote Originally Posted by diamondjim08 View Post
    Ok, with Ubuntu 8.10, I,ve got a new Acer Aspire 5515 with this seemingly very difficult wifi card, AR242X. I've tried everything in these posts with no results for wifi. WICD is loaded and works with hard wire but no wifi. Drivers checked show that the card is using the driver 5xxxx for AR242X. The origional driver was deactivated. My other notebook shows a wifi station present but this one can't see it.
    iwconfig shows:
    mashid@ubuntu:~$ iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    wmaster0 no wireless extensions.

    wlan1 IEEE 802.11bg ESSID:""
    Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
    Tx-Power=0 dBm
    Retry min limit:7 RTS thrff Fragment thr=2352 B
    Power Managementff
    Link Quality:0 Signal level:0 Noise level:0
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    pan0 no wireless extensions.
    What should I do next?
    Thanks, <> Jim
    You could try with madwifi instead of ath5k. To download, compile and install the madwifi, follow the instructions below, one line each time in a terminal (you can copy and paste).

    Code:
    echo "blacklist ath_hal" | sudo tee -a /etc/modprobe.d/blacklist
    echo "blacklist ath5k" | sudo tee -a /etc/modprobe.d/blacklist
    sudo apt-get update && sudo aptitude install build-essential gcc binutils autoconf automake linux-headers-$(uname -r)
    wget http://snapshots.madwifi-project.org/madwifi-hal-0.10.5.6/madwifi-hal-0.10.5.6-r3942-20090205.tar.gz
    tar xzf madwifi-hal-0.10.5.6-r3942-20090205.tar.gz
    cd madwifi-hal-0.10.5.6-r3942-20090205.tar.gz
    make
    sudo make install
    sudo modprobe -a ath_pci wlan_scan_sta
    sudo ifconfig ath0 up
    echo "ath_pci" | sudo tee -a /etc/modules
    All these put the ath5k driver in the blacklist, install all the tools that you need to compile, download de madwifi driver, compile and install it, then load the module and do the changes to load in every startup.
    After each kernel update, you will have to repeat this steps:
    Code:
    cd madwifi-hal-0.10.5.6-r3942-20090205.tar.gz
    make
    sudo make install
    sudo modprobe -a ath_pci wlan_scan_sta
    I hope it helps you.

  6. #26
    Join Date
    Oct 2007
    Location
    Ontario, Canada
    Beans
    77
    Distro
    Xubuntu 10.04 Lucid Lynx

    Re: [SOLVED] Problem with atheros wifi AR242x in 8.10

    Thank You Very Much

    This worked when the 8.10 upgrade killed my ndiswrapper setup in xubuntu
    Xubuntu 10.04

  7. #27
    Join Date
    Mar 2009
    Location
    Behind You
    Beans
    160
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Problem with atheros wifi AR242x in 8.10

    Quote Originally Posted by luks911 View Post
    The drivers that work are the last madwifi version[0] (before compile and install it you have to disable the ath_pci you are using from System > Administration > Restricted Drivers Manager) or, more simple, the ath5k driver. To use ath5k install linux-backports-modules-intrepid
    Code:
    sudo aptitude install linux-backports-modules-intrepid
    and then you can enable it in System > Administration > Restricted Drivers Manager, where you will saw a driver for Atheros 5xxx.

    [0] http://snapshots.madwifi-project.org...0081204.tar.gz
    Great tips luks. I installed the backport modules as you instructed and my wifi works great. The problem is, when the modules were installing, I think it overwrote my nvidia graphics kernel and im now running on low graphics setting. I tried reinstalling the drivers but didn't work... Please guide me if you can! Thanks a bunch!
    Slow Ubuntu compared to Windows or Mac OSX, despite all the tweaking? You might have an NVidia graphics card. Read this post.
    Tweak your Ubuntu!

  8. #28
    Join Date
    Jul 2007
    Beans
    190

    Re: [SOLVED] Problem with atheros wifi AR242x in 8.10

    Quote Originally Posted by luks911 View Post
    You could try with madwifi instead of ath5k. To download, compile and install the madwifi, follow the instructions below, one line each time in a terminal (you can copy and paste).

    Code:
    echo "blacklist ath_hal" | sudo tee -a /etc/modprobe.d/blacklist
    echo "blacklist ath5k" | sudo tee -a /etc/modprobe.d/blacklist
    sudo apt-get update && sudo aptitude install build-essential gcc binutils autoconf automake linux-headers-$(uname -r)
    wget http://snapshots.madwifi-project.org/madwifi-hal-0.10.5.6/madwifi-hal-0.10.5.6-r3942-20090205.tar.gz
    tar xzf madwifi-hal-0.10.5.6-r3942-20090205.tar.gz
    cd madwifi-hal-0.10.5.6-r3942-20090205.tar.gz
    make
    sudo make install
    sudo modprobe -a ath_pci wlan_scan_sta
    sudo ifconfig ath0 up
    echo "ath_pci" | sudo tee -a /etc/modules
    All these put the ath5k driver in the blacklist, install all the tools that you need to compile, download de madwifi driver, compile and install it, then load the module and do the changes to load in every startup.
    After each kernel update, you will have to repeat this steps:
    Code:
    cd madwifi-hal-0.10.5.6-r3942-20090205.tar.gz
    make
    sudo make install
    sudo modprobe -a ath_pci wlan_scan_sta
    I hope it helps you.
    nice! Thanks!

Page 3 of 3 FirstFirst 123

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •