Page 5 of 14 FirstFirst ... 34567 ... LastLast
Results 41 to 50 of 138

Thread: [Howto] Install the svn Mplayer under Intrepid Ibex

  1. #41
    Join Date
    Jan 2009
    Beans
    11

    Re: [Howto] Install the svn Mplayer under Intrepid Ibex

    Quote Originally Posted by andrew.46 View Post
    Hi Dakanya,



    This seems to be quite a turbulent period for the svn MPlayer and I have not been able to successfully compile a revision over the last week or so. Best advice is to wait for a couple of days and try again. You can keep an eye on developments via the MPlayer-users:

    http://lists.mplayerhq.hu/pipermail/mplayer-users/

    It will be a worthwhile wait as some major developments are settling in: libdvdnav and libdvdread incorporated from their own svn homes, the new NVidia driver incorporated .....

    Andrew
    Alright, thanks for the quick reply.

  2. #42
    Join Date
    Dec 2006
    Beans
    6,931

    Re: [Howto] Install the svn Mplayer under Intrepid Ibex

    Hi Dakanya,

    Quote Originally Posted by Dakanya View Post
    Alright, thanks for the quick reply.
    Things appear to have settled a little and I have had success with r28337. You could either try a straight 'svn up' or aim for this revision specifically from your svn tree with:

    Code:
    $ svn update -r 28337
    and then recompile as before.

    All the best,

    Andrew
    You think that's air you're breathing now?

  3. #43
    Join Date
    Feb 2007
    Beans
    37

    Re: [Howto] Install the svn Mplayer under Intrepid Ibex

    Hello Andrew. You guide is much appreciated. I've gone through it and everything works great until compile time which results in the following error:

    libvo/aclib.c:105:1: warning: "HAVE_MMX" redefined
    libvo/aclib.c:100:1: warning: this is the location of the previous definition
    libvo/aclib.c:106:1: warning: "HAVE_MMX2" redefined
    libvo/aclib.c:101:1: warning: this is the location of the previous definition
    In file included from libvo/aclib.c:108:
    libvo/aclib_template.c:69:14: error: operator '&&' has no left operand
    libvo/aclib_template.c:80:16: error: operator '!' has no right operand
    libvo/aclib_template.c:108:14: error: #if with no expression
    libvo/aclib_template.c:124:14: error: #if with no expression
    libvo/aclib_template.c:347:14: error: #if with no expression
    libvo/aclib_template.c:431:14: error: #if with no expression
    libvo/aclib.c:168:16: error: #if with no expression
    libvo/aclib.c:172:15: error: #if with no expression
    libvo/aclib.c:202:16: error: #if with no expression
    libvo/aclib.c:206:15: error: #if with no expression
    make: *** [libvo/aclib.o] Error 1
    I've been working on this off and on most of the day. However, I have only found one post concerning libvo/aclib.o error 1 using Google. It was one post asking about the error with no followup that I can find. Might you have a suggestion? I'm running an Athlon XP + 2800 but, I have no idea how to deal with the mmx issue, from what it appears.

  4. #44
    Join Date
    Dec 2006
    Beans
    6,931

    Re: [Howto] Install the svn Mplayer under Intrepid Ibex

    Hi domoso,

    Quote Originally Posted by domoso View Post
    Hello Andrew. You guide is much appreciated. I've gone through it and everything works great until compile time which results in the following error:
    Code:
    libvo/aclib.c:105:1: warning: "HAVE_MMX" redefined
    libvo/aclib.c:100:1: warning: this is the location of the previous definition
    libvo/aclib.c:106:1: warning: "HAVE_MMX2" redefined
    libvo/aclib.c:101:1: warning: this is the location of the previous definition
    This has been rectified with revision 28337 so I suspect if you run 'svn update' from your source tree you should be able to successfully compile.

    All the best,

    Andrew
    You think that's air you're breathing now?

  5. #45
    Join Date
    Feb 2007
    Beans
    37

    Re: [Howto] Install the svn Mplayer under Intrepid Ibex

    Wow, quick replier! I'm compiling now after running svn update. Another question for you. It's a "help me help myself" question. How would I have found that out? And how is it you have your hands on the pulse of mplayer development?

    Compilation successful, thanks.
    Last edited by domoso; January 17th, 2009 at 02:59 AM.

  6. #46
    Join Date
    Dec 2006
    Beans
    6,931

    Re: [Howto] Install the svn Mplayer under Intrepid Ibex

    Hi domoso,

    Quote Originally Posted by domoso View Post
    Wow, quick replier! I'm compiling now after running svn update. Another question for you. It's a "help me help myself" question. How would I have found that out? And how is it you have your hands on the pulse of mplayer development?
    But if I tell you that you will no longer believe that I am quite so clever . But seriously there are 2 mailing lists that are well worth subscribing to even if only to see some of the developers fighting:

    Mplayer-Users
    https://lists.mplayerhq.hu/mailman/l.../mplayer-users

    and

    MPlayer-dev-eng -- MPlayer development
    https://lists.mplayerhq.hu/mailman/l...player-dev-eng

    I would strongly advise lurking for a while in both of these mailing lists as perceived infractions are dealt with very sternly. It is also well worthwhile to keep an eye on the web interface of the svn repository:

    http://svn.mplayerhq.hu/mplayer/trunk/


    Compilation successful, thanks.
    Excellent news!

    Andrew
    You think that's air you're breathing now?

  7. #47
    Join Date
    Jan 2008
    Beans
    35

    Re: [Howto] Install the svn Mplayer under Intrepid Ibex

    Having new problems woohoo. So I just did a new install of mplayer for the dvd menus and all that jazz. Well my problem is that it doesn't play anything using smplayer and when I use the command line it only plays the audio of video files. So I'm guessing it has something to do with video output driver. But here is the strange thing. My list of video ouput drivers is seriously gimped same with my audio output drivers as well.

    video options: fbdev, fbdev2, v4fl2, cvidx, mpegpes, yuv4mpeg, user defined set as xv

    audio options: oss, mpegpes, v4l2, null, pcm, user defined set as alsa

    and heres the log that shows up when player crashes.

    Code:
    mplayer -noquiet -nofs -lavdopts threads=8 -sub-fuzziness 1 -identify -slave -vo xv, -ao alsa, -zoom -nokeepaspect -framedrop -nodr -double -input conf=/usr/share/smplayer/input.conf -stop-xscreensaver -wid 52428812 -monitorpixelaspect 1 -*** -embeddedfonts -***-line-spacing 0 -***-font-scale 1 -***-styles /home/jonathan/.config/smplayer/styles.*** -fontconfig -font Arial -subcp ISO-8859-1 -subpos 100 -volume 40 -dvd-device /dev/dvd -dvdangle 1 -cache 100000 -osdlevel 0 -nocorrect-pts -vf-add eq2,hue -vf-add screenshot -slices -channels 2 -af scaletempo,equalizer=0:0:0:0:0:0:0:0:0:0 dvd://1
    
    MPlayer dev-SVN-r28337-4.3.2 (C) 2000-2009 MPlayer Team
    CPU: Intel(R) Core(TM) Duo CPU      T2450  @ 2.00GHz (Family: 6, Model: 14, Stepping: 12)
    CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
    Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2
    Unknown option on the command line: -stop-xscreensaver
    Error parsing option on the command line: -stop-xscreensaver
    ID_EXIT=NONE
    I don't know what to do... I r sad

    EDIT: Ok so I just uninstalled smplayer 6.6 and installed 6.1 from the repositories and the problem still persists but if you look for the video and audio output driver lists you wont be able to find them because they're just not there... At all! there's not even text that says video or audio output drivers. I don't think any of them are actually installed at this point... Second opinion?
    Last edited by CraymelCage; January 17th, 2009 at 04:49 AM.

  8. #48
    Join Date
    Dec 2006
    Beans
    6,931

    Re: [Howto] Install the svn Mplayer under Intrepid Ibex

    Hi CraymelCage,

    It sounds like a bad compile as both the current MPlayer and SMPlayer should be working perfectly.

    Pivotal to any compiling effort in Ubuntu is the 'dev' files so can I suggest you pick up the entire list of dev files given in the guide and plant them in a terminal to download with 'sudo apt-get install'. Download any required files and if you could report any errors back here that would be great; these errors may show where there is a problem.

    Once this is accomplished completely remove the svn material by deleting $HOME/mplayer and all its subdirectories and again run:

    Code:
    $ cd $HOME
    $ svn checkout svn://svn.mplayerhq.hu/mplayer/trunk mplayer
    $ cd $HOME/mplayer
    $ ./configure
    $ make
    $ sudo checkinstall -D --install=yes --fstrans=no --pakdir "$HOME/Desktop" \
    --maintainer "$USER" --pkgname mplayer --pkgversion "3:1.0~svn" \
    --backup=no --deldoc=yes --deldesc=yes --delspec=yes --gzman --default
    $ make clean
    This is as much as I do on my own Ubuntu system and if there are no errors given by the terminal you should have a perfectly running svn MPlayer + SMPlayer.

    All the best with this,

    Andrew
    You think that's air you're breathing now?

  9. #49
    Join Date
    Jan 2008
    Beans
    35

    Re: [Howto] Install the svn Mplayer under Intrepid Ibex

    this is what I get when I try to install those dev files.

    Code:
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    libaudio2 is already the newest version.
    libaudio2 set to manually installed.
    libfaac0 is already the newest version.
    libfreebob0 is already the newest version.
    libjack0 is already the newest version.
    liblzo2-2 is already the newest version.
    libmad0 is already the newest version.
    libmp3lame0 is already the newest version.
    libmpcdec3 is already the newest version.
    libopenal1 is already the newest version.
    libopenal1 set to manually installed.
    libxvidcore4 is already the newest version.
    E: Couldn't find package libamrnb-dev
    and this is all the things that are disabled when I compile mplayer

    Code:
     Disabled optional drivers:
        Input: vstream radio tv-teletext tv-dshow nemesi cddb cdda smb 
        Codecs: libschroedinger libdirac xvid libdv libamr_wb libamr_nb faac musepack libdca libtheora speex toolame twolame libmad liblzo gif 
        Audio output: sun alsa openal jack pulse nas esd arts ivtv dxr2 sdl 
        Video output: zr zr2 ivtv dxr3 dxr2 sdl vesa gif89a jpeg png svga caca aa ggi xmga mga xvidix winvidix opengl 3dfx dga xvmc xv x11 dfbmga directfb bl xvr100 tdfx_vid wii s3fb tdfxfb
    yup they're not installing.

  10. #50
    Join Date
    Dec 2006
    Beans
    6,931

    Re: [Howto] Install the svn Mplayer under Intrepid Ibex

    Hi CraymelCage,

    Well that is actually good news because it is now clear why your copy of the svn MPlayer is failing: you have not been able to compile against all of the required dev files.

    Quote Originally Posted by CraymelCage View Post
    this is what I get when I try to install those dev files.

    Code:
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    libaudio2 is already the newest version.
    libaudio2 set to manually installed.
    libfaac0 is already the newest version.
    libfreebob0 is already the newest version.
    libjack0 is already the newest version.
    liblzo2-2 is already the newest version.
    libmad0 is already the newest version.
    libmp3lame0 is already the newest version.
    libmpcdec3 is already the newest version.
    libopenal1 is already the newest version.
    libopenal1 set to manually installed.
    libxvidcore4 is already the newest version.
    E: Couldn't find package libamrnb-dev
    There are 2 things to note here:

    1. E: Couldn't find package libamrnb-dev This file is located in the Medibuntu repository and it should be well worth your while to add this repository to your list.
    2. The number of dev files is too low. The dev files you quote above are only about a tenth of the requirements to compile MPlayer. I give the full list below:


    Code:
    sudo apt-get install em8300-headers gawk gettext html2text intltool-debian \
    ladspa-sdk libaa1-dev libartsc0 libartsc0-dev libasound2-dev libatk1.0-dev libaudio-dev \
    libaudio2 libaudiofile-dev libavahi-client-dev libavahi-common-dev libcaca-dev \
    libcairo2-dev libcdparanoia0-dev libcucul-dev libdbus-1-dev libdbus-glib-1-dev \
    libdirectfb-dev libdirectfb-extra libdts-dev libdv4-dev libenca-dev libenca0 \
    libesd0-dev libexpat1-dev libfaac-dev libfaac0 libfontconfig1-dev libfreebob0 \
    libfreetype6-dev libfribidi-dev libggi-target-x libggi2 libggi2-dev libggimisc2 \
    libggimisc2-dev libgif-dev libgii1 libgii1-dev libgii1-target-x libgl1-mesa-dev \
    libglib2.0-dev libglide2 libglu1-mesa-dev libglu1-xorg-dev libgtk2.0-dev libice-dev \
    libjack-dev libjack0 libjpeg62-dev liblzo-dev liblzo1 liblzo2-2 liblzo2-dev libmad0 \
    libmad0-dev libmail-sendmail-perl libmp3lame-dev libmp3lame0 libmpcdec-dev libmpcdec3 \
    libncurses5-dev libogg-dev libopenal-dev libopenal1 libpango1.0-dev libpixman-1-dev \
    libpng12-dev libpopt-dev libpthread-stubs0 libpthread-stubs0-dev libpulse-dev \
    libpulse-mainloop-glib0 libsdl1.2-dev libslang2-dev libsm-dev libsmbclient-dev \
    libspeex-dev libsvga1 libsvga1-dev libsys-hostname-long-perl libsysfs-dev \
    libtheora-dev libtwolame-dev libtwolame0 libvorbis-dev libx11-dev libxau-dev \
    libxcb-render-util0-dev libxcb-render0-dev libxcb-xlib0-dev libxcb1-dev \
    libxcomposite-dev libxcursor-dev libxdamage-dev libxdmcp-dev libxext-dev libxfixes-dev \
    libxft-dev libxi-dev libxinerama-dev libxrandr-dev libxrender-dev libxt-dev libxv-dev \
    libxvidcore4 libxvidcore4-dev libxvmc-dev libxvmc1 libxxf86dga-dev libxxf86vm-dev \
    mesa-common-dev po-debconf sharutils x11proto-composite-dev x11proto-core-dev \
    x11proto-damage-dev x11proto-fixes-dev x11proto-input-dev x11proto-kb-dev \
    x11proto-randr-dev x11proto-render-dev x11proto-video-dev x11proto-xext-dev \
    x11proto-xf86dga-dev x11proto-xf86vidmode-dev x11proto-xinerama-dev \
    xtrans-dev zlib1g-dev libamrnb-dev libamrwb-dev libschroedinger-dev
    You can see all the dev files that have been missed in your compile.

    and this is all the things that are disabled when I compile mplayer

    Code:
     Disabled optional drivers:
        Input: vstream radio tv-teletext tv-dshow nemesi cddb cdda smb 
        Codecs: libschroedinger libdirac xvid libdv libamr_wb libamr_nb faac musepack libdca libtheora speex toolame twolame libmad liblzo gif 
        Audio output: sun alsa openal jack pulse nas esd arts ivtv dxr2 sdl 
        Video output: zr zr2 ivtv dxr3 dxr2 sdl vesa gif89a jpeg png svga caca aa ggi xmga mga xvidix winvidix opengl 3dfx dga xvmc xv x11 dfbmga directfb bl xvr100 tdfx_vid wii s3fb tdfxfb
    yup they're not installing.
    Yes, you have missed out on basic stuff like xv and x11 video. What you should see on configure is:

    Code:
      Enabled optional drivers:
        Input: dvdnav(internal) ftp pvr tv-teletext tv-v4l2 tv-v4l tv live555 cddb cdda libdvdcss(internal) dvdread(internal) vcd dvb smb network 
        Codecs: libschroedinger x264 xvid libdv libamr_wb libamr_nb libavcodec(internal) qtx real xanim win32 faad2(internal) faac musepack libdca libmpeg2(internal) liba52(internal) mp3lib(internal) libtheora speex tremor(internal) twolame libmad liblzo gif 
        Audio output: alsa openal jack pulse nas esd arts oss v4l2 sdl mpegpes(dvb) 
        Video output: v4l2 dxr3 sdl gif89a pnm jpeg png mpegpes(dvb) fbdev svga caca aa ggi xvidix cvidix opengl dga xv x11 xover dfbmga directfb yuv4mpeg md5sum tga 
    
      Disabled optional drivers:
        Input: vstream radio tv-dshow nemesi 
        Codecs: libdirac toolame 
        Audio output: sun ivtv dxr2 
        Video output: zr zr2 ivtv dxr2 vesa xmga mga winvidix 3dfx xvmc bl xvr100 tdfx_vid wii s3fb tdfxfb
    If you can get these dev files installed you should be right.

    All the best,

    Andrew
    You think that's air you're breathing now?

Page 5 of 14 FirstFirst ... 34567 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •