Results 1 to 7 of 7

Thread: PHP5 interpreter missing

  1. #1
    Join Date
    Dec 2008
    Beans
    6

    PHP5 interpreter missing

    Greetings. Two days ago, I installed Ubuntu 8.10 using Wubi.

    Before that day, I'd never worked with anything but Windows.
    Now, with the help of google, most things weren't hard to figure out. I had the system checked for updates, I installed Java, I installed netbeans for PHP and then I followed these 3 articles to be able to debug PHP:

    http://blogs.sun.com/netbeansphp/ent...u_php_netbeans
    http://blogs.sun.com/netbeansphp/ent...tbeans_part_ii
    http://blogs.sun.com/netbeansphp/ent...beans_part_iii

    I got the phpinfo() page to run and all, so that's a succeS.

    Now I'm trying to get Netbeans to debug my files, but for some reason, there's no PHP interpreter found.

    I went to /usr/bin/ to check for PHP but it wasn't there.

    I tried the terminal: whereis php
    but that returned nothing.

    So since I don't have a php interpreter, I can't debug my php projects.

    It's kinda weird, since the pages render perfectly, but I just can't find the interpreter...

    does anybody know what might be causing this and/or what I can do to make things work?

  2. #2
    Join Date
    Jul 2009
    Beans
    103
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: PHP5 interpreter missing

    no i don't that is exactly what i'm also looking for netbeans

    their is easy eclipse and it comes with everything pre installed all u do is open the package in the folder and walla it opens with no installation required @ all

  3. #3
    Join Date
    Jul 2009
    Beans
    103
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: PHP5 interpreter missing

    i'll try it out as well and let u know how it works out for me

  4. #4
    Join Date
    Jul 2007
    Beans
    336

    Re: PHP5 interpreter missing

    try this:
    sudo apt-get install php5-cli

  5. #5
    Join Date
    Jul 2009
    Beans
    103
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: PHP5 interpreter missing

    yes its working thank u very much mate

  6. #6
    Join Date
    Jul 2009
    Beans
    103
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: PHP5 interpreter missing

    now their is no need for any other ide

  7. #7
    Join Date
    Jun 2010
    Beans
    1

    Re: PHP5 interpreter missing

    sudo apt-get install php5-cli
    worked for me!!
    thanks

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •