Results 1 to 3 of 3

Thread: [SOLVED] Poor sound quality w/ HDA ATI SB AD198X

  1. #1
    Join Date
    Jul 2008
    Location
    Lost River Lake
    Beans
    233
    Distro
    Ubuntu Jaunty Jackalope (testing)

    [SOLVED] Poor sound quality w/ HDA ATI SB AD198X

    Dear all,

    I'm getting very bad audio playback quality with this setup:

    Code:
    aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: SB [HDA ATI SB], device 0: AD198x Analog [AD198x Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: SB [HDA ATI SB], device 1: AD198x Digital [AD198x Digital]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    From sudo lspci -v output:

    Code:
    Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
    	Subsystem: Hewlett-Packard Company Device 3613
    	Flags: bus master, slow devsel, latency 64, IRQ 16
    	Memory at 94400000 (64-bit, non-prefetchable) [size=16K]
    	Capabilities: [50] Power Management version 2
    	Kernel driver in use: HDA Intel
    	Kernel modules: snd-hda-intel
    This is a brand new HP Compaq 6735S laptop, dual booting Windows Vista & Ubuntu Intrepid 64-bit. Sound is good in Vista, but in Ubuntu it gets distorted. Any suggestions?

    Regards,

    Piraja
    Last edited by Piraja; December 27th, 2008 at 06:04 PM.
    I never use smilies, but there are exceptions that prove the rule [Hey, how do I disable showing colon & parenthesis as an emoticon in my signature?]
    Now playing: Last.fm

  2. #2
    Join Date
    Jul 2008
    Location
    Lost River Lake
    Beans
    233
    Distro
    Ubuntu Jaunty Jackalope (testing)

    Re: [SOLVED] Poor sound quality w/ HDA ATI SB AD198X

    Even though I still hear some static noise listening to a certain Zappa recording,* it seems that the problem found its solution in the thread HOWTO: PulseAudio Fixes... — kudos to psyke83 for that!

    *) This time I think it's the live recording (Trance Fusion) and not my equipment...

    Edit / Addition: Better, but not perfect... Now Aqualung behaves badly: doesn't respond to pressing the "Stop" button, except with a delay, and then stifles when I touch GNOME's volume control. Yet, I can always use MOC as a gapless player. The situation is way better anyway now.
    Last edited by Piraja; December 27th, 2008 at 06:39 PM.
    I never use smilies, but there are exceptions that prove the rule [Hey, how do I disable showing colon & parenthesis as an emoticon in my signature?]
    Now playing: Last.fm

  3. #3
    Join Date
    Jul 2008
    Location
    Lost River Lake
    Beans
    233
    Distro
    Ubuntu Jaunty Jackalope (testing)

    Re: [SOLVED] Poor sound quality w/ HDA ATI SB AD198X

    The best of solutions and the easiest was yet to come: adding just one line to the alsa-base file.
    I never use smilies, but there are exceptions that prove the rule [Hey, how do I disable showing colon & parenthesis as an emoticon in my signature?]
    Now playing: Last.fm

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •