Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: [SOLVED] Video, googleearth FLICKERING

  1. #1
    Join Date
    Dec 2007
    Location
    Póvoa de Varzim, Portugal
    Beans
    113
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    [SOLVED] Video, googleearth FLICKERING

    Hello.

    I've just upgraded to Intrepid.

    While on hardy, i always had problems with linux games (openarena for example) and google earth -- they flickered a lot. Google earth was impossible to use. 3d games were a problem too.

    After upgrading to intrepid, openarena was playable! google earth is still flickering, but less!

    The problem is that now, my videos also flicker with totem movie player and vlc. The flicker only stops if I put them in full screen mode! Totem, for example, only stops having the problem after that time-out in which there still are visible menus in full screen mode. When menus totally disappear in full screen mode, the flickering stops completely.

    I have a ATI X1600, compiz enabled...

    Can anyone help me?

    Thanks.
    Murphy's Law: if anything can go wrong, it will!

  2. #2
    Join Date
    Dec 2007
    Location
    Póvoa de Varzim, Portugal
    Beans
    113
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Video, googleearth FLICKERING

    *Bump*
    Murphy's Law: if anything can go wrong, it will!

  3. #3
    Join Date
    Oct 2007
    Beans
    288
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Video, googleearth FLICKERING

    Have you tried any of these suggestions in this thread?
    http://ubuntuforums.org/showthread.p...ht=vlc+flicker
    New To Linux? So am I.
    http://linux4noobs.blogspot.com/

  4. #4
    Join Date
    Jun 2007
    Location
    Poughkeepsie, NY
    Beans
    5,815
    Distro
    Ubuntu

    Re: Video, googleearth FLICKERING

    turn off compiz, simple as that

    install fusion-icon from synaptic to control compiz formthe panel tray to make the change simply
    Last night I lay in bed looking up at the stars in the sky and I thought to myself, where the heck is the ceiling.

  5. #5
    Join Date
    Dec 2007
    Location
    Póvoa de Varzim, Portugal
    Beans
    113
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Video, googleearth FLICKERING

    Thanks umechanism and LowSky!

    Disabling compiz, makes all good! However, I'd prefer not to have to disable compiz every time I want to make use of any of these applications.

    With compiz turned on, this workes for movie player and rythmbox visualizations:
    Type gstreamer-properties in terminal (Applications > Accessories in Ubuntu) and go to the video tab. Under Default Output, choose X Window System (no Xv).
    However, googlearth and vlc continue to flicker!!

    As for vsync, I used the ATI control center and put the slider to the right, like it is in the screen shot.

    As for the last tip, I have intrepid, does xorg.conf still exists?



    One way or another, the tips on the other forum and knowing that disabling compiz solves everything has been a great help!! Thank you both, umechanism and LowSky.
    Please, if there is another to put things working with compiz turned on, please advice

    Thanks
    Attached Images Attached Images
    Murphy's Law: if anything can go wrong, it will!

  6. #6
    Join Date
    Oct 2007
    Beans
    288
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Video, googleearth FLICKERING

    Hey, glad it worked out for you. Turning off effects seems to work well for me to.
    New To Linux? So am I.
    http://linux4noobs.blogspot.com/

  7. #7
    Join Date
    May 2006
    Beans
    911

    Re: Video, googleearth FLICKERING

    There is no other way around it at the moment. You have to turn off Compiz if you plan to run any 3D and/or hardware accelerated videos, although some applications (mostly games) can work with Compiz as long as they're in fullscreen.

  8. #8
    Join Date
    Jun 2007
    Location
    England, UK
    Beans
    1,809
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Video, googleearth FLICKERING

    Some games and Google Earth use OpenGL, so it makes sense to disable desktop effects when running them.

    Also, you shouldn't disable Xv (Xvideo) if you like high quality video.

  9. #9
    Join Date
    Jun 2007
    Location
    England, UK
    Beans
    1,809
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Video, googleearth FLICKERING

    Quote Originally Posted by Melcar View Post
    There is no other way around it at the moment. You have to turn off Compiz if you plan to run any 3D and/or hardware accelerated videos, although some applications (mostly games) can work with Compiz as long as they're in fullscreen.

    Same kinda post within a minute of each other!

    Great minds etc...

  10. #10
    Join Date
    Dec 2007
    Location
    Póvoa de Varzim, Portugal
    Beans
    113
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Video, googleearth FLICKERING

    Quote Originally Posted by ubuntu-freak View Post
    Some games and Google Earth use OpenGL, so it makes sense to disable desktop effects when running them.

    Also, you shouldn't disable Xv (Xvideo) if you like high quality video.
    Sorry, can you elaborate? They use OpenGL so I need to disable Compiz why?
    Murphy's Law: if anything can go wrong, it will!

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •