Results 1 to 4 of 4

Thread: [SOLVED] Keyboard backlight does not work

  1. #1
    Join Date
    Apr 2006
    Location
    Chicago
    Beans
    1,405
    Distro
    Ubuntu Intrepid Ibex (testing)

    [SOLVED] Keyboard backlight does not work

    I've installed the hal-applesmc package and applesmc is in /etc/modules. I'm on a macbook pro 3.1 running intrepid. I've had intrepid on here before and it worked great. I took it off for a while and decided to reinstall, now nothing works the way it did a few months ago. The trackpad fdi config didn't work, resume doesn't work, keyboard backlight... Many of the instructions I followed the first time don't work anymore.

    What happened?
    Constant development is the law of life, and a man who always tries to maintain his dogmas in order to appear consistent drives himself into a false position - Mahatma Gandhi

  2. #2
    Join Date
    Apr 2006
    Location
    Chicago
    Beans
    1,405
    Distro
    Ubuntu Intrepid Ibex (testing)

    Re: Keyboard backlight does not work

    I fooled around with some track pad settings and my acpi-support file(trying to get resume to work), rebooted and the keyboard lit up like a Christmas tree.
    Constant development is the law of life, and a man who always tries to maintain his dogmas in order to appear consistent drives himself into a false position - Mahatma Gandhi

  3. #3
    Join Date
    Apr 2007
    Location
    San Francisco
    Beans
    30

    Re: Keyboard backlight does not work

    Do you know which settings you fooled around with?
    Blawrgiddy blawrgiddy blawr, Ubuntu.

  4. #4
    Join Date
    Apr 2007
    Location
    San Francisco
    Beans
    30

    Re: Keyboard backlight does not work

    I figured it out: on MacBook Pro 3,1 versions, you simply remove the MacBook Pro 3,1 entries from /usr/share/hal/fdi/policy/10osvendor/10-macbookpro-utils.fdi, then open gconf-editor, go to apps --> gnome-power-manager and select backlight. Adjust the settings from 100 and 50 (the defaults, I believe) to 0 and 0 if you don't want it turning on every time the power state changes.
    Blawrgiddy blawrgiddy blawr, Ubuntu.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •