Results 1 to 5 of 5

Thread: Please help - Faulty driver package wrecks updates

  1. #1
    Join Date
    Jul 2006
    Beans
    22

    Exclamation Please help - Faulty driver package wrecks updates - 8.10

    E: The package mfc9180lpr needs to be reinstalled, but I can't find an archive for it.
    E: Internal error opening cache (1). Please report.

    The printer package was downloaded from the official brother site.
    http://solutions.brother.com/linux/e....html#MFC-9180

    Now I can't update, can't remove, can't reinstall. Neither update manager nor Synaptic will start because of this package. Please help?

    Version is 8.10
    Last edited by ÄlveKatt; December 26th, 2008 at 08:15 PM. Reason: Needed to add Ubuntu version

  2. #2
    Join Date
    Jul 2006
    Beans
    22

    Re: Please help - Faulty driver package wrecks updates

    I forgot to add the Ubuntu version in the last post. It is 8.10.

  3. #3
    Join Date
    Jan 2007
    Location
    Melbourne, Australia
    Beans
    5,096

    Re: Please help - Faulty driver package wrecks updates

    This is what worked for me.
    Open a terminal and try
    Code:
    sudo dpkg --remove --force-remove-reinstreq mfc9180lpr
    If that does not work then open up //var/lib/dpkg/status
    Code:
    sudo cp /var/lib/dpkg/status /var/lib/dpkg/status.backup
    Code:
    gksu gedit /var/lib/dpkg/status
    search for mfc9180lpr, should look something like this:
    Package: mfc9180lpr
    Status: deinstall reinstreq half-installed
    Maintainer: Brother Industries, Ltd.
    Architecture: i386
    Version: 1.1.2-1
    Description: Brother lpr Printer Definitions
    Copyright: 2003 Brother Industries, Ltd. All Rights Reserved
    Brother printer Driver
    delete it and save.
    Then back in the terminal
    Code:
    sudo apt-get -f install
    sudo dpkg --configure -a
    Ubuntu Newbie Help: irc: #beginners-help on network irc.freenode.net
    Help others, mark your threads solved.

  4. #4
    Join Date
    Jul 2006
    Beans
    22

    Re: Please help - Faulty driver package wrecks updates

    Thank you so very much. That did it.

  5. #5
    Join Date
    Jul 2006
    Beans
    22

    Re: Please help - Faulty driver package wrecks updates

    Oh, and there was no faulty driver. I just did it wrong...

    Though it can't be good that the update thingie is so easy to inadvertently break

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •