Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: Script errors (plugin path) installing 4.5.8 on Mint 6

  1. #1
    Join Date
    Apr 2008
    Beans
    10,439

    Script errors (plugin path) installing 4.5.8 on Mint 6

    I was having trouble with Flash and specifically Flashblock after updating Firefox yesterday in Intrepid and then today in Linux Mint 6, so I decided to give Ubuntuzilla a whirl!

    Things went flawlessly in Intrepid, but in Mint 6 I got the errors at the bottom of this script:

    lance@lance-desktop ~ $ ubuntuzilla.py -a install -p firefox

    Welcome to the Ubuntuzilla Firefox script version 4.5.8

    This script installs the latest release of the official Mozilla build of Firefox on Ubuntu Linux. If you run into any problems using this script, or have feature requests, suggestions, or general comments, please visit our website at http://ubuntuzilla.sourceforge.net/

    Retrieving the version of the latest release of Firefox from the Mozilla website...
    The most recent release of Firefox is detected to be 3.0.5. Please make sure this is correct before proceeding. (You can confirm by going to http://www.mozilla.org/)
    If no version number shows, if the version shown is not the latest, or if you would like to install an older release, press 'n', and you'll be given the option to enter the version manually. Otherwise, press 'y', and proceed with installation. [y/n]?
    Please enter 'y' or 'n': y
    Retrieving list of available localizations for Firefox ...
    Please choose the localization (language) for Firefox. Enter the number of your choice from the list below. [If you do not see a list of localizations, please check the help section of our website at http://ubuntuzilla.sourceforge.net/ for steps you can take to resolve this problem.]
    0. af 1. ar 2. be 3. bg
    4. bn-IN 5. ca 6. cs 7. cy
    8. da 9. de 10. el 11. en-GB
    12. en-US 13. eo 14. es-AR 15. es-ES
    16. et 17. eu 18. fi 19. fr
    20. fy-NL 21. ga-IE 22. gl 23. gu-IN
    24. he 25. hi-IN 26. hu 27. id
    28. is 29. it 30. ja 31. ka
    32. kn 33. ko 34. ku 35. lt
    36. lv 37. mk 38. mn 39. mr
    40. nb-NO 41. nl 42. nn-NO 43. oc
    44. pa-IN 45. pl 46. pt-BR 47. pt-PT
    48. ro 49. ru 50. si 51. sk
    52. sl 53. sq 54. sr 55. sv-SE
    56. te 57. th 58. tr 59. uk
    60. zh-CN 61. zh-TW
    Enter your choice of localization (integer, from 0 to 61): 12
    You have chosen localization en-US. Is that correct [y/n]?
    Please enter 'y' or 'n': y
    Hit http://archive.ubuntu.com intrepid Release.gpg
    Ign http://archive.ubuntu.com intrepid/main Translation-en_US
    Hit http://security.ubuntu.com intrepid-security Release.gpg
    Ign http://security.ubuntu.com intrepid-security/main Translation-en_US
    Hit http://archive.canonical.com intrepid Release.gpg
    Ign http://archive.canonical.com intrepid/partner Translation-en_US
    Ign http://packages.linuxmint.com felicia Release.gpg
    Ign http://archive.ubuntu.com intrepid/restricted Translation-en_US
    Ign http://archive.ubuntu.com intrepid/universe Translation-en_US
    Ign http://archive.ubuntu.com intrepid/multiverse Translation-en_US
    Hit http://archive.ubuntu.com intrepid-updates Release.gpg
    Ign http://archive.ubuntu.com intrepid-updates/main Translation-en_US
    Ign http://archive.ubuntu.com intrepid-updates/restricted Translation-en_US
    Ign http://archive.ubuntu.com intrepid-updates/universe Translation-en_US
    Ign http://security.ubuntu.com intrepid-security/restricted Translation-en_US
    Hit http://archive.canonical.com intrepid Release
    Ign http://packages.linuxmint.com felicia/main Translation-en_US
    Ign http://packages.linuxmint.com felicia/upstream Translation-en_US
    Ign http://packages.linuxmint.com felicia/import Translation-en_US
    Ign http://security.ubuntu.com intrepid-security/universe Translation-en_US
    Ign http://security.ubuntu.com intrepid-security/multiverse Translation-en_US
    Ign http://archive.ubuntu.com intrepid-updates/multiverse Translation-en_US
    Hit http://archive.ubuntu.com intrepid Release
    Hit http://security.ubuntu.com intrepid-security Release
    Hit http://archive.ubuntu.com intrepid-updates Release
    Get:1 http://packages.linuxmint.com felicia Release [7817B]
    Hit http://archive.canonical.com intrepid/partner Packages
    Hit http://archive.ubuntu.com intrepid/main Packages
    Hit http://security.ubuntu.com intrepid-security/main Packages
    Hit http://archive.ubuntu.com intrepid/restricted Packages
    Hit http://archive.ubuntu.com intrepid/universe Packages
    Hit http://archive.ubuntu.com intrepid/multiverse Packages
    Hit http://security.ubuntu.com intrepid-security/restricted Packages
    Hit http://security.ubuntu.com intrepid-security/universe Packages
    Hit http://security.ubuntu.com intrepid-security/multiverse Packages
    Hit http://archive.ubuntu.com intrepid-updates/main Packages
    Hit http://archive.ubuntu.com intrepid-updates/restricted Packages
    Hit http://archive.ubuntu.com intrepid-updates/universe Packages
    Hit http://archive.ubuntu.com intrepid-updates/multiverse Packages
    Ign http://packages.linuxmint.com felicia/main Packages
    Ign http://packages.linuxmint.com felicia/upstream Packages
    Ign http://packages.linuxmint.com felicia/import Packages
    Hit http://packages.linuxmint.com felicia/main Packages
    Hit http://packages.linuxmint.com felicia/upstream Packages
    Hit http://packages.linuxmint.com felicia/import Packages
    Hit http://packages.medibuntu.org intrepid Release.gpg
    Ign http://packages.medibuntu.org intrepid/free Translation-en_US
    Ign http://packages.medibuntu.org intrepid/non-free Translation-en_US
    Hit http://packages.medibuntu.org intrepid Release
    Hit http://packages.medibuntu.org intrepid/free Packages
    Hit http://packages.medibuntu.org intrepid/non-free Packages
    Fetched 7817B in 4s (1587B/s)
    Reading package lists... Done
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    firefox is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 13 not upgraded.

    Backing up old Firefox preferences

    Retrieving package name for Firefox ...
    Success!: firefox-3.0.5.tar.bz2

    Downloading Firefox archive from the Mozilla site

    --2008-12-19 15:54:05-- ftp://releases.mozilla.org/pub/mozil...-3.0.5.tar.bz2
    => `firefox-3.0.5.tar.bz2'
    Resolving releases.mozilla.org... 155.98.64.83, 156.56.247.196, 204.152.184.113, ...
    Connecting to releases.mozilla.org|155.98.64.83|:21... connected.
    Logging in as anonymous ... Logged in!
    ==> SYST ... done. ==> PWD ... done.
    ==> TYPE I ... done. ==> CWD /pub/mozilla.org/firefox/releases/3.0.5/linux-i686/en-US ... done.
    ==> SIZE firefox-3.0.5.tar.bz2 ... 9112341
    ==> PASV ... done. ==> RETR firefox-3.0.5.tar.bz2 ... done.
    Length: 9112341 (8.7M)

    100%[======================================>] 9,112,341 266K/s in 36s

    2008-12-19 15:54:43 (245 KB/s) - `firefox-3.0.5.tar.bz2' saved [9112341]


    Downloading Firefox signature from the Mozilla site

    --2008-12-19 15:54:43-- ftp://releases.mozilla.org/pub/mozil....5.tar.bz2.asc
    => `firefox-3.0.5.tar.bz2.asc'
    Resolving releases.mozilla.org... 149.20.20.5, 128.61.111.9, 64.50.238.52, ...
    Connecting to releases.mozilla.org|149.20.20.5|:21... connected.
    Logging in as anonymous ... Logged in!
    ==> SYST ... done. ==> PWD ... done.
    ==> TYPE I ... done. ==> CWD /pub/mozilla.org/firefox/releases/3.0.5/linux-i686/en-US ... done.
    ==> SIZE firefox-3.0.5.tar.bz2.asc ... 186
    ==> PASV ... done. ==> RETR firefox-3.0.5.tar.bz2.asc ... done.
    Length: 186

    100%[======================================>] 186 --.-K/s in 0.01s

    2008-12-19 15:54:44 (18.4 KB/s) - `firefox-3.0.5.tar.bz2.asc' saved [186]

    tru::1:1229711353:0:3:1:5
    pub:-:1024:17:696E34310E3606D9:2005-09-29:::-:Mozilla Software Releases <releases@mozilla.org>::scESC:
    sub:e:1024:17:C660CCE21AF32821:2005-09-29:2006-09-29:::::s:
    sub:-:2048:16:70474DABAFE99880:2005-09-29::::::e:
    tru::1:1229711353:0:3:1:5
    pub:-:1024:17:74474499812347DD:2007-07-17:2009-07-16::-:Mozilla Software Releases <releases@mozilla.org>::scESC:
    sub:-:1024:17:B57B548417785FE8:2007-07-17:2009-07-16:::::s:
    sub:-:2048:16:CB3A74DF1B0EC2E7:2007-07-17:2009-07-16:::::e:

    Verifying signature...
    Note: do not worry about "untrusted key" warnings. That is normal behavior for newly imported keys.

    gpg: Signature made Mon 15 Dec 2008 08:55:38 PM CST using DSA key ID 17785FE8
    gpg: Good signature from "Mozilla Software Releases <releases@mozilla.org>"
    gpg: WARNING: This key is not certified with a trusted signature!
    gpg: There is no indication that the signature belongs to the owner.
    Primary key fingerprint: 8D6F 1BA4 A340 4DDB 3F2F D080 7447 4499 8123 47DD
    Subkey fingerprint: 3338 E6BA FF10 3B3D A6A9 E424 B57B 5484 1778 5FE8
    sudo dpkg -L firefox |egrep 'firefox(-[0-9]\.[0-9]+[a-z][0-9]+)?/plugins$'
    Failed to determine plugin path. Exiting.
    Process returned code 1
    Traceback (most recent call last):
    File "/usr/local/bin/ubuntuzilla.py", line 1110, in <module>
    bs.start()
    File "/usr/local/bin/ubuntuzilla.py", line 209, in start
    fi.start()
    File "/usr/local/bin/ubuntuzilla.py", line 236, in start
    self.install()
    File "/usr/local/bin/ubuntuzilla.py", line 546, in install
    self.linkPlugins()
    File "/usr/local/bin/ubuntuzilla.py", line 716, in linkPlugins
    self.pluginPath = self.util.getSystemOutput(executionstring="sudo dpkg -L " + self.aptPackage + " |egrep 'firefox(-[0-9]\.[0-9]+[a-z][0-9]+)?/plugins$'", errormessage="Failed to determine plugin path. Exiting.")
    File "/usr/local/bin/ubuntuzilla.py", line 118, in getSystemOutput
    raise SystemCommandExecutionError, "Command has not completed successfully. If this problem persists, please seek help at our website, " + self.version.url
    __main__.SystemCommandExecutionError: Command has not completed successfully. If this problem persists, please seek help at our website, http://ubuntuzilla.sourceforge.net/
    lance@lance-desktop ~ $
    So I ended up installing manually and now the Flash and Flashblock problems are resolved but I'm not linked to the vlc plugin.

    Hope you can help! Thanks in advance!

  2. #2
    Join Date
    Apr 2008
    Beans
    10,439

    Re: Script errors (plugin path) installing 4.5.8 on Mint 6

    I did find an acceptable alternative. I installed the gecko-mediaplayer. Still inferior to vlc IMHO, but acceptable. Certainly better than the mplayer plugins packaged with Mint 6.

    Other things I tried:

    1: I restored Mint 6 to it's virgin Firefox state. Even removing all the backups, the .mozilla folder entirely and starting fresh. the Flash problem (I think because Flashblock would no longer work) still persisted.

    This may be due to limited CPU capacity: VIA 1500 MHZ (very, very energy efficient but weak on performance). I do have 2GB of RAM.

    2: I then once again installed the Ubuntuzilla version of Firefox (same errors) and completely deleted .mozilla and replaced it with a copy of the .mozilla from the perfectly working Intrepid with the Ubuntuzilla install of Firefox. (Quite easy since they're on the same machine).

    Anyway the bottom line is that Ubuntuzilla worked flawlessly on Intrepid and solved my flash/flashblock problems, I can still link the vlc and totem plug-ins on Intrepid! So your project is AWESOME!

    Now for a Mintzilla

    Just joking!

    I'll wait a few days before marking this solved in case anyone has any ideas about how to link the vlc plug-in in Mint (which I also couldn't do in the manual install).

    Also I like to play, as time allows, so if you have some specific testing that needs to be done I have a spare hard drive. But as my moniker indicates I'm a noob! I started out with gOS and Freespire only about 10 months ago.

    Don't let the project die! It's awesome!

  3. #3
    Join Date
    Jan 2006
    Location
    Philadelphia
    Beans
    4,061
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Script errors (plugin path) installing 4.5.8 on Mint 6

    hi
    well, ubuntuzilla has pretty specific versionstring checking for ubuntu (because with each ubuntu release they keep changing where they store the plugins for firefox, basically), and i bet linux mint doesn't keep ubuntu's version string.

    so... could you tell me what it says on your linux mint in the file
    /etc/issue
    ?

    and could you tell me where the plugins are located? (on recent ubuntu versions, its in /usr/lib/xulrunner-addons/plugins )

  4. #4
    Join Date
    Apr 2008
    Beans
    10,439

    Re: Script errors (plugin path) installing 4.5.8 on Mint 6

    I'll have to do some more studying, probably not until Saturday or Sunday.

    So far this:

    lance@lance-desktop ~ $ cat /etc/issue
    Linux Mint 6 Felicia \n \l
    I love Ubuntuzilla in Intrepid! I tried the Ubuntu repo version updated on my test drive and still horrible Flash and no Flashblock. With Ubuntuzilla all is good!

    Great work! Excellent project!

  5. #5
    Join Date
    Apr 2008
    Beans
    10,439

    Re: Script errors (plugin path) installing 4.5.8 on Mint 6

    Two possibly interesting things here:

    lance@lance-desktop ~ $ apt contains addons/plugins
    xulrunner-1.9: /usr/lib/xulrunner-addons/plugins/libnullplugin.so
    totem-mozilla: /usr/lib/xulrunner-addons/plugins/libtotem-gmp-plugin.so
    gecko-mediaplayer: /usr/lib/xulrunner-addons/plugins/gecko-mediaplayer-rm.so
    mozilla-mplayer: /usr/lib/xulrunner-addons/plugins/mplayerplug-in-dvx.so
    mozilla-mplayer: /usr/lib/xulrunner-addons/plugins/mplayerplug-in-wmp.xpt
    mozilla-mplayer: /usr/lib/xulrunner-addons/plugins/mplayerplug-in-rm.so
    gecko-mediaplayer: /usr/lib/xulrunner-addons/plugins/gecko-mediaplayer-rm.xpt
    gecko-mediaplayer: /usr/lib/xulrunner-addons/plugins/gecko-mediaplayer.xpt
    rhythmbox: /usr/lib/xulrunner-addons/plugins/librhythmbox-itms-detection-plugin.so
    gecko-mediaplayer: /usr/lib/xulrunner-addons/plugins/gecko-mediaplayer-dvx.xpt
    xulrunner-1.9, rhythmbox, totem-mozilla, gecko-mediaplayer, mozilla-plugin-vlc, mozilla-mplayer, adobe-flashplugin, sun-java6-plugin: /usr/lib/xulrunner-addons/plugins
    totem-mozilla: /usr/lib/xulrunner-addons/plugins/libtotem-mully-plugin.so
    xulrunner-1.9: /usr/lib/xulrunner-addons/plugins/libunixprintplugin.so
    firefox-3.0: /usr/lib/firefox-addons/plugins
    mozilla-mplayer: /usr/lib/xulrunner-addons/plugins/mplayerplug-in-rm.xpt
    gecko-mediaplayer: /usr/lib/xulrunner-addons/plugins/gecko-mediaplayer-wmp.so
    gecko-mediaplayer: /usr/lib/xulrunner-addons/plugins/gecko-mediaplayer.so
    gecko-mediaplayer: /usr/lib/xulrunner-addons/plugins/gecko-mediaplayer-qt.so
    mozilla-plugin-vlc: /usr/lib/xulrunner-addons/plugins/libvlcplugin.so
    mozilla-mplayer: /usr/lib/xulrunner-addons/plugins/mplayerplug-in.xpt
    mozilla-mplayer: /usr/lib/xulrunner-addons/plugins/mplayerplug-in-dvx.xpt
    totem-mozilla: /usr/lib/xulrunner-addons/plugins/libtotem-narrowspace-plugin.so
    mozilla-mplayer: /usr/lib/xulrunner-addons/plugins/mplayerplug-in-qt.so
    gecko-mediaplayer: /usr/lib/xulrunner-addons/plugins/gecko-mediaplayer-qt.xpt
    mozilla-mplayer: /usr/lib/xulrunner-addons/plugins/mplayerplug-in-wmp.so
    gecko-mediaplayer: /usr/lib/xulrunner-addons/plugins/gecko-mediaplayer-wmp.xpt
    totem-mozilla: /usr/lib/xulrunner-addons/plugins/libtotem-basic-plugin.so
    gecko-mediaplayer: /usr/lib/xulrunner-addons/plugins/gecko-mediaplayer-dvx.so
    mozilla-mplayer: /usr/lib/xulrunner-addons/plugins/mplayerplug-in.so
    mozilla-mplayer: /usr/lib/xulrunner-addons/plugins/mplayerplug-in-qt.xpt
    lance@lance-desktop ~ $

  6. #6
    Join Date
    Jan 2006
    Location
    Philadelphia
    Beans
    4,061
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Script errors (plugin path) installing 4.5.8 on Mint 6

    Hi
    ok, so... mint looks like it's ubuntu with a few bells and whistles on top, so it should be possible to include it.

    currently, the only reason there are version checks is because of the changes in the location of firefox plugins over time, and changes in the name of the default firefox package over time. i think i can do this without relying on version checks, so i'll try to implement that properly, and then ask you to test the new version on both ubuntu and mint, to see if everything works ok.

    keep an eye out for it.

  7. #7
    Join Date
    Apr 2008
    Beans
    10,439

    Re: Script errors (plugin path) installing 4.5.8 on Mint 6

    Quote Originally Posted by nanotube View Post
    Hi
    ok, so... mint looks like it's ubuntu with a few bells and whistles on top, so it should be possible to include it.

    currently, the only reason there are version checks is because of the changes in the location of firefox plugins over time, and changes in the name of the default firefox package over time. i think i can do this without relying on version checks, so i'll try to implement that properly, and then ask you to test the new version on both ubuntu and mint, to see if everything works ok.

    keep an eye out for it.
    Sounds good!

  8. #8
    Join Date
    Jan 2006
    Location
    Philadelphia
    Beans
    4,061
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Script errors (plugin path) installing 4.5.8 on Mint 6

    Hi,

    Well, I have made the code generic, and independent of hard-coded ubuntu version checks. So if things go well, it should now work on any ubuntu/debian derivative distro.

    I am attaching the latest release-candidate package, please give it a test and see if it works for you on ubuntu, mint, ubuntu older versions (feisty?, gutsy, hardy), anything else you can throw at it.

    let me know if you run into any errors.

    I have done some testing myself, on my intrepid system, but I don't have any other linuxes sitting around...
    Attached Files Attached Files

  9. #9
    Join Date
    Apr 2008
    Beans
    10,439

    Re: Script errors (plugin path) installing 4.5.8 on Mint 6

    Great work!

    I popped in my testing hard drive which had "virgin" 8.10 and Mint 6 installed. After updating both I verified that the flash (actually flashblock) problem persisted and it did.

    To be specific the version of flashblock in the repos is 1.3.10a, whereas the current version of flashblock provided by Mozilla is 1.5.7.1. One of those packages that wasn't updated along with Firefox 3.05!

    Anyway the changes you made resulted in Ubuntuzilla running flawlessly on both 8.10 (Intrepid), and Mint 6. All plug-ins work great.

    I'll next try 8.04 (I have an 8.04.2 daily build disc from 12-27), then 7.10, and finally Mint 5, just to be on the safe side.

    I may try to dig up a 6.06 disc but I've always found Dapper to be very fiddly to get running on my hardware.

    BTW, I'm sure there might be some other way of installing only the needed newer version of Flashblock, just running gksudo firefox doesn't get-r-done in the installed version of Firefox, but the point is you've taken out all the guess work!

    Super great project!

  10. #10
    Join Date
    Jan 2006
    Location
    Philadelphia
    Beans
    4,061
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Script errors (plugin path) installing 4.5.8 on Mint 6

    Hi,
    Thanks for testing, sounds great.

    about solving just the flashblock issue without ubuntuzilla: if you want to try it, all you need to do is:

    1. uninstall flashblock from the repos
    2. then go to mozilla addons site for flashblock https://addons.mozilla.org/en-US/firefox/addon/433, click on add to firefox, and when the dialog pops up, say 'install', and it will be installed to your profile.

    no need for sudo or anything like that, since it gets installed to your user profile.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •