Page 3 of 3 FirstFirst 123
Results 21 to 21 of 21

Thread: Using TrueCrypt to encrypt one users home folder...

  1. #21
    Join Date
    Oct 2012
    Beans
    1

    Lightbulb Re: Using TrueCrypt to encrypt one users home folder...

    This above tutorial is not working anymore since ubuntu 11.10 and above uses lightdm instead gdm. I am posting this tutorial for Ubuntu 12.04 and for anyone who needs ubuntu + truecrypt + home folder encrypted.

    My home folder is /home/ionut
    My truecrypt drive is /home/drive

    Install truecrypt.

    Code:
    sudo apt-add-repository ppa:michael-astrapi/ppa && sudo apt-get update && sudo apt-get install truecrypt
    Start truecrypt and create your volume.

    I created my volume in /home. The name of my volume is drive. This is my path for drivecrypt volume: /home/drive.

    Mount your new created volume

    Code:
    sudo mkdir /mnt/tmp
    truecrypt /home/drive /mnt/tmp
    Copy all our data from your home profile, mine is /home/ionut to mnt/tmp


    Code:
    rsync -aHv /home/ionut/ /mnt/tmp
    Delete everything in your home folder
    Code:
    rm -rf * .*
    Then we need to create this script

    Code:
    sudo nano /usr/share/truecrypt.sh
    Add these lines to your truecrypt.sh

    Code:
    if !(echo `mount` | grep -q "/home/ionut type")
    then
            truecrypt /home/drive /home/ionut
    fi
    Replace /home/drive and /home/ionut with your own volume and home directory paths.

    Don't forget to add permisions for your truecrypt.sh file

    Code:
    chmod a+x /usr/share/truecrypt.sh
    Now we edit lightdm.conf

    Code:
    sudo nano /etc/lightdm/lightdm.conf
    Under
    Code:
    [SeatDefaults]
    greeter-session=unity-greeter
    user-session=ubuntu
    we add this line
    Code:
    display-setup-script=/usr/share/truecrypt.sh
    If you want to disable guest account, as I did add also the following line to the lightdm.conf

    Code:
    allow-guest=false
    So /etc/lightdm/lightdm.conf should look like this:

    Code:
    [SeatDefaults]
    greeter-session=unity-greeter
    user-session=ubuntu
    allow-guest=false
    display-setup-script=/usr/share/truecrypt.sh
    Restart and test.

    Now if you did everything as above you should be asked for truecrypt password before logon screen. Feel free to correct me if I'm wrong.

    Hope it helps.
    Last edited by ionutt; October 11th, 2012 at 02:01 PM.

Page 3 of 3 FirstFirst 123

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •