Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: [SOLVED] Huawei e169 USB modem - Virgin Broadband - Australia [solved]

  1. #1
    Join Date
    Dec 2008
    Beans
    2

    [SOLVED] Huawei e169 USB modem - Virgin Broadband - Australia [solved]

    Been tearing my hair out for two weeks now with this one but I did get it to work.

    I have Ubuntu 8.10, Huawei e169 USB modem and Virgin Broadband. The modem was detected no problems although shows up as an E620, but that doesn't seam to matter, I created the connection in the nm-applet and it looked like it was trying to connect but would immediately disconnect or keep asking for the password which wouldn't work.

    It does seam the new network manager has alot of problems to sort out yet, the particular one causing me grief was that I couldn't change the settings on the PPP tab of the connection editor. I could change the check boxes but the changes are not retained.

    With Virgin,it seams, you must login with PAP authentication, but because I couldn't disable CHAP authentication in the connection editor I was unable to connect successfully

    To fix
    sudo gedit /etc/ppp/options

    find the line that says
    #-chap
    and uncomment it (delete #)
    -chap
    this (I think) disables CHAP authentication

    I also had to change the APN to VirginBroadband instead of VirginInternet which was the default And now its happy.

    Other settings
    Number *99#
    Uname <your virgin username>
    PW <your virgin password>

    Hope this helps someone else.


    One other warning on this type of connection. Your machine is visible on the net. Make sure you install a firewall (eg firestarter)to protect yourself.
    Last edited by step_god; December 18th, 2008 at 12:55 AM.

  2. #2
    Join Date
    Dec 2008
    Location
    Australia
    Beans
    182
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Huawei e169 USB modem - Virgin Broadband - Australia [solved]

    That's very nice of you to help somebody else. And welcome to the forums. Also, if you want to mark a topic as solved just use the inbuilt, Thread Tools -> Mark as Solved option in the top right of this thread.
    "What gets us into trouble is not what we don't know, it's what we know for sure that just ain't so." - Mark Twain

  3. #3
    Join Date
    Sep 2006
    Beans
    8
    Distro
    Ubuntu 6.10 Edgy

    Re: [SOLVED] Huawei e169 USB modem - Virgin Broadband - Australia [solved]

    Wow! This really helped me too. And I can confirm that both steps were needed to be able to connect (-chap and APN VirginBroadband).

    Also when it comes up with the password dialog I can enter anything in there and it connects.

  4. #4
    Join Date
    Apr 2006
    Location
    Adelaide, Australia
    Beans
    787
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: [SOLVED] Huawei e169 USB modem - Virgin Broadband - Australia [solved]

    Many thanks for this information. Worked perfectly. You have saved me massive headaches.

  5. #5
    Join Date
    Feb 2009
    Beans
    5

    Angry Re: [SOLVED] Huawei e169 USB modem - Virgin Broadband - Australia [solved]


    Thank you i followed your instructions but do not understand""
    to fix
    sudo gedit/etc/ppp/options
    find the line etc. etc.

    where do i type this or how do i find this sorry but am first time user ofubuntu and need more help

  6. #6
    Join Date
    Mar 2006
    Beans
    1,435
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: [SOLVED] Huawei e169 USB modem - Virgin Broadband - Australia [solved]

    you type that command in terminal. You should find terminal from
    Accessorie>terminal

    (Or if you dont have terminal in there you can type Alt-F2 and type gnome-terminal in there..)

    PS. gnome-ppp should work fine with e169 too.
    _______________
    - anaconda

  7. #7
    Join Date
    Feb 2009
    Beans
    5

    Re: [SOLVED] Huawei e169 USB modem - Virgin Broadband - Australia [solved]

    Quote Originally Posted by anaconda View Post
    you type that command in terminal. You should find terminal from
    Accessorie>terminal

    (Or if you dont have terminal in there you can type Alt-F2 and type gnome-terminal in there..)

    PS. gnome-ppp should work fine with e169 too.
    when i open terminal it shows brian@brian-dektop:~$ and i type sudo gedit/etc/ppp/options
    it then says type in password which i do i then press enter and it comes up command not found... i am not sure why it does not accept the command.!!

  8. #8
    Join Date
    Feb 2009
    Beans
    5

    Re: [SOLVED] Huawei e169 USB modem - Virgin Broadband - Australia [solved]

    Quote Originally Posted by anaconda View Post
    you type that command in terminal. You should find terminal from
    Accessorie>terminal

    (Or if you dont have terminal in there you can type Alt-F2 and type gnome-terminal in there..)

    PS. gnome-ppp should work fine with e169 too.
    when i open terminal it shows brian@brian-dektop:~$ and i type sudo gedit/etc/ppp/options
    it then says type in password which i do i then press enter and it comes up command not found... i am not sure why it does not accept the command.!!

  9. #9
    Join Date
    Feb 2009
    Beans
    5

    Angry Re: [SOLVED] Huawei e169 USB modem - Virgin Broadband - Australia [solved]

    i have also typed other commands in the terminal and have received the same answer "command not found"" maybe i am missing some software??? loaded gnome-ppp and still cannot connect.have spent 5 hours searching the net for help and this site seems to be the only one where people have had success with loading the e 169 usb modem onto ubuntu....what must i be doing wrong????

  10. #10
    Join Date
    Mar 2006
    Beans
    1,435
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: [SOLVED] Huawei e169 USB modem - Virgin Broadband - Australia [solved]

    Quote Originally Posted by brianco View Post
    when i open terminal it shows brian@brian-dektop:~$ and i type sudo gedit/etc/ppp/options
    it then says type in password which i do i then press enter and it comes up command not found... i am not sure why it does not accept the command.!!
    You typed it wrongly. It is:
    sudo gedit /etc/ppp/options
    NOT
    sudo gedit/etc/ppp/options
    There is supposed to be a space between qedit and /

    And the gnome-ppp should also work, but you need to fill the information from your operator.. eg.
    username, password, phone number, init Strings, and select the "Ignore terminal strings" from options tab. and from the modem tab press the "Detect" modem button...
    Last edited by anaconda; February 13th, 2009 at 02:01 PM.
    _______________
    - anaconda

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •