Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 26

Thread: [SOLVED] Huawei e169 USB modem - Virgin Broadband - Australia [solved]

  1. #11
    Join Date
    Feb 2009
    Beans
    5

    Thumbs up Re: [SOLVED] Huawei e169 USB modem - Virgin Broadband - Australia [solved]

    well what a dodo i am i must have looked at that command line 50 times and did not see the space,sorry for that....thank you i typed it correctly and modem works perfectly....also i did not enter details in gnome ppp properly....many thanks for your patience!!

  2. #12
    Join Date
    Feb 2009
    Beans
    1

    Re: [SOLVED] Huawei e169 USB modem - Virgin Broadband - Australia [solved]

    Thank you so much! I called VirginBroadband to ask for help with this and they said "We do not support Linux" which I thought was very sad given that I had signed up for a 24 month contract. So I did a search on google to find your solution and it worked perfectly without a hitch! Thank you so much! I hope Virgin can use this to help other customers too.

  3. #13
    Join Date
    Aug 2008
    Beans
    26

    Re: [SOLVED] Huawei e169 USB modem - Virgin Broadband - Australia [solved]

    Thank you very much sir! Worked perfectly for me.

  4. #14
    Join Date
    Mar 2009
    Beans
    14

    Re: [SOLVED] Huawei e169 USB modem - Virgin Broadband - Australia [solved]

    My first Post! First time K/Ubuntu user long time Linux user (circa 1998 ).
    Confirming the ability to use Virgin Broadband in Australia. Here is my setup:

    - Ubuntu Ultimate Intrepid with Kubuntu DE
    - Linux laptop64 2.6.27-11-generic #1 SMP Thu Jan 29 19:28:32 UTC 2009 x86_64 GNU/Linux
    - Qt: 3.3.8b, KDE: 3.5.10 (Yes but running 4.2), KNetworkManager: 0.7, Networkmanager 0.7
    - Bus 006 Device 003: ID 12d1:1001 Huawei Technologies Co., Ltd. E620 USB Modem
    - Looks like it is using both usbserial and option kernal modules:
    Code:
    Mar 25 20:05:37 laptop64 kernel: [  167.568887] usbcore: registered new interface driver usbserial                       
    Mar 25 20:05:37 laptop64 kernel: [  167.569314] usbserial: USB Serial support registered for generic                     
    Mar 25 20:05:37 laptop64 kernel: [  167.569726] usbcore: registered new interface driver usbserial_generic               
    Mar 25 20:05:37 laptop64 kernel: [  167.569729] usbserial: USB Serial Driver core                                        
    Mar 25 20:05:37 laptop64 kernel: [  167.584601] usbserial: USB Serial support registered for GSM modem (1-port)          
    Mar 25 20:05:37 laptop64 kernel: [  167.585106] option 6-2:1.0: GSM modem (1-port) converter detected                    
    Mar 25 20:05:37 laptop64 kernel: [  167.585622] usb 6-2: GSM modem (1-port) converter now attached to ttyUSB0            
    Mar 25 20:05:37 laptop64 kernel: [  167.586039] option 6-2:1.1: GSM modem (1-port) converter detected                    
    Mar 25 20:05:37 laptop64 kernel: [  167.586466] usb 6-2: GSM modem (1-port) converter now attached to ttyUSB1            
    Mar 25 20:05:37 laptop64 kernel: [  167.586879] option 6-2:1.2: GSM modem (1-port) converter detected                    
    Mar 25 20:05:37 laptop64 kernel: [  167.587300] usb 6-2: GSM modem (1-port) converter now attached to ttyUSB2            
    Mar 25 20:05:37 laptop64 kernel: [  167.587714] usbcore: registered new interface driver option                          
    Mar 25 20:05:37 laptop64 kernel: [  167.587717] option: USB Driver for GSM modems: v0.7.2
    - Clicked the Knetwork Manager icon in the tray, New Connection, ttyUSB0, entered a PIN, VirginBroadband for the APN, Network = Any, Band = 0, NUMBER = *99#.
    - Edited the /etc/ppp/options file to uncomment #-chap as the previous posts suggested and VOILA!! Happy days!

  5. #15
    Join Date
    Apr 2007
    Location
    Sydney, Australia
    Beans
    1

    Re: [SOLVED] Huawei e169 USB modem - Virgin Broadband - Australia [solved]

    Just a security note about the original solution, the user name and password do NOT have to be your virgin user name and password. You can either leave these fields blank, or put any random text in that you wish.

  6. #16
    Join Date
    Apr 2009
    Beans
    1

    Re: [SOLVED] Huawei e169 USB modem - Virgin Broadband - Australia [solved]

    Thank you very much nice and short and painless

  7. #17
    Join Date
    Sep 2007
    Beans
    8

    Re: [SOLVED] Huawei e169 USB modem - Virgin Broadband - Australia [solved]

    Thanks from me, too!

  8. #18
    Join Date
    Jul 2009
    Location
    South Australia, AUS
    Beans
    2
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: [SOLVED] Huawei e169 USB modem - Virgin Broadband - Australia [solved]

    Thanks guys for all of this helpful info!!! It worked for me as a result, but below I have outlined how a newbie, like me, could do it. It worked for me on a few machines anyhow. Much appreciated all of the info you supplied, though! I needed it.

    (Thanks to Grant Petch for helping to figure this out!!)

    First off, this worked with Ubuntu Linux versions 8.10 and 9.04. This may or may not work in previous versions, but please let us know if this works under any other versions or distributions of Linux.
    Secondly, the model number that this solution worked for is the "Huawei E169".

    So, with your Ubuntu 8.10 or 9.04 system booted up and ready, plug in the USB device.
    Wait.
    Follow the prompts for a couple of screens and then when you come to the Name of the device, RENAME IT to "VirginBroadband" (all one word and note the capital letters).
    Then apply that change by clicking OK. Then hit the close buttons of the open windows.

    Now, go to your network icon at the top of the Ubuntu desktop, which is an icon of two computers. Left-click that once and then select 'VPN' and then select 'Configure VPN'.
    Then click on the 'Mobile Broadband' tab. Highlight the Virgin Broadband option and then click 'Edit'. If you are asked about whether to accept a keyring, click 'Allow' or 'Accept All'.
    Under the 'Mobile Broadband' tab, rename the APN to "VirginBroadband", which is exactly the same as the name we first gave the device.

    Now, click on the 'PPP Settings' tab. Click 'Configure Methods' button and then UNCHECK the 'CHAP' check-box. Click 'Apply' and then close all of the windows down.

    Now, left-click on the networks icon again and now click on 'VirginBroadband'... wait a bit... and now, it should be working.

    Open Mozilla Firefox or whatever internet browser you use, and test it out by going to 'Baysidechurch.org.au'... or any other web-page of choice.


    NOW, I found a difference when using Ubuntu 8.10, whereby it actually asked for a password to access the internet. I went and found a solution to this problem too! Here it is:

    Double-click the 'VIRGIN BROADBAND' icon on desktop to open it.
    You will then see a file called 'SysConfig.dat'. Double-click this to open it.
    You will be asked the question, "Do you want to run 'SysConfig.dat', or display its contents?" to which you should click on 'Display'.

    There will be a list of paragraphs with headings in square brackets. Find the paragraph with "[customize]" as the heading and then notice the first line following that reads "operator=VirginMobile_C261", or something like that.
    THIS is your password! Well, not with the operator bit, the password is actually "VirginMobile_C261", at least it was for me. Yours might be different.
    So, either write that down, or copy it by clicking Ctrl+C on your keyboard and then PASTE (or type) that password into the space provided when prompted for the password again.
    A smart thing to do would be to create a quick text document using Text Editor and then paste this password into there. Save this text file to your desktop as something like "Virgin Broadband password".

    There you have it! You should be able to open your internet browser now and surf the three w's.

    Hoping for the best,

    jazzguyman.

  9. #19
    Join Date
    Apr 2005
    Location
    Sydney, NSW
    Beans
    123
    Distro
    Kubuntu 9.04 Jaunty Jackalope

    Re: [SOLVED] Huawei e169 USB modem - Virgin Broadband - Australia [solved]

    Thanks for this thread all.

    I am looking at getting Virigin Broadband for my girlfriends PC and she is running Kubuntu 8.04 I believe.

    So I will update it to 9.04 to get this working.

    I will test with other distro's too while I have the device for people's interest. Mandriva 2009.1 will be tested. The Network Manager there has USB, Bluetooth options all there, so I am confident, as long as the kernel works out the hardware.

    Thanks

  10. #20
    Join Date
    Apr 2005
    Location
    Sydney, NSW
    Beans
    123
    Distro
    Kubuntu 9.04 Jaunty Jackalope

    Re: [SOLVED] Huawei e169 USB modem - Virgin Broadband - Australia [solved]

    I ran up a DVD of Kubuntu 8.10 I had here, rc1, i386.

    In that, using Knetworkmanager. I only had to use the GUI. There was a page that had a bunch of check boxes, one was "Refuse CHAP", so I ticked that from my readings here and all worked second go. I didn't do anything different second go, just tried again when it first failed.

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •