Page 1 of 19 12311 ... LastLast
Results 1 to 10 of 185

Thread: X-server breakage

  1. #1
    Join Date
    Nov 2006
    Location
    Sweden
    Beans
    2,594
    Distro
    Ubuntu Development Release

    X-server breakage

    A little warning until this is clarified.....

    The following packages will be REMOVED:
    nvidia-glx-180 xserver-xorg xserver-xorg-core xserver-xorg-input-all
    xserver-xorg-input-evdev xserver-xorg-input-kbd xserver-xorg-input-mouse
    xserver-xorg-input-synaptics xserver-xorg-input-vmmouse
    xserver-xorg-input-wacom
    The following packages will be upgraded:
    console-setup libdjvulibre-text libdjvulibre21 manpages ttf-liberation
    ttf-sazanami-mincho ubuntu-minimal ubuntu-standard unattended-upgrades
    xserver-common xserver-xorg-dev
    11 upgraded, 0 newly installed, 10 to remove and 0 not upgraded.
    Need to get 7583kB of archives.
    After this operation, 34.3MB disk space will be freed.
    Do you want to continue [Y/n]?
    https://lists.ubuntu.com/archives/ja...er/thread.html

    This will also probably break the nVidia driver.

    Even if the ABI check is removed there will probably be no composite..


    So I wait.......

  2. #2
    Join Date
    Mar 2006
    Beans
    4,373
    Distro
    Ubuntu Development Release

    Re: X-server breakage

    thanks for the warning . I think I'll hold off awhile too .
    if it ain't broke you haven't tweaked it enough

  3. #3
    Join Date
    Mar 2007
    Location
    Hempstead, NY
    Beans
    1,694
    Distro
    Ubuntu Development Release

    Re: X-server breakage

    I don't understand why DRI and compositing are so ridiculously broken on both stable repos and unstable ppa repos...

  4. #4
    Join Date
    Nov 2006
    Location
    Sweden
    Beans
    2,594
    Distro
    Ubuntu Development Release

    Re: X-server breakage

    Quote Originally Posted by ronacc View Post
    thanks for the warning . I think I'll hold off awhile too .

    OK

    I also read this post which also includes log files

    http://ubuntuforums.org/showpost.php...5&postcount=15

  5. #5
    Join Date
    Jun 2005
    Location
    Pacific NorthWest
    Beans
    2,782
    Distro
    Ubuntu Development Release

    Post Re: X-server breakage

    I saw the updates this morning & as it wanted to remove the 180 driver I thought: Well, I'll just revert back to the 177 driver & that "should" fix it.....In short, it wants to remove the 177 also--So I wait too....
    "Let's nobody be dead today----Looks very bad on my report" One of my favourite lines from AVATAR
    Linux User#395230
    Ubuntu User# 13498

  6. #6
    Join Date
    Feb 2007
    Location
    Everywhere
    Beans
    1,529
    Distro
    Ubuntu Development Release

    Re: X-server breakage

    Dammit! I wish I saw this thread earlier. I did the upgrades and nVidia broke. But I am able to use the nv driver, but compositing with Metacity is a joke.

    I do have a usable system, so I'll lump it for now.
    "Knowledge is power. Who said that?" - Dave Lister

  7. #7
    Join Date
    Mar 2007
    Location
    Devon UK
    Beans
    1,494
    Distro
    Ubuntu Development Release

    Re: X-server breakage

    Have you tried reinstalling the 180 driver from Synaptic or CLI?
    Desktops: AMD64X2 3GB RAM 500GB SATA2 GeForce9400GT - P4 HT 3.2Ghz 1GB RAM 250GB IDE + 2x160GB SATA ATI Radeon X740XL - Laptop AMD AthlonXP 1.6 512MB RAM 120GB HD ATI M200

    Gina's Ubuntu HowTo's for beginners (and reference)

  8. #8
    Join Date
    Nov 2006
    Location
    Sweden
    Beans
    2,594
    Distro
    Ubuntu Development Release

    Re: X-server breakage

    Quote Originally Posted by autocrosser View Post
    I saw the updates this morning & as it wanted to remove the 180 driver I thought: Well, I'll just revert back to the 177 driver & that "should" fix it.....In short, it wants to remove the 177 also--So I wait too....
    Yup... the challenge is that Xserver 1.6 brakes nVidias ABI check.

    You can start the driver with the noABI check option but glx is probably broken without patches and that is in the "highest division".

    I hope someone will clarify this situation... Xserver can also be set on "hold"...

  9. #9
    Join Date
    Jan 2008
    Location
    the space between spaces.
    Beans
    1,654

    Re: X-server breakage

    Wait, could this have anything to do with my xorg eating up to 30% CPU? Because it just started doing that two days ago, see my thread:
    http://ubuntuforums.org/showthread.php?t=1011048
    also, I (used to until 180.06) get
    Code:
    AUDIT: Sun Dec 14 17:55:47 2008: 7228 X: client 4 rejected from local host ( uid=0 gid=0 pid=7598 )
    AUDIT: Sun Dec 14 17:55:52 2008: 7228 X: client 4 rejected from local host ( uid=1000 gid=1000 pid=7633 )
    AUDIT: Sun Dec 14 17:55:52 2008: 7228 X: client 4 rejected from local host ( uid=1000 gid=1000 pid=7634 )
    AUDIT: Sun Dec 14 17:55:52 2008: 7228 X: client 4 rejected from local host ( uid=1000 gid=1000 pid=7635 )
    at Xorg.0.log upon boot.AUDIT: Sun Dec 14 17:55:47 2008: 7228 X: client 4 rejected from local host ( uid=0 gid=0 pid=7598 )
    AUDIT: Sun Dec 14 17:55:52 2008: 7228 X: client 4 rejected from local host ( uid=1000 gid=1000 pid=7633 )
    AUDIT: Sun Dec 14 17:55:52 2008: 7228 X: client 4 rejected from local host ( uid=1000 gid=1000 pid=7634 )
    AUDIT: Sun Dec 14 17:55:52 2008: 7228 X: client 4 rejected from local host ( uid=1000 gid=1000 pid=7635 )
    "If a cluttered desk signs a cluttered mind, Of what, then, is an empty desk a sign?" -Albert Einstein.

  10. #10
    Join Date
    Jun 2006
    Location
    GEORGE ZA
    Beans
    173
    Distro
    Ubuntu Development Release

    Re: X-server breakage

    Quote Originally Posted by plun View Post
    A little warning until this is clarified.....



    https://lists.ubuntu.com/archives/ja...er/thread.html

    This will also probably break the nVidia driver.

    Even if the ABI check is removed there will probably be no composite..


    So I wait.......
    I took the plunge...

    I will be waiting for awhile...

    Except if somebody has got a workaround?
    Intel E5200Dual Core CPU, Gigabyte G31 mobo, 4 GB DDR800 mem, Intel graphics, 250 GB Seagate HDD, Liteon 22x DVD Rewriter, 17" HP LCD Ubuntu User # 17508

Page 1 of 19 12311 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •