Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Toshiba Portege M750 suspend doesn't work

  1. #1
    Join Date
    Jan 2007
    Beans
    16

    Unhappy [SOLVED] Toshiba Portege M750 suspend doesn't work

    Hi,

    I just installed ubuntu into my new Portege 750 Tablet PC (basically an upgraded version of the M700). After some tweaking everything is working except suspending to RAM.

    Suspend seems to work but coming out of suspend gives me a blank screen, a mouse pointer that doesn't move and, after a while, a spinning like crazy fan.

    Here is my pm-suspend.log (which seems fine):

    Code:
    Initial commandline parameters: 
    Fri Dec 12 19:18:02 WET 2008: Running hooks for suspend.
    /usr/lib/pm-utils/sleep.d/00clear suspend: success.
    /usr/lib/pm-utils/sleep.d/05led suspend: not applicable.
    /usr/lib/pm-utils/sleep.d/10NetworkManager suspend: success.
    /usr/lib/pm-utils/sleep.d/48hid2hci suspend: not applicable.
    /usr/lib/pm-utils/sleep.d/49bluetooth suspend: not applicable.
    /usr/lib/pm-utils/sleep.d/50modules suspend: success.
    /usr/lib/pm-utils/sleep.d/90clock suspend: success.
    /usr/lib/pm-utils/sleep.d/94cpufreq suspend: success.
    /usr/lib/pm-utils/sleep.d/95anacron suspend: success.
    /usr/lib/pm-utils/sleep.d/95led suspend: not applicable.
    /usr/lib/pm-utils/sleep.d/96laptop-mode suspend: success.
    /usr/lib/pm-utils/sleep.d/98smart-kernel-video suspend: success.
    /usr/lib/pm-utils/sleep.d/99video suspend: success.
    Fri Dec 12 19:18:06 WET 2008: performing suspend
    Is there anything more I can do? I'm totally lost here.

    Thanks,

    Andre Restivo
    Last edited by arestivo; May 14th, 2009 at 07:50 PM. Reason: Solved

  2. #2
    Join Date
    Jan 2007
    Beans
    16

    Re: Toshiba Portege M750 suspend doesn't work

    I've been searching for a solution for this problem and this is what I found so far:

    I followed the DebuggingKernelSuspend tutorial but the only "hash matches" line I get on dmesg is:

    [1.501712] hash matches /build/buildd/linux-2.6.27/drivers/base/power/main.c:390

    If I switch to a text console and run "sudo pm-suspend" I can successfully return from suspend but when I try to switch to gnome the computer freezes. Doing this and killing X before switching back to gnome works but I lose my gnome session.

  3. #3
    Join Date
    Jan 2007
    Beans
    16

    Re: Toshiba Portege M750 suspend doesn't work


  4. #4
    Join Date
    May 2008
    Beans
    15

    Re: Toshiba Portege M750 suspend doesn't work

    I have a similar problem on my Toshiba Satellite L355D. The computer seems to suspend properly, with the power light doing its little slow flash thing. But when I try to return from it all I get is a black screen. Here is my suspend log output.
    Code:
     Initial commandline parameters: 
    Sun Dec 21 09:21:13 CST 2008: Running hooks for suspend.
    /usr/lib/pm-utils/sleep.d/00clear suspend: success.
    /usr/lib/pm-utils/sleep.d/05led suspend: not applicable.
    /usr/lib/pm-utils/sleep.d/10NetworkManager suspend: success.
    /usr/lib/pm-utils/sleep.d/48hid2hci suspend: not applicable.
    /usr/lib/pm-utils/sleep.d/49bluetooth suspend: not applicable.
    /usr/lib/pm-utils/sleep.d/50modules suspend: success.
    /usr/lib/pm-utils/sleep.d/90clock suspend: success.
    /usr/lib/pm-utils/sleep.d/94cpufreq suspend: success.
    /usr/lib/pm-utils/sleep.d/95anacron suspend: success.
    /usr/lib/pm-utils/sleep.d/95led suspend: not applicable.
    /usr/lib/pm-utils/sleep.d/96laptop-mode suspend: success.
    /usr/lib/pm-utils/sleep.d/98smart-kernel-video suspend: success.
    /usr/lib/pm-utils/sleep.d/99video suspend: success.
    Sun Dec 21 09:21:16 CST 2008: performing suspend
    I am also at a loss as to what to do. I guess I'll watch the launchpad page to see if something comes up.

  5. #5
    Join Date
    Jan 2007
    Beans
    16

    Re: Toshiba Portege M750 suspend doesn't work

    Just found out that suspend works with my M750 on Fedora 10 live cd.

  6. #6
    Join Date
    Jan 2007
    Beans
    16

    Re: Toshiba Portege M750 suspend doesn't work

    It seems to be working now. Probably one of the updates corrected something. No idea which one did it.

  7. #7
    Join Date
    May 2009
    Beans
    45

    Re: Toshiba Portege M750 suspend doesn't work

    Can you confirm that touch screen and pen is working ? If so would you mind to help me with your xorg.conf file and "dmesg | grep ttyS' command output ?

  8. #8
    Join Date
    Jan 2007
    Beans
    16

    Re: Toshiba Portege M750 suspend doesn't work

    It's all working. I just followed this tutorial.

    Here goes my xorg.conf

    Code:
    Section "Monitor"
    	Identifier	"Configured Monitor"
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Monitor		"Configured Monitor"
    	Device		"Configured Video Device"
    	Option 		"MonitorLayout"	"CRT,LFP" 
    	Option 		"Clone" 	"true"
    EndSection
    
    Section "InputDevice"
    	Identifier      "stylus"
    	Driver          "wacom"
    	Option          "Device"        "/dev/ttyS0"
    	Option          "Type"          "stylus"
    	Option          "ForceDevice"   "ISDV4"
    	Option          "Mode"          "absolute"
    	Option          "SendCoreEvents"        "true"
    	Option		"Button2"	"3"
    EndSection
    
    Section "InputDevice"
    	Identifier      "eraser"
    	Driver          "wacom"
    	Option          "Device"        "/dev/ttyS0"
    	Option          "Type"          "eraser"
    	Option          "ForceDevice"   "ISDV4"
    	Option          "Mode"          "absolute"
    	Option          "SendCoreEvents"        "true"
    	Option		"Button1"	"2"	
    EndSection
    
    Section "InputDevice"
    	Identifier      "touch"
    	Driver          "wacom"
    	Option          "Device"        "/dev/ttyS0"
    	Option          "Type"          "touch"
    	Option          "ForceDevice"   "ISDV4"
    	Option          "Mode"          "absolute"
    	Option          "SendCoreEvents"        "true"
    EndSection
    
    Section "ServerLayout"
    	Identifier    "Default Layout"
    	Screen        "Default Screen"
    	InputDevice     "stylus"        "SendCoreEvents"
    	InputDevice     "touch"        "SendCoreEvents"
    	InputDevice     "eraser"        "SendCoreEvents"
    EndSection
    
    Section "Device"
    	Identifier	"Configured Video Device"
    	Option          "RandRRotation" "true"
    EndSection
    dmesg doesn't have any lines with ttyS on it. Hope it helps.

  9. #9
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Toshiba Portege M750 suspend doesn't work

    Hi arestivo,

    Thank you for helping us out. Do you mean that when you type in a terminal:
    Code:
    dmesg | grep ttyS
    you don't get any output? If so on your 750 did you use the setserial line for the 700 in the tutorial ie:
    Code:
    /bin/setserial /dev/ttyS0 port 0x338 irq 4 autoconfig
    And did you put it in "/bin/setserial" like the guy in the tutorial did?

  10. #10
    Join Date
    Jan 2007
    Beans
    16

    Re: Toshiba Portege M750 suspend doesn't work

    Quote Originally Posted by Favux View Post
    Do you mean that when you type in a terminal:
    Code:
    dmesg | grep ttyS
    you don't get any output?
    Exactly. I can post my complete dmesg if you want.
    Quote Originally Posted by Favux View Post
    If so on your 750 did you use the setserial line for the 700 in the tutorial ie:
    Code:
    /bin/setserial /dev/ttyS0 port 0x338 irq 4 autoconfig
    And did you put it in "/bin/setserial" like the guy in the tutorial did?
    If I remember correctly I did everything exactly as specified in the tutorial without a single problem. I'm still using 8.10 btw.

    Are you getting any error messages or is it simply not working?

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •