Results 1 to 8 of 8

Thread: Trouble trying to set up OpenSSL

  1. #1
    Join Date
    Jun 2008
    Location
    London
    Beans
    64
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Trouble trying to set up OpenSSL

    First off, I'm a total beginner here. My only real past experience doing anything non-GUI beyond a basic level with any Linux system was troubleshooting installing a wireless device (which failed failed miserably despite the help of some experienced users, and a guarantee on the box that it was Linux-compatible). Even then I was just executing commands that were instructed - I understood only a few. So warning over, just bear this in mind =)

    I want to install OpenSSL. But unfortunately, the process has really gone ****-up and now I'm missing a load of directories/files etc now I've come to the point of actually getting it running after installation. So I have bits and pieces of the installation, but gaping holes where some stuff should be. All I've done is follow some different online tutorials and instructions, and manually work around any small problems up until this point.

    As this clearly isn't working for me, I'd really appreciate it if someone could help out with a step-by-step guide on how I'm meant to get it working (and how to use it once installed if possible) - trying to figure it out from an online tutorial which I don't fully understand hasn't worked for me. It's helpful especially if the process is explained - I don't want to be a noobie forever so the more I understand what I'm doing and why, the better. I suppose to start with some help on how to uninstall all the crap I've accumulated and data I've put in that now I need to get rid of.

    Thanks in advance for any help =)

  2. #2
    Join Date
    Jun 2008
    Location
    Colombia
    Beans
    443

    Re: Trouble trying to set up OpenSSL

    I got it working after installing apache2 from the repos and following the guide at https://help.ubuntu.com/community/fo...er/apache2/SSL

    The guide for 7.10 worked for me, even tho I did it on 8.04, you should start from
    Code:
    sudo apt-get install apache2
    till it says Ubuntu 7.04

    If you have any questions, post them here.

  3. #3
    Join Date
    Jun 2008
    Location
    London
    Beans
    64
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Trouble trying to set up OpenSSL

    First off, thanks for the response. =)

    Having followed the instructions on the link you gave, I've successfully got up to the point "Restart Apache server" where executing the supplied command returns:

    Code:
     * Restarting web server apache2                                                                                                                          apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
    [Thu Dec 11 19:41:37 2008] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
    [Thu Dec 11 19:41:37 2008] [warn] NameVirtualHost *:80 has no VirtualHosts
    apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
    [Thu Dec 11 19:41:47 2008] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
    [Thu Dec 11 19:41:47 2008] [warn] NameVirtualHost *:80 has no VirtualHosts
    Trying to use the "Old fashioned way" just gives a "command not found" error straight away.

    I'm not entirely sure what I've done wrong since I've tried to follow the instructions as precisely as I can. However, I didn't understand some of it so it's possible I messed up.

  4. #4
    Join Date
    Jun 2008
    Location
    Colombia
    Beans
    443

    Re: Trouble trying to set up OpenSSL

    Post the output of
    Code:
    head /etc/apache2/sites-available/default
    And
    Code:
    head /etc/apache2/sites-available/ssl

  5. #5
    Join Date
    Jun 2008
    Location
    London
    Beans
    64
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Trouble trying to set up OpenSSL

    Results are:

    Code:
    NameVirtualHost *:80
    <VirtualHost *:80>
    	ServerAdmin webmaster@localhost
    	
    	DocumentRoot /var/www/
    	<Directory />
    		Options FollowSymLinks
    		AllowOverride None
    	</Directory>
    	<Directory /var/www/>
    and

    Code:
    NameVirtualHost *
    <VirtualHost *>
    	ServerAdmin webmaster@localhost
    	
    	DocumentRoot /var/www/
    	<Directory />
    		Options FollowSymLinks
    		AllowOverride None
    	</Directory>
    	<Directory /var/www/>

  6. #6
    Join Date
    Jun 2008
    Location
    Colombia
    Beans
    443

    Re: Trouble trying to set up OpenSSL

    Here's the problem
    Quote Originally Posted by Spunkbubble View Post
    Code:
    NameVirtualHost *
    <VirtualHost *>
    Change it to
    Code:
    NameVirtualHost *:443
    <virtualhost *:443>
    SSLEngine On
    SSLCertificateFile /etc/apache2/ssl/apache.pem

  7. #7
    Join Date
    Jun 2008
    Location
    London
    Beans
    64
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Trouble trying to set up OpenSSL

    Ok done that, now trying to reload returns:

    Code:
    apache2: Syntax error on line 298 of /etc/apache2/apache2.conf: Syntax error on line 2 of /etc/apache2/sites-enabled/000-default: /etc/apache2/sites-enabled/000-default:2: <virtualhost> was not closed.
       ...fail!
    Why is this? It looks to me as if "virtualhost" is enclosed properly in <> with its value. Does it not work this way?

  8. #8
    Join Date
    Jun 2008
    Location
    Colombia
    Beans
    443

    Re: Trouble trying to set up OpenSSL

    You should look around for a missing </virtualhost> tag after a <virtualhost> tag.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •