Results 1 to 7 of 7

Thread: /etc/X11/xorg.conf is very lean... auto detect not working?

  1. #1
    Join Date
    Dec 2006
    Location
    /dev/null
    Beans
    347

    /etc/X11/xorg.conf is very lean... auto detect not working?

    I read this thread about auto detecting to build an xorg.conf and tried methods 0, 1, and 2 but got nothing useful.

    It seems very lean compare to some others I have seen, for example, read post #11 in this thread... why didn't my hardware get detected and written accordingly?

    My hardware details:

    Microsoft Intelimouse Explorer 4.0
    Microsoft Natural Ergo Keyboard 4000
    GeForce 8800 GTS 512 meg
    ViewSonic G90f

    Here is my out-of-the-box /etc/X11/xorg.conf:

    Code:
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 1.0  (buildmeister@builder58)  Wed Oct  1 15:12:53 PDT 2008
    
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "Module"
        Load           "dbe"
        Load           "extmod"
        Load           "type1"
        Load           "freetype"
        Load           "glx"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
        Option         "VertScrollDelta" "8"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "Unknown"
        HorizSync       30.0 - 110.0
        VertRefresh     50.0 - 150.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "AllowGLXWithComposite" "True"
        Option         "AddARGBGLXVisuals" "True"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    
    Section "Extensions"
        Option         "Composite" "Enable"
    EndSection

  2. #2
    Join Date
    Oct 2005
    Location
    Jacksonville, FL
    Beans
    29,420

    Re: /etc/X11/xorg.conf is very lean... auto detect not working?

    Do you see your graphic card in System -> Administration -> Hardware Drivers?
    In the world of Linux, who needs Windows and Gates...

    Got most of my golden beans at an auction on eBay (with a couple of free drinks).

  3. #3
    Join Date
    Nov 2008
    Location
    West Lafayette, IN
    Beans
    10
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: /etc/X11/xorg.conf is very lean... auto detect not working?

    HA! You think YOUR xorg is lean? Look at mine!

    Code:
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # Note that some configuration settings that could be done previously
    # in this file, now are automatically configured by the server and settings
    # here are ignored.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "Monitor"
    	Identifier	"Configured Monitor"
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Monitor		"Configured Monitor"
    	Device		"Configured Video Device"
    	DefaultDepth	24
    EndSection
    
    Section "Module"
    	Load	"glx"
    EndSection
    
    Section "Device"
    	Identifier	"Configured Video Device"
    	Driver	"fglrx"
    EndSection

  4. #4
    Join Date
    Dec 2007
    Location
    Buenos Aires, Argentina
    Beans
    1,231
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: /etc/X11/xorg.conf is very lean... auto detect not working?

    Mine is really, really thin too...
    But, everything (Compiz, etc, etc.) works perfectly, is just the NVIDIA dwarfs, man... Working on the behind each pixel.


    Code:
    Section "Monitor"
            Identifier      "Configured Monitor"
    EndSection
    
    Section "Screen"
            Identifier      "Default Screen"
            Monitor         "Configured Monitor"
            Device          "Configured Video Device"
            DefaultDepth    24
    EndSection
    
    Section "Module"
            Load    "glx"
    EndSection
    
    Section "Device"
            Identifier      "Configured Video Device"
            Driver  "nvidia"
            Option  "NoLogo"        "True"
    EndSection
    Live long and prosper.
    And use lotsa Linux, BSD, and Emacs.

  5. #5
    Join Date
    Dec 2006
    Beans
    Hidden!
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: /etc/X11/xorg.conf is very lean... auto detect not working?

    I end up with the same lean xorg.conf....works fine.

    Problem is, I have three different Intrepid machines hooked up to one monitor/keyboard/mouse using a KVM switch.

    If the monitor is not connected to the device when I reboot, then I get the stoopid Low Resolution warning message and X won't start on boot.

    Anyone figured out a way to have Intrepid Desktop boot headless with this new minimal xorg.conf file?

    Headless booting worked fine in Hardy....it's all the auto-detection nonsense that seems to have broken the ability to boot without a monitor.

    Help!

  6. #6
    Join Date
    Oct 2008
    Beans
    15

    Re: /etc/X11/xorg.conf is very lean... auto detect not working?

    I have same problem, I do not mind booting it with the monitor, mouse connected.
    My problem is when I switch back and forth, the new xorg does not always re-detect keyboard and mouse and I have to re-boot. to get them back.
    Wonder if anybody else was having this problem?
    By the way I am running debian/lenny with the new xorg and have spent days reading the forum with no help. Now I am searching here.

  7. #7
    Join Date
    Dec 2007
    Location
    Buenos Aires, Argentina
    Beans
    1,231
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: /etc/X11/xorg.conf is very lean... auto detect not working?

    I have my Ubuntu installed on a Compaq F700 laptop, and I didn't have the problem you mention, I can reboot it, connect and disconnect either USB mouse & keyboard (or both of them at the same time thru the keyboard) with no problem at all.

    On thing I did, to expand my xorg.file, in order to customize it, was installeing 'nvidia-settings', of couse, I have an NVIDIA card, and use to write an xorg.conf file of the run time configuration.
    Live long and prosper.
    And use lotsa Linux, BSD, and Emacs.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •