Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: 10.10 Can someone tell me how to disable the touchscreen?

  1. #1
    Join Date
    Apr 2007
    Beans
    492

    10.10 Can someone tell me how to disable the touchscreen?

    I want Pen and Touch disabled. The touch part has calibration issues and clicks when nothing is near the screen, so I just want the whole thing turned off.

    How can I do this in 10.10?

    It is an N-Trig touch screen on a Dell latitude XT.

    Thanks!

  2. #2
    Join Date
    Sep 2009
    Location
    Russia
    Beans
    318

    Re: 10.10 Can someone tell me how to disable the touchscreen?

    Hello, try this:

    Code:
    $ synclient TouchpadOff=1
    Debian GNU/Linux user

  3. #3
    Join Date
    Apr 2007
    Beans
    492

    Re: 10.10 Can someone tell me how to disable the touchscreen?

    Before I try that, is that going to disable the touchscreen or the touchpad? Because I need the touchpad.

  4. #4
    Join Date
    Sep 2009
    Location
    Russia
    Beans
    318

    Re: 10.10 Can someone tell me how to disable the touchscreen?

    Quote Originally Posted by gohanssjn View Post
    Before I try that, is that going to disable the touchscreen or the touchpad? Because I need the touchpad.
    Oh, sorry. My bad, I was not careful.

    Please give here output of
    Code:
    $ xinput --list
    Debian GNU/Linux user

  5. #5
    Join Date
    Apr 2007
    Beans
    492

    Re: 10.10 Can someone tell me how to disable the touchscreen?

    Quote Originally Posted by utilitytrack View Post
    Oh, sorry. My bad, I was not careful.

    Please give here output of
    Code:
    $ xinput --list
    Code:
    xinput --list
    ⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
    ⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
    ⎜   ↳ Logitech USB Receiver                   	id=10	[slave  pointer  (2)]
    ⎜   ↳ N-Trig Pen eraser                       	id=11	[slave  pointer  (2)]
    ⎜   ↳ N-Trig Pen stylus                       	id=12	[slave  pointer  (2)]
    ⎜   ↳ N-Trig MultiTouch                       	id=13	[slave  pointer  (2)]
    ⎜   ↳ N-Trig Touchscreen                      	id=14	[slave  pointer  (2)]
    ⎜   ↳ PS/2 Generic Mouse                      	id=16	[slave  pointer  (2)]
    ⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
        ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
        ↳ Video Bus                               	id=6	[slave  keyboard (3)]
        ↳ Power Button                            	id=7	[slave  keyboard (3)]
        ↳ Sleep Button                            	id=8	[slave  keyboard (3)]
        ↳ Logitech USB Receiver                   	id=9	[slave  keyboard (3)]
        ↳ AT Translated Set 2 keyboard            	id=15	[slave  keyboard (3)]
        ↳ Dell WMI hotkeys                        	id=17	[slave  keyboard (3)]

  6. #6
    Join Date
    Sep 2009
    Location
    Russia
    Beans
    318

    Re: 10.10 Can someone tell me how to disable the touchscreen?

    Ok, next post here output of
    Code:
    $ xinput --list-props 14
    Debian GNU/Linux user

  7. #7
    Join Date
    Apr 2007
    Location
    Mount Horeb, WI
    Beans
    4,312
    Distro
    Kubuntu Development Release

    Re: 10.10 Can someone tell me how to disable the touchscreen?

    You can try:
    To turn it off
    Code:
    xinput set-prop 'N-Trig MultiTouch' 'Device Enabled' 0
    To turn it on
    Code:
    xinput set-prop 'N-Trig MultiTouch' 'Device Enabled' 1
    When you have the N-Trig MultiTouch device, the N-Trig Touchscreen does not report anything. The device uses the N-Trig Touchscreen for single-touch reporting when the multitouch firmware is not present.

    I hope that helps.

  8. #8
    Join Date
    Apr 2007
    Beans
    492

    Re: 10.10 Can someone tell me how to disable the touchscreen?

    Quote Originally Posted by Ayuthia View Post
    You can try:
    To turn it off
    Code:
    xinput set-prop 'N-Trig MultiTouch' 'Device Enabled' 0
    To turn it on
    Code:
    xinput set-prop 'N-Trig MultiTouch' 'Device Enabled' 1
    When you have the N-Trig MultiTouch device, the N-Trig Touchscreen does not report anything. The device uses the N-Trig Touchscreen for single-touch reporting when the multitouch firmware is not present.

    I hope that helps.
    Yay! Touch is off, but the pen still works!

    Now, what would I have to do to make this persistent between reboots?

  9. #9
    Join Date
    Apr 2007
    Location
    Mount Horeb, WI
    Beans
    4,312
    Distro
    Kubuntu Development Release

    Re: 10.10 Can someone tell me how to disable the touchscreen?

    You can try:
    Code:
    echo "xinput set-prop 'N-Trig MultiTouch' 'Device Enabled' 0" >> .xinitrc
    I have not had a chance to try it out, but the .xinitrc file should run when your session starts so it should turn off touch.

  10. #10
    Join Date
    Apr 2007
    Beans
    492

    Re: 10.10 Can someone tell me how to disable the touchscreen?

    Quote Originally Posted by Ayuthia View Post
    You can try:
    Code:
    echo "xinput set-prop 'N-Trig MultiTouch' 'Device Enabled' 0" >> .xinitrc
    I have not had a chance to try it out, but the .xinitrc file should run when your session starts so it should turn off touch.
    Did not work, still had touch on login screen and in session.

    Thanks for all the help so far.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •