It is possible that you are experiencing freezes related to this Nouveau bug. If you have Nvidia hardware but wish to use Nouveau, please try adding nouveau.noaccel=1 to your boot options as mentioned in that bug report.