Results 1 to 5 of 5

Thread: White Screen instead of desktop in 10.10 (Radeon 7500 card)

  1. #1
    Join Date
    Jun 2007
    Beans
    18
    Distro
    Ubuntu

    White Screen instead of desktop in 10.10 (Radeon 7500 card)

    I have upgraded an IBM T41 laptop from UNR 10.04 to 10.10 beta. Upgrade ran fine.

    After rebooting, I see the splash screen, and eventually the screen goes white. It does this over a few transitions, most likely in the time between X starting and having the desktop loading (I have auto logon enabled).

    Once it is all white, I can Ctrl-Alt-F1 to the terminal. Since then I have disabled auto login but same result. I have also removed Unity (I use UNR and the T41 doesn't have a 3d graphics card), and have the same white screen.

    Only after removing xserver-xorg-video-radeon, can I get to the Ubuntu Desktop (in 16 colour glory).

    The Thinkpad T41 has a Radeon Mobility 7500 in it, and ran fine in UNR 10.04 (which is also a different kernel).

    There was no xorg.conf in use (although I have added one during testing and forced the radeon driver to load) and I reviewed xorg log but didn't see anything.

    Any ideas on how to get X working properly again?

  2. #2
    Join Date
    Dec 2005
    Location
    Cape Town, South Africa
    Beans
    52
    Distro
    Ubuntu Development Release

    Re: White Screen instead of desktop in 10.10 (Radeon 7500 card)

    Same problem here on a Lenovo S10-2. Did you manage to find a fix?

  3. #3
    Join Date
    May 2007
    Beans
    13,059

    Re: White Screen instead of desktop in 10.10 (Radeon 7500 card)

    To both of you ...

    If you're going to upgrade to pre-release versions of Ubuntu, then you need to keep a close check on the appropriate Development forum -- which is where these kinds of posts (and answers) are supposed to go.

    As a matter of fact, if you check the Maverick Development forum and do a search on ATI, you will find a post dealing with radeon-driver problems that also contains a fix.

    So, please go to THAT forum with your questions, not here.

    And in the future, please post your Beta-related questions to the proper Development forum. You'll get answers a lot quicker that way.
    Ubuntu 15.04 Mate, Mint 17.1; MS Win 8.1, Win10 TP.
    Will not respond to PM requests for support -- use the forums.

  4. #4
    Join Date
    Dec 2005
    Location
    Cape Town, South Africa
    Beans
    52
    Distro
    Ubuntu Development Release

    Re: White Screen instead of desktop in 10.10 (Radeon 7500 card)

    Sorry, this was the first result I saw when searching for the problem. I have re-posted here: http://ubuntuforums.org/showthread.p...26#post9921026

  5. #5
    Join Date
    Jun 2007
    Beans
    18
    Distro
    Ubuntu

    Re: White Screen instead of desktop in 10.10 (Radeon 7500 card)

    OK cheers. I did try #ubuntu+1 irc channel with no response, and reviewed the Beta page to try and work out which forum this post belongs in. I would suggest clarifying the beta page with a direct link to the relevant forum.

    For others, the correct forum is:
    Ubuntu Forums > The Ubuntu Forum Community > Other Community Discussions > Development & Programming > Maverick Meerkat Testing and Discussion

    This question has been reposted and solved in there
    Last edited by ubanksy; October 5th, 2010 at 12:20 PM. Reason: added URL, resolution

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •