Results 1 to 1 of 1

Thread: System wide LADSPA audio filters...

  1. #1
    Join Date
    Sep 2010
    Beans
    2

    Question System wide LADSPA audio filters...

    Based on the PulseAudio equalizer I've tried to get my own LADSPA plugins inserted into pulseaudio's chain... and here's what I've got for a compressor


    Code:
    ### BEGIN: Compressor configuration
    load-module module-ladspa-sink sink_name=ladspa_output.dyson_compress_1403.dysonCompress master=alsa_output.default plugin=dyson_compress_1403 label=dysonCompress control=0,1,0.5,0.99
    set-default-sink ladspa_output.dyson_compress_1403.dysonCompress
    set-sink-volume alsa_output.default 65536
    set-sink-mute alsa_output.default 0
    ### END: Compressor configuration
    appended to the end of either /etc/pulse/default.pa or ~/.pulse/default.pa

    then reset pulseaudio with killall pulseaudio

    It properly loads the plugins (I think), it even shows up in the sound preferences as a new output (as "LADSPA Plugin Dyson compressor on Internal Audio"), however it has no effect on the audio output.

    Any ideas what's going wrong, or where I can start to debug?
    Trying to get a compressor and limiter inserted into my audio chain.

    P.S. running Ubuntu 10.04 with all upgrades installed, ladspa-sdk and swh-plugins installed


    -----------------------
    Edit: It works! Now just to find a limiter that pulseaudio will stomach.
    Last edited by [STD]Ein; September 16th, 2010 at 08:51 AM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •