I use Ubuntu 9.10 64-bit. The 9.10 repository only has version 1.0.5 of the VideoLAN VLC Media Player, but I would like to upgrade. What is the best way to upgrade to the latest version of VLC Media Player, 1.1.2?
I Googled the problem and found a couple of pages suggesting this sequence at the command line:
(Taken from this article at Ubuntu Geek: http://www.ubuntugeek.com/install-vl...html#more-7483)
sudo add-apt-repository ppa:c-korn/vlc
sudo apt-get update
sudo apt-get install vlc mozilla-plugin-vlc
This did not quite work for me. Here's what happened when I tried the first command:
Strangely, when I checked my software sources list, the c-korn/vlc entry had been added.
objekt910@objekt910-desktop:~$ sudo add-apt-repository ppa:c-korn/vlc
Exception in thread Thread-1:
Traceback (most recent call last):
File "/usr/lib/python2.6/threading.py", line 525, in __bootstrap_inner
File "/usr/lib/python2.6/dist-packages/softwareproperties/ppa.py", line 60, in run
File "/usr/lib/python2.6/dist-packages/softwareproperties/ppa.py", line 79, in add_ppa_signing_key
'\"signing_key_fingerprint\": \"(\w*)\"', lp_page)
IndexError: list index out of range
When I tried to run the next command, I got:
Does that simply mean there is no 64-bit specific version of VLC 1.1.2?
objekt910@objekt910-desktop:~$ sudo apt-get update
W: Failed to fetch http://ppa.launchpad.net/c-korn/vlc/ubuntu/dists/karmic/main/binary-amd64/Packages.gz 404 Not Found
E: Some index files failed to download, they have been ignored, or old ones used instead.
I also got a bad result from trying the last command:
objekt910@objekt910-desktop:~$ sudo apt-get install vlc mozilla-plugin-vlc
Reading package lists... Done
Building dependency tree
Reading state information... Done
vlc is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
mozilla-plugin-vlc: Depends: vlc-nox (= 1.0.2-1ubuntu2.1) but 1.0.5-1~getdeb1 is to be installed
E: Broken packages
1) Is my Ubuntu 9.10 install hopelessly broken? Or can it be fixed?
2) Does there exist a way to download & install VLC 1.1.2 manually? I can only find Windows and Mac downloadable archives of VLC 1.1.2. The only way I can find to get 1.1.2 on Ubuntu is the commands given above, which don't work.