Touchpad users have noticed their mouse has a 3-4 second lagg if their holding down any key, this is obviously a big problem as it makes games unplayable.

This is because of a default setting "Disable mouse while typing" disable this setting from
system->preferences->mouse->touchpad

If you turn it off in the gconf editor it will now work.

https://lists.launchpad.net/ubuntu-x-swat/msg82093.html

*the problem is also fixed using an external mouse.*