Results 1 to 10 of 70

Thread: 10.04 won't boot without monitor / keyboard (headless)

Threaded View

  1. #18
    Join Date
    Jan 2008
    Ubuntu 10.04 Lucid Lynx

    Smile Re: 10.04 won't boot without monitor / keyboard (headless)

    YEA! I got it.

    The answer is actually a combination of two separate solutions, each of which did not work separately. I have 10.04 now working headless on two different servers (different MB, Video...) and both are working great.

    Step 1. Create a xorg.conf in /etc/X11 with the following. I tried Step 2 without doing this and it failed exactly as it had before.

    Section "Device"
    Identifier "VNC Device"
    Driver "vesa"

    Section "Screen"
    Identifier "VNC Screen"
    Device "VNC Device"
    Monitor "VNC Monitor"
    SubSection "Display"
    Modes "1024x768"

    Section "Monitor"
    Identifier "VNC Monitor"
    HorizSync 30-70
    VertRefresh 50-75

    Step 2. Disable KMS for your video card as described here

    The jist is to know which video card manufacturer you have and use the command line entry below it to create the appropriate kms.conf file with the line "options...modeset=0" line in it. If you have access to the GUI you could just are easily create/modify the file and put the "options...modeset=0" in as appropriate.

    The following are input into the terminal windows as a line command.

    # ATI Radeon:
    echo options radeon modeset=0 > /etc/modprobe.d/radeon-kms.conf

    # Intel:
    echo options i915 modeset=0 > /etc/modprobe.d/i915-kms.conf

    # Nvidia (this should revert you to using -nv or -vesa):
    echo options nouveau modeset=0 > /etc/modprobe.d/nouveau-kms.conf

    Step 3. Reboot...Putty In...startx...GTG!

    Last edited by bapool; July 4th, 2010 at 07:13 PM.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts