Well with the release of iOS 4, many Ubuntu users are complaining of incompatibility with between rhythmbox and the new update. Here is a simple way to fix that:

1. Open up synaptic

2. Go to the Repositories (Under Settings)

3. Add this source:
Code:
ppa:pmcenery/ppa
(from https://launchpad.net/~pmcenery/+archive/ppa)

4. Click Close and then click the Reload button at the top left

5. After it is done reloading search for:
libimobiledevice1

6. It will give you two results, install both.

7. Now after installing, close synaptic and open up the terminal and type in
Code:
sudo apt-get dist-upgrade
8. After the upgrade Ubuntu 10.04 will have iOS 4 support!!