When you have Ubuntu 10.04, and you login as root, you cannot change the sound volume or settings with the sound applet in the gnome-panel.

The solution:

Go to System->Preferences -> Startup Applications

Make sure you're in the tab 'Startup programs'
-> Click on 'Add'

Name: Pulseaudio daemon
Comment: Start the sound daemon

Now logout, then login again