Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: Huawei EC1261 does not work with Ubuntu

  1. #1
    Join Date
    Dec 2009
    Beans
    130
    Distro
    Ubuntu

    Angry Huawei EC1261 does not work with Ubuntu

    I recently bought a Huawei EC1261 mobile broadband dongle from Tata Teleservices. Unfortunately,neither does the dongle does not work in Ubuntu 9.04(Jaunty Jackalope) nor in Windows XP. The dongle is rather mounted as a drive and not recognised by NetworkManager as a mobile broadband device. The drive can be accessed with Nautilus as well as terminal like any other USB pen drive and located at "/media/disk". Please help.

    Also, does the device work in Ubuntu 10.04(Lucid Lynx)? Please report if anyone has tried using the device on Lucid, as I will upgrade to Lucid if the device is supported.

  2. #2
    Join Date
    Mar 2005
    Location
    Isle of Bute, Scotland
    Beans
    365
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Huawei EC1261 does not work with Ubuntu

    Quote Originally Posted by jre6 View Post
    I recently bought a Huawei EC1261 mobile broadband dongle from Tata Teleservices. Unfortunately,neither does the dongle does not work in Ubuntu 9.04(Jaunty Jackalope) nor in Windows XP. The dongle is rather mounted as a drive and not recognised by NetworkManager as a mobile broadband device. The drive can be accessed with Nautilus as well as terminal like any other USB pen drive and located at "/media/disk". Please help.

    Also, does the device work in Ubuntu 10.04(Lucid Lynx)? Please report if anyone has tried using the device on Lucid, as I will upgrade to Lucid if the device is supported.
    Cannot really help with either O/S problems just give some pointers

    The devices can usually be be used for mass storage or modem and the default is mass storage. With the drivers installed under windows you should have some means of switching between the two.
    For Linux some work has been done to sort this out and I can only suggest you look at this thread:
    http://ubuntuforums.org/showthread.p...ghlight=huawei

  3. #3
    Join Date
    Jul 2007
    Location
    Melbourne, Australia
    Beans
    3,475
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Huawei EC1261 does not work with Ubuntu

    I had the same issue with huawei E620 (fortunately it works with the latest lucid kernel). There are two things you can try.
    1. I found the development mainline kernel found here allowed the huawei to work. You will only need the image, not the headers as well.
    2. Install these two packages - the data one first, I think. As tehy are .deb, you only need to double click them to install them.
    usb-modeswitch-data_20100127-1_all.deb
    usb-modeswitch_1.1.0-2_i386.deb

    Either solution might work. p to you which one you try first.
    Windows is the best virus detector on the market!
    Ubuntu attracts Human Beings - Windows attracts viruses and worms

  4. #4
    Join Date
    Sep 2006
    Beans
    2

    Re: Huawei EC1261 does not work with Ubuntu

    Edit /etc/usb_modeswitch.d/12d1:1446,
    add 140b to the targetList=

  5. #5
    Join Date
    Apr 2005
    Beans
    2,051

    Re: Huawei EC1261 does not work with Ubuntu

    I see this described as CDMA EVDO device

    http://img246.imageshack.us/img246/2015/dsc02657t.jpg

    can you type in

    lsusb
    in a terminal and copy and paste the results please?

    One way to try with ubuntu 10.04 is to download the iso and try that as a liveCD: either as a CD or usb stick; (I suspect this device will work well with 10.04)

    I notice if you google on

    ubuntu Huawei EC1261
    seems like the device ID is

    12d1:1446 Huawei Technologies Co., Ltd.
    and that is covered in usb_modeswitch

    you need to install the latest version, 1.1.2

    from here

    http://packages.debian.org/search?ke...usb-modeswitch

    it should flip the device and it can be configured as here

    "create a mobile broadband connection .."

    http://www.pharscape.org/networkmana...an-modems.html

    see halfway down page
    Last edited by pdc; May 25th, 2010 at 11:47 AM.

  6. #6
    Join Date
    Dec 2009
    Beans
    130
    Distro
    Ubuntu

    Question Re: Huawei EC1261 does not work with Ubuntu

    Quote Originally Posted by bumanie View Post
    I had the same issue with huawei E620 (fortunately it works with the latest lucid kernel). There are two things you can try.
    1. I found the development mainline kernel found here allowed the huawei to work. You will only need the image, not the headers as well.
    2. Install these two packages - the data one first, I think. As tehy are .deb, you only need to double click them to install them.
    usb-modeswitch-data_20100127-1_all.deb
    usb-modeswitch_1.1.0-2_i386.deb

    Either solution might work. p to you which one you try first.
    Is there anything that requires to be done after installing the packages?

    Typing lsusb in terminal gives this output:
    Code:
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 005 Device 002: ID 413c:3016 Dell Computer Corp. 
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 002: ID 12d1:1446 Huawei Technologies Co., Ltd. 
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 004: ID 0b97:7762 O2 Micro, Inc. Oz776 SmartCard Reader
    Bus 002 Device 003: ID 0b97:7761 O2 Micro, Inc. Oz776 1.1 Hub
    Bus 002 Device 002: ID 413c:a005 Dell Computer Corp. Internal 2.0 Hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Last edited by jre6; May 26th, 2010 at 01:51 PM.

  7. #7
    Join Date
    Apr 2005
    Beans
    2,051

    Re: Huawei EC1261 does not work with Ubuntu

    if the ID says

    1446
    the device has not changed its ID:

    usb_modeswitch file says it should change to

    14ac
    If you go here

    http://packages.debian.org/search?ke...usb-modeswitch

    you can download the latest usb_modeswitch;

    your system should offer to install it for you, and it should auto-configure and change the ID from 1446 to 14ac; you can check that on lsusb

    when it has changed, it should be able to be configured ... as here ..

    http://www.pharscape.org/networkmana...an-modems.html

    half-way down page ....... create mobile broadband connection ..?

  8. #8
    Join Date
    Mar 2010
    Location
    Lost in Space
    Beans
    100
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Huawei EC1261 does not work with Ubuntu

    Also, does the device work in Ubuntu 10.04(Lucid Lynx)? Please report if anyone has tried using the device on Lucid, as I will upgrade to Lucid if the device is supported.
    Ya I'm using the device in Ubuntu Lucid, but I had to install usbmodswitch from Synaptic like the above posters said. The funny thing is, it was working without installing anything on Ubuntu 9.10. And you said it isn't working on Windows XP, did you try to install the drivers? It should mount a CD image of the drivers and you should be able to install the drivers from a "CD Drive".
    Windows free since March 22, 2010.

  9. #9
    Join Date
    Dec 2009
    Beans
    130
    Distro
    Ubuntu

    Question Re: Huawei EC1261 does not work with Ubuntu

    you can download the latest usb_modeswitch;

    your system should offer to install it for you, and it should auto-configure and change the ID from 1446 to 14ac; you can check that on lsusb
    This is where I am having the problem in understanding. Does the change take place without any user intervention? Should I install this package with the device connected? Also, is installing with Synaptic necessary, as I do not any other mode of internet browsing except for my dial-up connection(which has simply failed in Ubuntu) which works in Windows?

    I do not have a crystal clear understanding of Linux and so I do not have an understanding of these things. So please clarify the above.

    Meanwhile, I was able to install the device in Windows (with much hassle).
    Last edited by jre6; May 26th, 2010 at 02:01 PM.

  10. #10
    Join Date
    Oct 2009
    Location
    A world without windows
    Beans
    Hidden!

    Re: Huawei EC1261 does not work with Ubuntu

    hi if you install the latest pkg's >= 1.1.0 then if the device is listed then no user intervention should be required , if you are a novice follow the links to the Debian site
    you will need two packages , the modeswitch it's self and then the modeswitch-data .

    Debian Repository.

    regards
    alexfish
    Two tin cans are better than an iphone

    http://www.ehow.co.uk/how_2067160_ma...hone.html?cr=1

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •