Results 1 to 9 of 9

Thread: [SOLVED] EVDO modem disconnects after 2min 30sec, help.

  1. #1
    Join Date
    Aug 2008
    Beans
    41

    [SOLVED] EVDO modem disconnects after 2min 30sec, help.

    I am using an LG phone with Verizon as an EVDO modem. Gnome PPP automatically disconnects after 2min 30sec. This is really annoying as I have to Ctrl+tab to Gnome PPP every 2.5 min, and I cannot download anything that takes longer than 2.5 min.

    Phone works fine as modem on Windows.

    I have used almost every setting I can find through GUI. It's now time to get some help.

    Thanks

    P.S. I'm using Hardy Heron.

  2. #2
    Join Date
    Aug 2008
    Beans
    41

    Re: EVDO modem disconnects after 2min 30sec, help.

    Same happens with KPPP

  3. #3
    Join Date
    Aug 2008
    Beans
    41

    Re: EVDO modem disconnects after 2min 30sec, help.

    Can anyone help?

  4. #4
    Join Date
    Aug 2008
    Beans
    41

    Re: EVDO modem disconnects after 2min 30sec, help.

    So many views, so few posts... BUMP!

  5. #5
    Join Date
    Dec 2004
    Location
    Oregon, USA
    Beans
    278
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: EVDO modem disconnects after 2min 30sec, help.

    I think this might help:

    In the file:
    Code:
    /etc/ppp/options
    change the line
    Code:
    lcp-echo-failure 4
    to
    Code:
    #lcp-echo-failure 4
    If I have an apple & I give it to you, still only one of us has an apple. But if I know how to do something & show you how to do it, we both now possess that knowledge. This is the community of GNU/Linux.

  6. #6
    Join Date
    Aug 2008
    Beans
    41

    Re: EVDO modem disconnects after 2min 30sec, help.

    Thanks, I think that worked. I am only a few months into linux, can you tell me how that worked?

  7. #7
    Join Date
    Dec 2004
    Location
    Oregon, USA
    Beans
    278
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: EVDO modem disconnects after 2min 30sec, help.

    The PPP protocol by default periodically checks to make sure the other modem can "hear" it by sending a special packet - an LCP echo request - every so often. If nothing is received in response, it is assumed that the link has been broken & PPP disconnects.

    On some PPP links, yours for instance, this doesn't work properly. Not all remote modems will respond to the LCP echo request. We simply told PPP not to worry if these LCP echo requests are not answered.
    If I have an apple & I give it to you, still only one of us has an apple. But if I know how to do something & show you how to do it, we both now possess that knowledge. This is the community of GNU/Linux.

  8. #8
    Join Date
    Aug 2008
    Beans
    41

    Re: EVDO modem disconnects after 2min 30sec, help.

    cool, thanks again.

  9. #9
    Join Date
    Feb 2008
    Beans
    1

    Re: [SOLVED] EVDO modem disconnects after 2min 30sec, help.

    ModelM you are my saviour,
    it worked like a charm

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •