Results 1 to 5 of 5

Thread: Exim4 sends mail correctly, but wrong "from" address

  1. #1
    Join Date
    Jan 2009
    Beans
    9
    Distro
    Ubuntu

    Exim4 sends mail correctly, but wrong "from" address

    Hello everyone!

    I have a ubuntu server 9.10 installed with exim4 as MTA. I configured a mail address on it (let's say me@example.com). Before i had it working i had a other email configured (let's say me_2@example.com). At the time i had this one it didn't work i removed exim4.

    Now i can successfully send mails with it by the configured me@example.com. I also configured the password for this, but when i receive the mail the old configured mail is presented as "from" (so from: me_2@example.com).

    Anyone knows how this can be changed so it says the mail is from me@example.com? The mail is not an alias, and in a mail client they work separately.

  2. #2
    Join Date
    Nov 2005
    Location
    Bordeaux, France
    Beans
    11,297
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Exim4 sends mail correctly, but wrong "from" address

    How are you sending your email? The From: address is generally configured in your client, independently of the MTA.
    「明後日の夕方には帰ってるからね。」


  3. #3
    Join Date
    Jan 2009
    Beans
    9
    Distro
    Ubuntu

    Re: Exim4 sends mail correctly, but wrong "from" address

    Quote Originally Posted by Bachstelze View Post
    How are you sending your email? The From: address is generally configured in your client, independently of the MTA.
    I'm sending the mail with the CLI of ubuntu server. It's a virtual machine where i connect to from the terminal with ssh

    EDIT:
    Example of how i send it is:
    mail mail_to_send_to@examples.com
    Cc: <empty>
    Subject: test
    message to sent
    .
    user@server:~$
    Last edited by Gambakoker; April 5th, 2010 at 01:29 PM. Reason: Forgot example for mail

  4. #4
    Join Date
    Nov 2005
    Location
    Bordeaux, France
    Beans
    11,297
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Exim4 sends mail correctly, but wrong "from" address

    Then, unless you configured some kind of address rewriting in your MTA, the From: email will be user@host where host is the hostname of te machine and user is your real username on the machine (the same name that is returned by e.g. the whoami command).
    「明後日の夕方には帰ってるからね。」


  5. #5
    Join Date
    Jan 2009
    Beans
    9
    Distro
    Ubuntu

    Re: Exim4 sends mail correctly, but wrong "from" address

    Quote Originally Posted by Bachstelze View Post
    Then, unless you configured some kind of address rewriting in your MTA, the From: email will be user@host where host is the hostname of te machine and user is your real username on the machine (the same name that is returned by e.g. the whoami command).
    If i understand you correctly, i think this isn't the problem. I have a email account specially for the server it is myname.ubuntu@myhost.com, while the email where it's from is completely different, and my username of the server is the same as the myname.ubuntu@hmyhost.com.

    But it's strange i can't find that old email address anywhere anymore so i dont' get where it's getting from.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •