Results 1 to 10 of 10

Thread: Problem with audio card

  1. #1
    Join Date
    May 2009
    Location
    Italy
    Beans
    18
    Distro
    Ubuntu 9.10 Karmic Koala

    Problem with audio card

    Hi to all.

    I am having troubles with my audio card:

    Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

    I can hear sound when I plug my headphones but I cannot hear any sound when I unplug them.
    I know that Ubuntu has got problems with pulseaudio. So I removed pulseaudio using Synaptic, I restarted the system but still no sound.

    I attach the output of dmesg (dmesg.odt)

    Thanks for your attention.
    Regards.

    Ubuntu 9.10
    kernel 2.6.31-17-generic
    alsa-base 1.0.20+dfsg-1ubuntu5
    NETBOOK: Toshiba NB200
    Attached Files Attached Files
    Last edited by Freelife; January 24th, 2010 at 12:56 PM. Reason: add model netbook

  2. #2
    Join Date
    Jan 2005
    Location
    Oshawa, ON CANADA
    Beans
    199
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Problem with audio card

    Pulse audio has nothing to do with this, you can remove it altogether...

    How many physical outputs do you have on your card? is it possible you're plugging the headphones where the speakers should go?

    Check using alsamixer in terminal, using F4 and F3 to switch between playback/recording, adjust/enable/disable channels as necessary (using the M and space bar to toggle options, while speakers and headphones are plugged in.

    Once satisfied, issue: sudo alsactl store (to save your settings)
    What in tarnation is antivirus?

  3. #3
    Join Date
    May 2009
    Location
    Italy
    Beans
    18
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Problem with audio card

    Quote Originally Posted by tripolitan View Post
    Pulse audio has nothing to do with this, you can remove it altogether...

    How many physical outputs do you have on your card? is it possible you're plugging the headphones where the speakers should go?

    Check using alsamixer in terminal, using F4 and F3 to switch between playback/recording, adjust/enable/disable channels as necessary (using the M and space bar to toggle options, while speakers and headphones are plugged in.

    Once satisfied, issue: sudo alsactl store (to save your settings)

    Thanks for your reply,
    but the situation has not changed, however the alsamixer's parameters are:
    100% :"Master", "Headphone", "Pcm" and "Mic"
    and
    0 % : "IEC958" and " IEC958 D"(I can not change them).

    Help me, please!

    P.D.
    It is a Netbook (Toshiba NB200)
    Last edited by Freelife; January 24th, 2010 at 10:00 PM. Reason: add P.D.

  4. #4
    Join Date
    May 2009
    Location
    Italy
    Beans
    18
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Problem with audio card

    I attaching the contents of two files:
    1) alsa.conf
    2) pulse-alsa.conf

    Help!!!
    Attached Files Attached Files
    Last edited by Freelife; January 24th, 2010 at 11:53 PM.

  5. #5
    Join Date
    May 2009
    Location
    Italy
    Beans
    18
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Problem with audio card

    Up

  6. #6
    Join Date
    Jun 2007
    Beans
    11,011

    Re: Problem with audio card

    Try
    1. Upgrade to latest ALSA: http://ubuntuforums.org/showthread.php?t=1046137
    2. Specify model keyword
    Code:
    gksu gedit /etc/modprobe.d/alsa-base.conf
    Add the following line at the end of alsa-base.conf file:
    Code:
    options snd-hda-intel model=asus-mode4

    http://www.gossamer-threads.com/list...kernel/1134970

  7. #7
    Join Date
    May 2009
    Location
    Italy
    Beans
    18
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Problem with audio card

    Quote Originally Posted by Temüjin View Post
    Try
    1. Upgrade to latest ALSA: http://ubuntuforums.org/showthread.php?t=1046137
    2. Specify model keyword
    Code:
    gksu gedit /etc/modprobe.d/alsa-base.conf
    Add the following line at the end of alsa-base.conf file:
    Code:
    options snd-hda-intel model=asus-mode4

    http://www.gossamer-threads.com/list...kernel/1134970
    Hello,
    thanks for your answer!

    To update alsa i preferred to follow this guide:
    http://monespaceperso.org/blog-en/20...ic-koala-9-10/

    I added in alsa-base.conf
    Code:
    options snd-hda-intel model=asus-mode4
    (I enclose alsa-base.conf)

    Now i have alsa 1.0.22.1 but nothing has changed
    Attached Files Attached Files

  8. #8
    Join Date
    Jun 2007
    Beans
    11,011

    Re: Problem with audio card

    You should contact the ALSA developers then, and provide information from this script: http://ubuntuforums.org/attachment.p...0&d=1262704706

  9. #9
    Join Date
    May 2009
    Location
    Italy
    Beans
    18
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Problem with audio card

    Quote Originally Posted by Temüjin View Post
    You should contact the ALSA developers then, and provide information from this script: http://ubuntuforums.org/attachment.p...0&d=1262704706

    This is the needed results:
    http://www.alsa-project.org/db/?f=4a...6638fe41afadb7

    Who sent him?

  10. #10
    Join Date
    May 2009
    Location
    Italy
    Beans
    18
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Problem with audio card

    I made another attempt:

    1) :~$ gksu gedit /etc/modprobe.d/alsa-base.conf
    and i try one at a time:
    model=asus-mode4*
    model=asus-mode5
    model=asus-mode6
    model=3stack-6ch-dig

    2):~$ sudo alsa force-reload

    3):~$ speaker-test -c2 -D hw:0,0 -t wav -l1

    4)I have whit all:
    playback open error: -16,Device or resource busy
    and i can't hear sound.

    *I have: no error and when running speaker headphones, i can hear

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •