Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Wireless stops working when lid is closed.

  1. #1
    Join Date
    Jan 2008
    Beans
    4

    Wireless stops working when lid is closed.

    I am currently running Ubuntu 8.04 on my Lenovo T61p. Whenever I close my laptop lid the wireless seems to stop working after a certain amount of time. I currently have it set to put up a blank screen and do nothing else when the lid is closed. Its also worth noting that my laptop is plugged in.

    This is most frustrating when trying to upgrade to ubuntu 8.10, I will close my lid to let the update run but when I come back the wireless is broken and the update is nowhere near finished.

    Any help or suggestions would be greatly appreciated.

    Thanks

    Matthew

  2. #2
    Join Date
    Dec 2006
    Location
    Tucson, AZ
    Beans
    12
    Distro
    Kubuntu 6.10 Edgy

    Re: Wireless stops working when lid is closed.

    Bump for this. I've recently noticed the same problem. It doesn't happen every time, but it happens often enough to be annoying as it kills my connection for long enough to interrupt any programs that rely on it (Bittorrent, IM, access to my NAS, etc.)

    I'm using an Asus G1 laptop running 8.10.

  3. #3
    Join Date
    May 2007
    Beans
    125

    Re: Wireless stops working when lid is closed.

    I don't have a specific solution, but this sounds like a power management issue to me. I'd try tweaking the power management settings to see if this fixes it.

  4. #4
    Join Date
    Aug 2006
    Location
    Sligo, Ireland
    Beans
    306
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Wireless stops working when lid is closed.

    I'm having this problem also. On Ubuntu 9.04 on a Dell XPS M1330.

    After opening, the wifi, although it appears to be connected, isn't and I must turn it off and on again (the wifi) to connect again.

    There are no power management options for this kind of behaviour
    My Blog : http://shanetuohy.com
    Linux Counter #425464 ------- Ubuntu Counter # 7082
    Beware of blindly copying and pasting into the terminal

  5. #5
    Join Date
    Sep 2007
    Beans
    40

    Re: Wireless stops working when lid is closed.

    Same problem with a T-1625 Gateway, and Realtek 8187b.Out of the box wireless doesn't work right, but after installing linux-backport-modules, everything seems nice, except for this issue. Using Jaunty 32 bits, on a AMD Turion X2 64, maybe that'the problem? Doesn't have any experience with 64 bits systems.

  6. #6
    Join Date
    Apr 2007
    Beans
    115
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Wireless stops working when lid is closed.

    same problem here

    UPDATE: i disabled the screensaver when the lid closes or after a period of inactivity from power management options. Now everything works normal and there are no disconnections on the wifi so far.
    Last edited by micdhack; July 7th, 2009 at 02:10 PM.

  7. #7
    Join Date
    Aug 2008
    Beans
    3

    Re: Wireless stops working when lid is closed.

    Quote Originally Posted by micdhack View Post
    same problem here

    UPDATE: i disabled the screensaver when the lid closes or after a period of inactivity from power management options. Now everything works normal and there are no disconnections on the wifi so far.
    I have same problem with lid and wifi. My notebook is a HP COMPAQ F760 LA. AMD TURION 64. 2gb RAM, nvidia, wifi broadcom.
    With 8.04 it worked fine, but with 9.04.

    How did it do?. How to disalbed the screensaver when lid closes?.

  8. #8
    Join Date
    Aug 2008
    Beans
    3

    Re: Wireless stops working when lid is closed.

    I did a clean install of Kubuntu 9.10.
    This problem persists.
    I tried this
    $ ping www.google.com.ar
    PING www.l.google.com (74.125.67.105) 56(84) bytes of data.
    64 bytes from gw-in-f105.1e100.net (74.125.67.105): icmp_seq=1 ttl=50 time=193 ms
    64 bytes from gw-in-f105.1e100.net (74.125.67.105): icmp_seq=2 ttl=50 time=190 ms
    64 bytes from gw-in-f105.1e100.net (74.125.67.105): icmp_seq=3 ttl=50 time=193 ms
    64 bytes from gw-in-f105.1e100.net (74.125.67.105): icmp_seq=4 ttl=50 time=194 ms
    ------- here close the lid --------
    64 bytes from 74.125.67.105: icmp_seq=5 ttl=50 time=195 ms
    ping: sendmsg: No buffer space available
    ping: sendmsg: No buffer space available
    .
    .
    .
    ping: sendmsg: No buffer space available
    ping: sendmsg: No buffer space available
    From nblinux.local (192.168.1.34) icmp_seq=89 Destination Host Unreachable
    From nblinux.local (192.168.1.34) icmp_seq=90 Destination Host Unreachable
    From nblinux.local (192.168.1.34) icmp_seq=91 Destination Host Unreachable
    ------ here open the lid --------
    64 bytes from gw-in-f105.1e100.net (74.125.67.105): icmp_seq=93 ttl=50 time=638 ms
    64 bytes from gw-in-f105.1e100.net (74.125.67.105): icmp_seq=94 ttl=50 time=261 ms
    64 bytes from gw-in-f105.1e100.net (74.125.67.105): icmp_seq=95 ttl=50 time=375 ms
    64 bytes from gw-in-f105.1e100.net (74.125.67.105): icmp_seq=96 ttl=50 time=1068 ms

  9. #9
    Join Date
    Aug 2008
    Beans
    3

    Re: Wireless stops working when lid is closed.

    I did a clean install of Kubuntu 9.10.
    This problem persists.
    I tried this
    $ ping www.google.com.ar
    PING www.l.google.com (74.125.67.105) 56(84) bytes of data.
    64 bytes from gw-in-f105.1e100.net (74.125.67.105): icmp_seq=1 ttl=50 time=193 ms
    64 bytes from gw-in-f105.1e100.net (74.125.67.105): icmp_seq=2 ttl=50 time=190 ms
    64 bytes from gw-in-f105.1e100.net (74.125.67.105): icmp_seq=3 ttl=50 time=193 ms
    64 bytes from gw-in-f105.1e100.net (74.125.67.105): icmp_seq=4 ttl=50 time=194 ms
    ------- here close the lid --------
    64 bytes from 74.125.67.105: icmp_seq=5 ttl=50 time=195 ms
    ping: sendmsg: No buffer space available
    ping: sendmsg: No buffer space available
    .
    .
    .
    ping: sendmsg: No buffer space available
    ping: sendmsg: No buffer space available
    From nblinux.local (192.168.1.34) icmp_seq=89 Destination Host Unreachable
    From nblinux.local (192.168.1.34) icmp_seq=90 Destination Host Unreachable
    From nblinux.local (192.168.1.34) icmp_seq=91 Destination Host Unreachable
    ------ here open the lid --------
    64 bytes from gw-in-f105.1e100.net (74.125.67.105): icmp_seq=93 ttl=50 time=638 ms
    64 bytes from gw-in-f105.1e100.net (74.125.67.105): icmp_seq=94 ttl=50 time=261 ms
    64 bytes from gw-in-f105.1e100.net (74.125.67.105): icmp_seq=95 ttl=50 time=375 ms
    64 bytes from gw-in-f105.1e100.net (74.125.67.105): icmp_seq=96 ttl=50 time=1068 ms

    ScreenSaver is Off
    In powermanagement "When Lid Close: do nothing"

  10. #10
    Join Date
    Aug 2008
    Location
    San Juan, Argentina
    Beans
    137
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wireless stops working when lid is closed.

    Hi ppl
    I'm having the same trouble with my Toshiba Satellite Pro L300D-SP5802 laptop.
    I've the latest Karmic Koala 9.10 version, with screensaver off, dark screen on lid close (power management settings) , etc. but I keep being disconnected from my wireless connection when I close the laptop lid

    Any solutions yet?
    Thanks,
    Enrique Becerra
    @kabeza
    Beza

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •