Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: No sound on Lenovo T61 with KArmic Koala

  1. #1
    Join Date
    Nov 2009
    Location
    Denmark
    Beans
    50
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Question No sound on Lenovo T61 with KArmic Koala

    Hi all,

    Im a complete newbie to ubuntu and linux in general. Having wiped my Vista and replaced it with Ubuntu, I'm facing an annoying problem.

    Theres no audio at all. I have tried to toggle almost all switches in the sound controls. I have tried to run alsamixer to crank everything to max. with no result

    Having googled without getting an answer, I'm now desperate!

    What to do and what to check?

    alsamixer reports : Card: HDA Intel, Chip: Analog Devices AD1984

  2. #2
    Join Date
    Nov 2009
    Location
    Denmark
    Beans
    50
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: No sound on Lenovo T61 with KArmic Koala

    amixer -l gives:
    Code:
    Simple mixer control 'Master',0
      Capabilities: pvolume pvolume-joined pswitch pswitch-joined
      Playback channels: Mono
      Limits: Playback 0 - 39
      Mono: Playback 39 [100%] [0.00dB] [on]
    Simple mixer control 'Headphone',0
      Capabilities: pswitch
      Playback channels: Front Left - Front Right
      Mono:
      Front Left: Playback [on]
      Front Right: Playback [on]
    Simple mixer control 'PCM',0
      Capabilities: pvolume
      Playback channels: Front Left - Front Right
      Limits: Playback 0 - 39
      Mono:
      Front Left: Playback 39 [100%] [0.00dB]
      Front Right: Playback 39 [100%] [0.00dB]
    Simple mixer control 'Mic',0
      Capabilities: pvolume pswitch
      Playback channels: Front Left - Front Right
      Limits: Playback 0 - 31
      Mono:
      Front Left: Playback 31 [100%] [12.00dB] [off]
      Front Right: Playback 31 [100%] [12.00dB] [off]
    Simple mixer control 'Mic Boost',0
      Capabilities: volume
      Playback channels: Front Left - Front Right
      Capture channels: Front Left - Front Right
      Limits: 0 - 3
      Front Left: 3 [100%]
      Front Right: 3 [100%]
    Simple mixer control 'IEC958',0
      Capabilities: pvolume pswitch pswitch-joined
      Playback channels: Front Left - Front Right
      Limits: Playback 0 - 39
      Mono:
      Front Left: Playback 39 [100%] [0.00dB] [off]
      Front Right: Playback 39 [100%] [0.00dB] [off]
    Simple mixer control 'IEC958 Default PCM',0
      Capabilities: pswitch pswitch-joined
      Playback channels: Mono
      Mono: Playback [on]
    Simple mixer control 'IEC958 Playback Source',0
      Capabilities: enum
      Items: 'PCM' 'ADC'
      Item0: 'ADC'
    Simple mixer control 'Capture',0
      Capabilities: cvolume cswitch
      Capture channels: Front Left - Front Right
      Limits: Capture 0 - 54
      Front Left: Capture 39 [72%] [0.00dB] [off]
      Front Right: Capture 39 [72%] [0.00dB] [off]
    Simple mixer control 'Capture',1
      Capabilities: cvolume cswitch
      Capture channels: Front Left - Front Right
      Limits: Capture 0 - 54
      Front Left: Capture 39 [72%] [0.00dB] [off]
      Front Right: Capture 39 [72%] [0.00dB] [off]
    Simple mixer control 'Beep',0
      Capabilities: pvolume pvolume-joined pswitch pswitch-joined
      Playback channels: Mono
      Limits: Playback 0 - 15
      Mono: Playback 15 [100%] [0.00dB] [off]
    Simple mixer control 'Docking Mic',0
      Capabilities: pvolume pswitch
      Playback channels: Front Left - Front Right
      Limits: Playback 0 - 31
      Mono:
      Front Left: Playback 0 [0%] [-34.50dB] [off]
      Front Right: Playback 0 [0%] [-34.50dB] [off]
    Simple mixer control 'Docking Mic Boost',0
      Capabilities: volume
      Playback channels: Front Left - Front Right
      Capture channels: Front Left - Front Right
      Limits: 0 - 3
      Front Left: 0 [0%]
      Front Right: 0 [0%]
    Simple mixer control 'Input Source',0
      Capabilities: cenum
      Items: 'Mic' 'Internal Mic' 'Mix' 'Docking-Station'
      Item0: 'Mic'
    Simple mixer control 'Input Source',1
      Capabilities: cenum
      Items: 'Mic' 'Internal Mic' 'Mix' 'Docking-Station'
      Item0: 'Mic'
    Simple mixer control 'Internal Mic',0
      Capabilities: pvolume pswitch
      Playback channels: Front Left - Front Right
      Limits: Playback 0 - 31
      Mono:
      Front Left: Playback 0 [0%] [-34.50dB] [off]
      Front Right: Playback 0 [0%] [-34.50dB] [off]
    Simple mixer control 'Internal Mic Boost',0
      Capabilities: volume
      Playback channels: Front Left - Front Right
      Capture channels: Front Left - Front Right
      Limits: 0 - 3
      Front Left: 0 [0%]
      Front Right: 0 [0%]
    Simple mixer control 'Speaker',0
      Capabilities: pswitch
      Playback channels: Front Left - Front Right
      Mono:
      Front Left: Playback [off]
      Front Right: Playback [off]
    cat /proc/asound/card :
    Code:
     0 [Intel          ]: HDA-Intel - HDA Intel
                          HDA Intel at 0xfe020000 irq 17
    cat /proc/asound/devices:
    Code:
      2:        : timer
      3:        : sequencer
      4: [ 0- 1]: digital audio playback
      5: [ 0- 0]: digital audio playback
      6: [ 0- 0]: digital audio capture
      7: [ 0- 0]: hardware dependent
      8: [ 0]   : control

  3. #3
    Join Date
    Nov 2009
    Location
    Denmark
    Beans
    50
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: No sound on Lenovo T61 with KArmic Koala

    I have tried the following with no result:
    Code:
    sudo apt-get remove --purge alsa-base
    sudo apt-get remove --purge pulseaudio
    sudo apt-get install alsa-base
    sudo apt-get install pulseaudio
    sudo alsa force-reload
    Code:
    cat /proc/asound/cards
    still give the same result as in the original post.

    Tried:
    Code:
    sudo gedit /etc/modprobe.d/alsa-base-conf
    and commented out
    Code:
    # options snd-hda-intel power_save=10 power_save_controller=N
    and added a new line
    Code:
    options snd-hda-intel probe_mask=1 model=thinkpad
    Still i get no sound. HELP!!! Im getting desperate

  4. #4
    Join Date
    Sep 2009
    Beans
    8

    Re: No sound on Lenovo T61 with KArmic Koala

    Quote Originally Posted by venturax View Post
    I have tried the following with no result:
    Code:
    sudo apt-get remove --purge alsa-base
    sudo apt-get remove --purge pulseaudio
    sudo apt-get install alsa-base
    sudo apt-get install pulseaudio
    sudo alsa force-reload
    Code:
    cat /proc/asound/cards
    still give the same result as in the original post.

    Tried:
    Code:
    sudo gedit /etc/modprobe.d/alsa-base-conf
    and commented out
    Code:
    # options snd-hda-intel power_save=10 power_save_controller=N
    and added a new line
    Code:
    options snd-hda-intel probe_mask=1 model=thinkpad
    Still i get no sound. HELP!!! Im getting desperate
    options snd-hda-intel probe_mask=1 model=thinkpad
    i think this shud be
    options snd-hda-intel probe_mask=1 model=laptop


    another thing ..i m sure u must having sound wen u plug in ur headphones.....is it ?

  5. #5
    Join Date
    Nov 2009
    Location
    Denmark
    Beans
    50
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: No sound on Lenovo T61 with KArmic Koala

    Quote Originally Posted by nigamp View Post
    options snd-hda-intel probe_mask=1 model=thinkpad
    i think this shud be
    options snd-hda-intel probe_mask=1 model=laptop


    another thing ..i m sure u must having sound wen u plug in ur headphones.....is it ?
    Tried it and no luck. Theres no sound in the headphones either

  6. #6
    Join Date
    Feb 2008
    Location
    Greece
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Lightbulb Re: No sound on Lenovo T61 with KArmic Koala

    Try : 'options snd-hda-intel model=auto' and let Ubuntu get the type of the card from the BIOS.It's the safest way.

  7. #7
    Join Date
    Nov 2009
    Location
    Denmark
    Beans
    50
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: No sound on Lenovo T61 with KArmic Koala

    Quote Originally Posted by klemes View Post
    Try : 'options snd-hda-intel model=auto' and let Ubuntu get the type of the card from the BIOS.It's the safest way.
    Also tried this, but still no sound. I will try to make a live cd of hardy to see if audio works in a previous edition... *sigh*

    I would hate to migrate back to Vista, but I just cant do without audio.

  8. #8
    Join Date
    Mar 2009
    Location
    Melbourne
    Beans
    16
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: No sound on Lenovo T61 with KArmic Koala

    Have you read this? (I had no audio in my t61 after 9.10 install, and this fixed it)
    Karmic. Pluseaudio home folder is not ours

    there's also this one:
    sound-card-not-detected-ubuntu-910-fix-it
    Hope that keeps you from goin' back to windoze

  9. #9
    Join Date
    Nov 2009
    Location
    Denmark
    Beans
    50
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: No sound on Lenovo T61 with KArmic Koala

    Still no love

    I will try to brun the Koala iso again and run entirely from the CD, to see if somehow i have screwed up something.. Will also try with an older version as well..

    Will post the results.

    Thanks all for the help so far. Really appriciated

  10. #10
    Join Date
    Dec 2008
    Beans
    3

    Re: No sound on Lenovo T61 with KArmic Koala


Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •