Page 1 of 13 12311 ... LastLast
Results 1 to 10 of 128

Thread: Madwifi installation for Atheros card in Karmic koala

  1. #1
    Join Date
    Apr 2009
    Location
    Mangalore India
    Beans
    803
    Distro
    Kubuntu 14.04 Trusty Tahr

    Madwifi installation for Atheros card in Karmic koala

    Hi guys in this thread you will the instructions to install Madwifi drivers for Atheros wireless cards. Please follow the instructions to the word.

    Open the 'terminal' by navigating through Applications-->Accessories--> Terminal

    Now type the following commands in terminal

    1.
    Code:
    sudo nano /etc/apt/sources.list
    From there make sure you uncomment anything that starts with "deb" in there. So changer it from "#deb" to "deb" Something along thoes lines. To exit and save hit "CTRL+X" the answer "YES" to do you want to save, then finally hit "ENTER"

    2.
    Code:
    sudo apt-get update && sudo apt-get upgrade
    3.
    Code:
    sudo apt-get install build-essential libssl-dev
    4.
    Code:
    sudo apt-get install linux-headers-`uname -r`
    5.
    Code:
    sudo apt-get install subversion
    6.
    Code:
    sudo -i
    7.
    Code:
    sudo svn checkout http://svn.madwifi-project.org/madwifi/trunk/ madwifi-ng
    8.
    Code:
    cd madwifi-ng
    9.
    Code:
    echo "" >> /etc/modprobe.d/blacklist
    10.
    Code:
    echo "#Remove To Install MadWIFI Drivers" >> /etc/modprobe.d/blacklist
    11.
    Code:
    echo "blacklist ath9k" >> /etc/modprobe.d/blacklist
    12.
    Code:
    echo "blacklist ath5k" >> /etc/modprobe.d/blacklist
    13.
    Code:
    make && make install
    14.
    Code:
    echo ath_pci >> /etc/modules
    Restart your machine.
    It should work

    Well i use Wicd to connect to the wireless modem
    To install Wicd type the following commands in terminal
    Code:
    sudo apt-get update
    Code:
    sudo apt-get install wicd

    Kernal updates of your system will kill your driver. Well no need to worry about that.Just recompile your driver.
    For that you open a terminal and type the command
    Code:
    sudo -i
    and just repeat the steps from No 8. Your madwifi will cone back to life again.

    Best of Luck
    Dr Kurian
    Last edited by drpjkurian; December 6th, 2009 at 10:22 AM.

  2. #2
    Join Date
    Oct 2009
    Beans
    15

    Re: Madwifi installation for Atheros card in Karmic koala

    Amazing. It just worked (not that I didn't expect it to, but I've learned not to have too high hopes for these things) - and you just saved me hours of frustration. Thank you very, very much.

  3. #3
    Join Date
    Jan 2006
    Beans
    53

    Re: Madwifi installation for Atheros card in Karmic koala

    Previously, I hadn't tried to use the SVN snapshot; I was hopeful that this would fix my problem. However, I get the same results: it continually asks for my password. Every now and then, it actually connects, but it is HORRIBLY slow. It never failed me in Jaunty (or before).

    Any ideas?

    Thanks,
    Josh

  4. #4
    Join Date
    Jan 2006
    Beans
    53

    Re: Madwifi installation for Atheros card in Karmic koala

    I decided to give wicd a try in hopes that it would solve my problem. It seems to get past the WPA stuff just fine. It just sits forever at "Obtaining IP Address..."

    Josh

  5. #5
    Join Date
    Oct 2009
    Beans
    15

    Re: Madwifi installation for Atheros card in Karmic koala

    Try going to "preferences" and change from "madwifi" to "wext" - that has worked for me previously.

  6. #6
    Join Date
    Jul 2006
    Beans
    109

    Re: Madwifi installation for Atheros card in Karmic koala

    After doing this, I can't even turn my wireless card on...

  7. #7
    Join Date
    Apr 2009
    Location
    Mangalore India
    Beans
    803
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Madwifi installation for Atheros card in Karmic koala

    Quote Originally Posted by jshayden View Post
    I decided to give wicd a try in hopes that it would solve my problem. It seems to get past the WPA stuff just fine. It just sits forever at "Obtaining IP Address..."

    Josh
    Hi
    I think yours is not a problem of a driver.How is it after Wicd?

    With regards
    Dr Kurian

  8. #8
    Join Date
    Nov 2009
    Beans
    1

    Re: Madwifi installation for Atheros card in Karmic koala

    Hi mates!

    First of all, thanks for the info. I was trying to install dis madwifi driver by my own and was going nuts! It just worked perfectly!

    The problem is that now i cant connect to any network and even the signal is much slower than before.

    My question: How can i go back to my old driver? I don't really know which one i was using, but i'm running Koala on a Macbook pro 1,1, wich has an Atheros 5424.

    May somebody help me please? i know i know... why i'm touching what i don't understand? I'm a geek i can not do anything else!

  9. #9
    Join Date
    Jan 2007
    Location
    Colorado
    Beans
    35
    Distro
    Ubuntu

    Re: Madwifi installation for Atheros card in Karmic koala

    Thank you drpjkurian!!! I am able to now connect to wireless networks via command line. Neither wicd or network-manager will recognize my AR5212 Atheros wireless card, but using the command line, I can access wireless by specifying the following (as root):

    Code:
    ## scan for wireless networks
    $ iwlist ath0 scanning
    $ iwconfig ath0 essid routerName key yourWepKey
    ## if you can't connect to your router, try obtaining an IP via dhcp:
    $ dhclient aht0
    Thanks again!

  10. #10
    Join Date
    Nov 2008
    Beans
    26

    Re: Madwifi installation for Atheros card in Karmic koala

    drpjkurian, I've had the same problem as everyone else with 9.10. My wifi is rediculesly slow. 9.04 was excellent. I was just about to go back to 9.04 when I saw the link to this thread. This is the kind of C**P that makes me nervious but I had nothing to lose anyway so I tried it. My internet is noticably faster. I have not tried it away fron home yet but I see no reason that it would be different anywhere else. Thanks for the help. My wifi is near normal now. It still amazes me that 9.10 was released with such a blatent flaw! Internet is the root of using a computer! Whoever released 9.10 too early deserves a kick in the ***! Once again, Thanks.

Page 1 of 13 12311 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •