Page 1 of 9 123 ... LastLast
Results 1 to 10 of 84

Thread: Using PVR150 IR Blaster In Mythbuntu 9.10b

  1. #1
    Join Date
    Nov 2006
    Beans
    11

    Using PVR150 IR Blaster In Mythbuntu 9.10b

    Working on setting up a new box with Mythbuntu 9.10 beta.

    Everything's working pretty well so far - including my remote - but I can't get the blaster to work on my PVR150. (The vanilla 3.5mm blaster, not the MCE USB one.)

    I won't go on about what I've done, but basically I think I just need the LIRC_PVR150 kernel module.

    Where do I get that? How do I load it?
    Do I have to recompile the kernel? Or LIRC?

    Almost everything I've found on this references this page: http://www.blushingpenguin.com/mark/blog/?p=24
    That would be a great help, but the pre-patched version of LIRC he provides won't compile with the new kernel.

    I feel like I'm just missing something simple, but I can't figure out what. Any help would be great!

  2. #2
    Join Date
    Jan 2008
    Beans
    200

    Re: Using PVR150 IR Blaster In Mythbuntu 9.10b

    This won't help you much, but I could get the Hauppauge HVR-1600 remote to even be found in Ubuntu 9.10 with all of the updates as of today. I had to put the old Hauppauge PVR-150 card in and it is now - at least found.

    dmesg | grep lirc

    [ 13.477963] lirc_dev: IR Remote Control driver registered, major 61
    [ 13.824620] lirc_i2c: chip 0x10020 found @ 0x71 (Hauppauge PVR150)
    [ 13.824623] lirc_dev: lirc_register_driver: sample_rate: 10

    Still not finding the HVR-1600 but at least the remote for me now works.

    In your case, try to run "sudo dpkg-reconfigure lirc" and ensure that when it asks on the second page about the IR transmitter, choose the correct one you will be using it with.

  3. #3
    Join Date
    Nov 2006
    Beans
    11

    Re: Using PVR150 IR Blaster In Mythbuntu 9.10b

    Unfortunately, the Hauppauge transmitter doesn't appear to be an option when I run "dpkg-reconfigure lirc".

    I'm pretty sure it was there in at least one of the earlier Mythbuntu versions, but it's not in 9.10.

    Thanks though.

  4. #4
    Join Date
    Jan 2008
    Beans
    200

    Re: Using PVR150 IR Blaster In Mythbuntu 9.10b

    Wow, that is strange. I am running Ubuntu 9.10 (instead of Mythbuntu) and when I do the "sudo dpkg-reconfigure lirc" command, the first page that comes up is the information for the IR receiver. It lists many different cards - and there should be an entry (in alphabetical order) where it says "Hauppauge TV Card".

  5. #5
    Join Date
    Nov 2006
    Beans
    11

    Re: Using PVR150 IR Blaster In Mythbuntu 9.10b

    Oh yeah, the Hauppage card is there on the first screen, under Receivers. But it's the Transmitter I need (the next screen), and I don't see it there.

  6. #6
    Join Date
    Jan 2008
    Beans
    200

    Re: Using PVR150 IR Blaster In Mythbuntu 9.10b

    Yes, you will not see the Hauppauge TV Card under the transmitter. In that list, you need to select the box that the transmitter will control - this would be the make/model of the device that your cable company or satellite company provided you.

  7. #7
    Join Date
    Oct 2009
    Location
    Virginia US
    Beans
    46
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Using PVR150 IR Blaster In Mythbuntu 9.10b

    Hi All,

    Could some one point to the info reg setting up the IR Blaster ( MCE USB Version) with PVR-150 in 9.0.4 version.

    Thanks
    mars

  8. #8
    Join Date
    Nov 2006
    Beans
    11

    Re: Using PVR150 IR Blaster In Mythbuntu 9.10b

    Quote Originally Posted by bsntech View Post
    Yes, you will not see the Hauppauge TV Card under the transmitter. In that list, you need to select the box that the transmitter will control - this would be the make/model of the device that your cable company or satellite company provided you.
    I don't think that's it. It asks you to select the combination of transmitter and STB.
    I do have a Motorola Cable box, but I'm pretty sure my transmitter doesn't fit in to any of the options provided.
    If I were to choose the wrong one, /etc/lirc/hardware.conf is filled in incorrectly, and it doesn't work. Choosing "None" or "Custom" just creates a blank hardware.conf.

    None
    Custom
    Command IR : Direct TV Receiver
    Command IR : Dish Receiver
    Command IR : Motorola Cable box
    Command IR : Pioneer Cable box
    Command IR : Scientific Atlanta Cable box
    Command IR : Sky Satellite Receiver
    Microsoft Windows Media Center V2 (usb) : Direct TV Receiver
    Microsoft Windows Media Center V2 (usb) : Dish Receiver
    Microsoft Windows Media Center V2 (usb) : Motorola Cable box
    Microsoft Windows Media Center V2 (usb) : Pioneer Cable box
    Microsoft Windows Media Center V2 (usb) : Scientific Atlanta Cable box
    Microsoft Windows Media Center V2 (usb) : Sky Satellite Receiver
    Serial Port (UART) : Direct TV Receiver
    Serial Port (UART) : Dish Receiver
    Serial Port (UART) : Motorola Cable box
    Serial Port (UART) : Pioneer Cable box
    Serial Port (UART) : Scientific Atlanta Cable box
    Serial Port (UART) : Sky Satellite Receiver
    USB-UIRT2 : Direct TV Receiver
    USB-UIRT2 : Dish Receiver
    USB-UIRT2 : Motorola Cable box
    USB-UIRT2 : Pioneer Cable box
    USB-UIRT2 : Scientific Atlanta Cable box
    USB-UIRT2 : Sky Satellite Receiver

  9. #9
    Join Date
    May 2008
    Beans
    12

    Re: Using PVR150 IR Blaster In Mythbuntu 9.10b

    Quote Originally Posted by sentinel23 View Post
    Where do I get that? How do I load it?
    Do I have to recompile the kernel? Or LIRC?

    Almost everything I've found on this references this page: http://www.blushingpenguin.com/mark/blog/?p=24
    That would be a great help, but the pre-patched version of LIRC he provides won't compile with the new kernel.

    I feel like I'm just missing something simple, but I can't figure out what. Any help would be great!

    I am in the same situation and it appears I have tried the same steps as you. Has anyone been able to figure this out yet?

  10. #10
    Join Date
    Nov 2006
    Beans
    11

    Re: Using PVR150 IR Blaster In Mythbuntu 9.10b

    Quote Originally Posted by stong98 View Post
    I am in the same situation and it appears I have tried the same steps as you. Has anyone been able to figure this out yet?
    Thanks for posting... I knew I couldn't possibly be alone on this.

    No solution yet. I'm thinking we just need someone (smarter than me, apparently) to patch LIRC the same way that that guy Mark did in that link.

    Please let us know if you find anything.

Page 1 of 9 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •