Results 1 to 3 of 3

Thread: AppArmor module fails to load at boot (kernel 2.6.31 with Ubuntu patch 11.36)

  1. #1
    Join Date
    Sep 2009
    Location
    Cebu, Philippines
    Beans
    43
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    AppArmor module fails to load at boot (kernel 2.6.31 with Ubuntu patch 11.36)

    Hello!

    I have succeeded in compiling, installing, and booting from a 2.6.31 kernel in Jaunty. But when I look at the startup screens, it says
    Code:
    loading AppArmor module... FAILED
    . When I finally get into the desktop, then into a terminal, I look up the apparmor_status and here's the output:
    Code:
    $apparmor_status
    apparmor module is loaded.
    apparmor filesystem is not mounted.
    Is this a conflicting report, considering that it FAILED at bootup? Is there something wrong?

    Going back to the top of my source tree, I do a
    Code:
    make menuconfig
    I go into Ubuntu Supplied Third Party Drivers --> and yes, AppArmor support is set as built-in. AppArmor boot parameter default value is 1, meaning, "start during boot up". Well I read an AppArmor bug report here apparmor fails to load at startup. It refers to kernel 2.6.30. I don't know if it holds true for the patched 2.6.31 (Ubuntu patch 11.36)

  2. #2
    Join Date
    Jan 2008
    Beans
    4,757

    Re: AppArmor module fails to load at boot (kernel 2.6.31 with Ubuntu patch 11.36)

    Hi mo0nykit,

    Try downloading the Linux sources again, as it now appears to have been fixed in Ubuntu.
    see: https://bugs.launchpad.net/ubuntu/+s...ux/+bug/375422

    To download the 2.6.31 kernel, get it here: http://archive.ubuntu.com/ubuntu/poo...31.orig.tar.gz
    And the ubuntu patches (that include apparmor) you can get here: http://archive.ubuntu.com/ubuntu/poo...-11.38.diff.gz

    Regards
    Iain

  3. #3
    Join Date
    Sep 2009
    Location
    Cebu, Philippines
    Beans
    43
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: AppArmor module fails to load at boot (kernel 2.6.31 with Ubuntu patch 11.36)

    Thank you very much I'll give it another try.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •