Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Fix Ubuntu 9.04 ATI Driver Issue

  1. #1
    Join Date
    Aug 2009
    Beans
    12
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Fix Ubuntu 9.04 ATI Driver Issue

    UPDATED 06.10.09

    This acctually works!
    I did it and got my raedon9800pro working in Ubuntu 9.04

    This tutorial is a bit different than the normal one on wiki ubuntu:
    https://wiki.ubuntu.com/ReinhardTart...telDriverTo2.4

    All credits goes to Tyler how made this tutorial.
    Source: http://tan-com.com/posts/technology/...i-driver-issue

    Here is what I found:

    Tutorial made by: Tyler

    With the newest realease of Ubuntu (9.04 Jaunty Jackalope) came a major problem with support for older ATI graphics cards. Though these cards work with generic drivers, the ability to use dual heads and more advanced configurations has been lost. You may think that you can simply head over to AMD’s ATI driver page and get a driver, but the latest version of Catalyst does not support the older cards. “Maybe I can just download an older version of the driver,” might be what you are thinking, but the old driver is not compatible with the new version of xserver that is included with Ubuntu Jaunty.
    The only way to use the old driver is to downgrade your xserver, which is actually not too hard. As long as you have an internet connection and some terminal skills, you are set.

    WARNING: Running commands as root (using sudo or su) can potentially damage your operating system. Be sure to CAREFULLY read EVERYTHING. Only proceed with these steps if you are confident with what you are doing.
    First off we will want to backup your current “sources.list” (the file that contains all of the repository information), so simply run the command:
    sudo cp /etc/apt/sources.list /etc/apt/sources.list.bak
    Now, we will open up the original “sources.list” file and set it all back to the intrepid repositories. This can easily be done with Gedit’s replace tool. You can, of course, use any other text editor. To open the file in Gedit, just type the following into a terminal.
    sudo gedit /etc/apt/sources.list
    In gedit, simply select the word “jaunty” anywhere in the file and click on “Replace” on the tool bar. When the dialogue box comes up, type “intrepid” into the box labeled “Replace With:” and click “Find” then “Replace All”
    After replacing “jaunty”, save the file and close out of Gedit (or what ever text editor you used), and go back to a terminal and type:
    sudo apt-get update
    Once the repositories are updated, make sure all ATI drivers are uninstalled.
    Now we will uninstall the current version of the xserver using the following command. (Note that gnome-session and fast-user-switcher-applet are specific to Ubuntu. Variants like Kubuntu and Xubuntu will not need to remove these because they are not installed)
    sudo apt-get autoremove xserver-xorg gnome-session fast-user-switch-applet
    This may take a minute or so. After it completes, we will reinstall the xserver and also install the ATI drivers. (Note that gnome-session and fast-user-switcher-applet are specific to Ubuntu. Variants like Kubuntu and Xubuntu will not need to install them because they are not part of your desktop environment)
    sudo apt-get install xserver-xorg fglrx-amdcccle fglrx-kernel-source xorg-driver-fglrx libdrm2=2.3.1-0build1 gnome-session fast-user-switch-applet=2.24.0-0ubuntu6
    When everything is finished installing, you will want to open up Synaptic Package Manager and lock all of the xserver-xorg*, fglrx*, xorg-driver-fglrx, libdrm2, gnome-session, and fast-user-switch-applet packages at their current version. This is done by selecting the package then going to the “Package” menu and clicking on “Lock Version”. You can also do this in the terminal by running:
    sudo su
    then
    echo 'package-name hold' | dpkg --set-selections
    Make sure to repeat the last command for each package that was installed by the previous commands. (This should total to about 47 packages or so.)
    Once all of the xserver and ATI driver packages have been locked, run
    sudo cp /etc/apt/sources.list.bak /etc/apt/sources.list
    and restart your computer.
    Once your computer restarts, all you should be able to use all of the features provided by the ATI drivers that were just installed.
    EDIT 06/05/09: After you restart, make sure to go to the Hardware Drivers manager under the “System” menu: Administration > Hardware Drivers and enable that ATI driver and reboot again. (Thanks Nicholas)
    EDIT 07/15/09: I have added the 3D fix suggested in the comments. (Thanks Dario)
    EDIT 07/25/09: I have also added the fix for the CPU problem that was suggested. (Thanks Flávio)
    EDIT 08/04/09: I have once again added a user submitted fix for the Fast User Switcher. (Thanks Shaun)
    EDIT 09/23/09: An important comment from Mark:
    I did run into one issue- after activating the ATI driver and rebooting, I got a great big watermark in the bottom right corner of my screen with an AMD/ATI logo warning me of “Unsupported Hardware”. If anybody else runs into this, this is how I fixed it:
    1. Download the 9.3 legacy driver package from ati at this page:
    http://support.amd.com/us/gpudownload/linux/Legacy/Pages/radeon_linux.aspx?type=2.7&product=2.7.4.3.3.3 .1&lang=English
    2. Extract (don’t install!) the files from the 9.3 package to a folder with a command like:
    sh ati-driver-installer-9-3-x86.
    x86_64 –extract driverfiles
    3. Replace your ATI ‘control’ file with the one from this 9.3 package:
    First back up your existing file just in case:
    sudo cp /etc/ati/control /etc/ati/control.backup
    Then copy the new file in place:
    sudo cp driverfiles/common/etc/ati/control /etc/ati
    4. Reboot and profit! No more watermark.

    Source: http://tan-com.com/posts/technology/...i-driver-issue
    Last edited by gizmopower; October 6th, 2009 at 08:30 AM.

  2. #2
    Join Date
    Aug 2009
    Beans
    3

    Re: Fix Ubuntu 9.04 ATI Driver Issue

    Fantastic! Got my 800XT working like a champ once again. One question though, can I unlock everything now that the driver is up to date?

  3. #3
    Join Date
    Aug 2009
    Beans
    12
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Fix Ubuntu 9.04 ATI Driver Issue

    To be honest, I don´t know! If you find out please post!

  4. #4
    Join Date
    Aug 2009
    Beans
    12
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Fix Ubuntu 9.04 ATI Driver Issue

    I have tried to unlock files but it is not possible! At least not on my Ubuntu!

    I did a fresh install and reverted again without upgrading driver any further.

    It worked like a charm again, my Raedon 9800pro gives now about: 25000 5/sek - 5000 fps in gfxgears and Nexuis runs really smooth!


  5. #5
    Join Date
    Aug 2009
    Beans
    4

    Re: Fix Ubuntu 9.04 ATI Driver Issue

    I tried this, but it did not work for me. I am running a 9000pro card, and it just comes up to using the lowered graphical interface screen.

    I can unlock the files that were locked though, so I am going to undo all this and go back to the generic drivers.

    https://help.ubuntu.com/community/RadeonDriver

  6. #6
    Join Date
    Feb 2009
    Beans
    215
    Distro
    Kubuntu 9.04 Jaunty Jackalope

    Re: Fix Ubuntu 9.04 ATI Driver Issue

    you should bracket the CLI commands using code/, so that others can easily copy and paste them in their terminal.

    I would rather set my package preferences/pinning in /etc/apt/preferences, here's mine:

    Code:
    Package: xserver-xorg
    Pin: version 7.4~5ubuntu3
    Pin-Priority: 1001
    
    Package: xserver-xorg-video-all
    Pin: version 7.4~5ubuntu3
    Pin-Priority: 1001
    
    Package: xserver-xorg-input-all
    Pin: version 7.4~5ubuntu3
    Pin-Priority: 1001
    
    Package: xorg-driver-fglrx
    Pin: version 8.593-0ubuntu1
    Pin-Priority: 1001
    
    Package: fglrx-amdcccle
    Pin: version 8.593-0ubuntu1
    Pin-Priority: 1001
    
    Package: fglrx-kernel-source
    Pin: version 8.593-0ubuntu1
    Pin-Priority: 1001
    
    Package: libamdxvba1
    Pin: version 8.593-0ubuntu1
    Pin-Priority: 1001
    
    Package: libgl1-mesa-dri
    Pin: version 7.2*
    Pin-Priority: 1001
    
    Package: libdrm2
    Pin: version 2.3.1-0build1
    Pin-Priority: 1001
    Now I can upgrade away without feeling guilty. Unfortunately, synaptic does not read from preferences which is strange, but it is easy to lock the downgraded packages in synaptic (tools->) after searching for fglrx and xserver. Also, people, keep them locked, as the moment you unlock and upgrade (ie kernel security update), your video packages (fglrx) will upgrade to 9.4, giving you a black screen on reboot, nice huh? It does not affect me, as I use apt in CLI for managing my packages
    Last edited by ssri; September 8th, 2009 at 10:45 AM.

  7. #7
    Join Date
    Jan 2008
    Beans
    7
    Distro
    Kubuntu 10.04 Lucid Lynx

    Exclamation Re: Fix Ubuntu 9.04 ATI Driver Issue

    ref: radeon 9800 pro with ubuntu 9.04 posted by Gizmo
    Did everything step by step and got to the restart. I was just ready to activate driver under Hardware Drives and I’ve noticed my box is EMPTY: “No proprietary drivers are in use on this system”, so there’s nothing I can Enable.

    Any thoughts/Advice plz !?

    PS: I’m very green with linux (but so much in Love with it ) at the moment being in process of learning. [linux process ]

    THX to all of you!

  8. #8
    Join Date
    Sep 2009
    Beans
    2

    Smile Re: Fix Ubuntu 9.04 ATI Driver Issue

    Wow thanks this worked wonders for me. Have a dell e1505 and had some dusting and artifact effect when going to 9.04. Now it runs artifact free!!!!!

  9. #9
    Join Date
    Aug 2009
    Beans
    12
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Fix Ubuntu 9.04 ATI Driver Issue

    Quote Originally Posted by ssri View Post
    you should bracket the CLI commands using code/, so that others can easily copy and paste them in their terminal.

    I would rather set my package preferences/pinning in /etc/apt/preferences, here's mine:

    Code:
    Package: xserver-xorg
    Pin: version 7.4~5ubuntu3
    Pin-Priority: 1001
     
    Package: xserver-xorg-video-all
    Pin: version 7.4~5ubuntu3
    Pin-Priority: 1001
     
    Package: xserver-xorg-input-all
    Pin: version 7.4~5ubuntu3
    Pin-Priority: 1001
     
    Package: xorg-driver-fglrx
    Pin: version 8.593-0ubuntu1
    Pin-Priority: 1001
     
    Package: fglrx-amdcccle
    Pin: version 8.593-0ubuntu1
    Pin-Priority: 1001
     
    Package: fglrx-kernel-source
    Pin: version 8.593-0ubuntu1
    Pin-Priority: 1001
     
    Package: libamdxvba1
    Pin: version 8.593-0ubuntu1
    Pin-Priority: 1001
     
    Package: libgl1-mesa-dri
    Pin: version 7.2*
    Pin-Priority: 1001
     
    Package: libdrm2
    Pin: version 2.3.1-0build1
    Pin-Priority: 1001
    Now I can upgrade away without feeling guilty. Unfortunately, synaptic does not read from preferences which is strange, but it is easy to lock the downgraded packages in synaptic (tools->) after searching for fglrx and xserver. Also, people, keep them locked, as the moment you unlock and upgrade (ie kernel security update), your video packages (fglrx) will upgrade to 9.4, giving you a black screen on reboot, nice huh? It does not affect me, as I use apt in CLI for managing my packages

    Tanx for youre input!

    TangoRom:
    I dont know what could be wrong if you followed step by step! Maybe try again?

  10. #10
    Join Date
    Sep 2009
    Beans
    2

    Re: Fix Ubuntu 9.04 ATI Driver Issue

    Quote Originally Posted by TangoRom View Post
    ref: radeon 9800 pro with ubuntu 9.04 posted by Gizmo
    Did everything step by step and got to the restart. I was just ready to activate driver under Hardware Drives and I’ve noticed my box is EMPTY: “No proprietary drivers are in use on this system”, so there’s nothing I can Enable.

    Any thoughts/Advice plz !?

    PS: I’m very green with linux (but so much in Love with it ) at the moment being in process of learning. [linux process ]

    THX to all of you!

    Hi all, i'm on the same boat as TangoRom,
    did all the steps but no driver to enable.
    i have a mobility 9700
    (ATI Technologies RV350 (Mobility Radeon 9600 M10) 64MB VRAM)

    Any ideas what to do?

    Thanks.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •