Page 1 of 4 123 ... LastLast
Results 1 to 10 of 33

Thread: how to use ibus?

  1. #1
    Join Date
    Jun 2007
    Beans
    50

    Question how to use ibus?

    Hi all,

    I want to use russian, korean and english with iBus. These are the shortcuts to control ibus:
    Enable or Disable: Control + space
    Next input method: Control + Alt + space

    Input methods are Russian-kbd and Korean-Hangul, in the order presented.


    Now, when I want to type in russian, then I have to hit Control + space, but when I want to use Korean I have to hit Control + Alt + space. And when I want to switch to english, I have to hit Control + space, which, in my opinion, is inconsistent. Is there a way that I can set up ibus to function the same way as windows or mac os x?

    Any help would be appreciated.
    Thanks

  2. #2
    Join Date
    Dec 2006
    Location
    USA
    Beans
    348
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: how to use ibus?

    I'd also be interested to see if anyone is successfully using this on Ubuntu 9.04/9.10, specifically for Traditional Chinese Pinyin input?
    Keith
    Open.nfo

  3. #3
    Join Date
    May 2007
    Beans
    147

    Re: how to use ibus?

    What is Ibus?

  4. #4
    Join Date
    Dec 2006
    Location
    USA
    Beans
    348
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: how to use ibus?

    ibus (http://code.google.com/p/ibus/) is software for inputting foreign characters (Chinese, Korean, etc), similar to SCIM.

    I've actually been using it for the past several months, and I really like it.
    Keith
    Open.nfo

  5. #5
    Join Date
    Apr 2006
    Beans
    42
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: how to use ibus?

    I am completely new to IBus, but I need to input Korean and so I have been experimenting with IBus tonight. I am using Ubuntu 9.10.

    Start IBus

    Navigate to the menu:
    System >> Preferences >> IBus Preferences

    You will see a message which reads:
    IBus daemon is not started. Do you want to start it now?
    Click, "Yes"
    After clicking yes, I received the following message:
    IBus has been started! If you can not use IBus, please add below lines in $HOME/.bashrc, and relogin your desktop.
    export GTK_IM_MODULE=ibus
    export XMODIFIERS=@im=ibus
    export QT_IM_MODULE=ibus
    I have not been able to see any difference that these lines make in the ~/.bashrc file. I added these lines and rebooted and then did some testing. Then I took the lines out, rebooted again, and tested again. The behavior of IBus is the same for me either way.

    IBus Preferences
    Here is what I selected for Korean input:
    General (tab)
    Check: Show input method name on language bar
    Input Method (tab)
    Select an input method: Korean >> han2
    Click the button: Add

    PROBLEM: IBus doesn't start automatically when I restart my computer
    Here is how I solved the problem:
    Go to the menu:
    System >> Preferences >> Startup Applications
    Click the button: Add
    Name: IBus daemon
    Command: /usr/bin/ibus-daemon -d
    Comment: start IBus daemon when Gnome starts

    IBus usage tips
    • Input methods can be selected by clicking on an icon (of a keyboard and a tiny globe) in the notification area (the upper right part of the top edge panel)
    • If you click on the icon and it says, "No input window" that just means that there is no window currently selected where text can be entered. Open up a text editor or click some place where text can be entered, and then go back to the IBus icon. You should see the selection of input methods.


    Edit: added full path to ibus-daemon
    Last edited by davescafe; October 31st, 2009 at 03:05 PM.

  6. #6
    Join Date
    Nov 2007
    Beans
    92

    Re: how to use ibus?

    Davescafe, many thanks for your tip on how to get iBus to start automatically. Works perfectly!



    PROBLEM: IBus doesn't start automatically when I restart my computer
    Here is how I solved the problem:
    Go to the menu:
    System >> Preferences >> Startup Applications
    Click the button: Add
    Name: IBus daemon
    Command: /usr/bin/ibus-daemon -d
    Comment: start IBus daemon when Gnome starts

  7. #7
    Join Date
    Aug 2008
    Beans
    26
    Distro
    Ubuntu Development Release

    Re: how to use ibus?

    Quote Originally Posted by pwnedd View Post
    I'd also be interested to see if anyone is successfully using this on Ubuntu 9.04/9.10, specifically for Traditional Chinese Pinyin input?
    I did actually, after some work (just follow what people wrote here). If you want it to work without rebooting or logging out, just restart the ibus daemon:
    Code:
    $ killall ibus-daemon 2>/dev/null
    $ ibus-daemon -d &

  8. #8
    Join Date
    Jun 2006
    Beans
    66

    Re: how to use ibus?

    edit: actually below is wrong. You do not need to run ibus as a startup program if you set it to the default input system: System > Administration > Language Support

    I was having trouble with the iBus panel applet. When auto-started, the daemon was running, input worked, but no panel applet. When I ran it manually the panel applet showed up. Fixed after I did this setting in iBus preferences:

    Quote Originally Posted by davescafe View Post
    General (tab)
    Check: Show input method name on language bar
    In other words, you MUST select "show input method name on language bar" to make the applet show up when auto-started. Apparently this is not necessary when running it manually.

    huh, is that THE davescafe??
    Last edited by alexyz; November 9th, 2009 at 04:43 AM.

  9. #9
    Join Date
    Sep 2007
    Beans
    215

    Re: how to use ibus?

    Quote Originally Posted by davescafe View Post

    I have not been able to see any difference that these lines make in the ~/.bashrc file. I added these lines and rebooted and then did some testing. Then I took the lines out, rebooted again, and tested again. The behavior of IBus is the same for me either way.
    Could you tell me where exactly those 3 lines of text go? I have searched and searched, but don't have any file/folder labeled .bashrc hidden or otherwise. I have no clue what I should do.
    SCIM isn't working for me which is why I am trying IBus.

    Quote Originally Posted by davescafe View Post
    • If you click on the icon and it says, "No input window" that just means that there is no window currently selected where text can be entered. Open up a text editor or click some place where text can be entered, and then go back to the IBus icon. You should see the selection of input methods.

    I get this message in the search bar on google and in Open Office. So it seems for now, I do not have the ability to use other languages.

    I'm running 9.10

  10. #10
    Join Date
    Jun 2006
    Beans
    66

    Re: how to use ibus?

    Quote Originally Posted by T4K3Z0U View Post
    I have searched and searched, but don't have any file/folder labeled .bashrc hidden or otherwise
    .bashrc is in your home folder - the full path is /home/yourusername/.bashrc

    If you don't have one then it either got deleted or somehow was not installed, which is rather strange. In any case if it's not there just create a new file with that name, but I'd recommend figuring out why it's not there.

    You need to log out and log in for this to take effect.

    BTW the tilde character ~ is a handy shortcut for your home directory, and files whose name begins with a dot are hidden.

Page 1 of 4 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •