Well, I found out the cause--the System76 Driver automatically downloaded the newest kernel and I didn't notice that kernel had become the default one to boot from, and everyone knows the newest Ubuntu kernel almost never works with the NVidia drivers. Simply setting the kernel I always use back to the default in GRUB's menu.lst fixed it. Also, the items in menu.lst were overwritten from the driver install--I had to re-enter the Windows boot line.