Results 1 to 6 of 6

Thread: *some* MP3s shared on Ubunut PC have duration of 0:00 on Windows XP PC

  1. #1
    Join Date
    May 2009
    Location
    Courtenay, BC, Canada
    Beans
    1,661

    (Solved) *some* MP3s shared on Ubunut PC have duration of 0:00 on Windows XP PC

    ok. here's the scenario
    I am filesharing my mp3s so that I can listen to them on the Windows XP computer that is on my network. all of the mp3s work on the Ubuntu PC but half or more of the mp3s display a duration of 0:00 and an empty tag on the Windows XP computer. I have done two things which I found on another thread, days ago, of which I have lost the link. the first is to re-set the system time format on the Windows XP computer (in regional settings). the second is I manually built all the 'tags' using EasyTag (the thread I found suggested another windows program but all the files are on the Ubuntu PC).

    any ideas how to fix it?
    Last edited by HiImTye; August 24th, 2009 at 06:30 AM. Reason: want to buy 'Solved' tag

  2. #2
    Join Date
    Jun 2007
    Location
    Porirua, New Zealand
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: *some* MP3s shared on Ubunut PC have duration of 0:00 on Windows XP PC

    Don't panic! You're not alone in noticing an "incorrect" duration for the MP3 files.

    A search of the forums reveals a number of threads that touch on this topic: http://ubuntuforums.org/tags.php?tag=length

    Seomthing else to be aware of (which might not be relevant to your siuation) is that some MP3 files that can be downloaded using P2P software come with nasty surprises in the form of malware.
    Forum DOs and DON'Ts
    Never assume that information you find using a search engine is up-to-date.
    Please use CODE tags.

  3. #3
    Join Date
    May 2009
    Location
    Courtenay, BC, Canada
    Beans
    1,661

    Re: *some* MP3s shared on Ubunut PC have duration of 0:00 on Windows XP PC

    some of the files showing incorrect duration are ones that were ripped locally and I always approach every file with a 'hacker mindset' - old habits die hard lol

    I wouldnt have posted if I didnt take as many steps as I could think of (including searching) before posting.

    I know, you're used to lay-mans trying to finger stuff out but I'm not a layman at all. a bit new to Linux (about a year or so) but not new to computing at an advanced level at all.

  4. #4
    Join Date
    Jun 2007
    Location
    Porirua, New Zealand
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: *some* MP3s shared on Ubunut PC have duration of 0:00 on Windows XP PC

    Quote Originally Posted by HiImTye View Post
    some of the files showing incorrect duration are ones that were ripped locally and I always approach every file with a 'hacker mindset' - old habits die hard lol

    I wouldnt have posted if I didnt take as many steps as I could think of (including searching) before posting.

    I know, you're used to lay-mans trying to finger stuff out but I'm not a layman at all. a bit new to Linux (about a year or so) but not new to computing at an advanced level at all.
    So the other threads on the forum didn't help?
    Forum DOs and DON'Ts
    Never assume that information you find using a search engine is up-to-date.
    Please use CODE tags.

  5. #5
    Join Date
    May 2009
    Location
    Courtenay, BC, Canada
    Beans
    1,661

    Re: *some* MP3s shared on Ubunut PC have duration of 0:00 on Windows XP PC

    no, the ones linked ^ up there were about incorrect duration *within* Ubuntu, not correct length in Ubuntu and incorrect length in Windoze XP. The one thread I found offsite I tried both 'fixes' (mentioned in my first post) but neither corrected the issue.

  6. #6
    Join Date
    May 2009
    Location
    Courtenay, BC, Canada
    Beans
    1,661

    Re: *some* MP3s shared on Ubunut PC have duration of 0:00 on Windows XP PC

    so I did fix my problem (I did a couple weeks ago and forgot to post the solution). It turns out that I needed to enable both 'Read' and 'Execute' permissions for all of the files. Only some had 'execute' permissions and so only they were able to show the proper duration.

    to do so, I used nautilus.

    1. right click on the folder containing all of my MP3s (neatly organized in sub-folders)
    2. select the 'permissions' tab
    3. ensure that both 'read' and 'execute' are enabled for 'group' and 'everyone else' for both folders and files
    4. click 'close'
    5. viola!

    hope this helps someone else!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •