Results 1 to 10 of 10

Thread: High-pitched noise at startup

  1. #1
    Join Date
    Feb 2009
    Beans
    71

    High-pitched noise at startup

    Hi!

    I've read a couple of threads with people having similar issues, but nothing has helped, so I try creating an own one. Here goes:

    First, sound has been working well earlier, this is something that changed recently. I have a Dell Latitude D830 with a docking station, and this weekend I decided to fix some trouble where Skype had a conflict with Rhythmbox and Flash applications while the computer was docked. I followed the steps in this guide: http://ubuntuforums.org/showthread.php?t=789578 (which I have used to solve this problem when the laptop is un-docked, but this did not help for the docked setup).

    Since then, a screeching, high-pitched noise/beep at maximum volume comes out of my speakers, starting somewhere halfway through booting, and continuing indefinitely - until I plug something into the headphone jack to silence it (if I plug in headphones, the noise comes out of them instead). The noise is independent of mute, volume change, etc. If I play a sound, I still only hear the noise. I have tried to uninstall ALSA and pulseaudio, nothing helps. I have also gone through the Comprehensive Sound guides in this forum without success.

    While tweaking around with the ALSA installation, I now also get an error message after logon, telling me that something is wrong with the certificate for bugtrack.alsa-project.org:443. This error, however, started after the noise error started.

    I have no issues at all in Windows Vista (the computer is dual-boot), neiter in Ubuntu when the computer is in its docking station.

    I am quite new to Ubuntu, so the more basic steps you include, the better (I know how to start the terminal, execute commands as root, but not much more than that.)

  2. #2
    Join Date
    Jan 2009
    Location
    In Your Head
    Beans
    370
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: High-pitched noise at startup

    Hi,

    This is something you've probably already tried, but turning off wifi can help.
    The sound is likely due to interference.
    Learn the principle, abide by the principle, and dissolve the principle. Obey the principle without being bound by it. This my friend, is the GnuFu.
    Geeks die, but the Linux kernel lives forever.

  3. #3
    Join Date
    Feb 2009
    Beans
    71

    Re: High-pitched noise at startup

    Quote Originally Posted by WatchingThePain View Post
    Hi,

    This is something you've probably already tried, but turning off wifi can help.
    The sound is likely due to interference.
    Nope, doesn't help. And the wifi is turned on even in the docking station, so it should be unrelated.

    I copied the error message from ALSA (which might not be related):
    (I am using a Swedish version of Ubuntu, so I have translated it.)

    "bugtrack.alsa-project.org:443 is using an invalid security certificate.

    The certificate is not trustable since the issuer certificate is not trustable.

    (Error code: sec_error_untrusted_issuer)"

    More info: I have tried all the suggestions in this thread without success: http://ubuntuforums.org/showthread.php?t=310938

  4. #4
    Join Date
    Feb 2009
    Beans
    71

    Re: High-pitched noise at startup

    Btw: If anyone knows a way of resetting all audio settings and drivers to the original settings without doing a clean re-install, that might be very helpful to me.

  5. #5
    Join Date
    Feb 2009
    Beans
    71

    Re: High-pitched noise at startup

    Progress!

    I reinstalled Pulseaudio again, but that didn't help. But then I went into the volume control and disabled "Capture: ALSA PCM on front:0 (STAC92xx Analog) via DMA (PulseAudio Mixer)". Thus, I turned off my desktop microphone, which solved the problem.
    But why does this happen, and can I get my mic working again?

  6. #6
    Join Date
    Feb 2009
    Beans
    71

    Re: High-pitched noise at startup

    Update:
    I think this might be related to sinks, sources and captures, but I don't really know.
    My default sink is "alsa_output.pci_8086_284b_sound_card_0_alsa_playb ack_0", and default source is "alsa_output.pci_8086_284b_sound_card_0_alsa_playb ack_0.monitor". With this configuration, I have no noise, but the microphone is not working. If I instead activate "alsa_input.pci_8086_284b_sound_card_0_alsa_captur e_0" as the default source, I get the horrible beep. The sound input now gets a signal in the PulseAudio Volume Meter, but this signal is not related to me tapping on the microphone.

    If I in the Ubuntu Volume Control go to the tab "Alternatives", and change the "Input Source" (which have two identical drop down menus, with alternatives "Mic" and "Front Mic") both to be "Mic", the beep changes to a buzz (not as strong as the horrible beep). Still nothing through the mic, though.

  7. #7
    Join Date
    Feb 2009
    Beans
    71

    Re: High-pitched noise at startup

    *bump*

    Any ideas of how I get the mic working without a horrible beep at all times?

  8. #8
    Join Date
    Feb 2009
    Beans
    71

    [SOLVED] Re: High-pitched noise at startup

    Finally, solved the problem. Just in case anyone else gets the same:
    In the volume control, under the "Switches" tab, disable Analog loopback. I have no idea what this is for, or why I had enabled it, but disabling it killed the noise!

  9. #9
    Join Date
    Feb 2008
    Beans
    35
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: [SOLVED] Re: High-pitched noise at startup

    Hi JolinB. THanks for posting on this. I have a very similar problem. I am using pulseaudio server on Intrepid (8.10). I have also followed the howto you mentioned.

    The source of the noise in my case seems to be the front mic input, which I can mute in the Gnome ALSA mixer application. I still have some background noise (not as bad) even when this input is muted, and obviously any mic plugged into the input will not work.

    You mention a "switches tab". I can't find this. Can you give more direction?

  10. #10
    Join Date
    Feb 2008
    Beans
    35
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: [SOLVED] Re: High-pitched noise at startup

    OK I figured it out. Way down at the far end of alsa mixer, which I opened using this command:

    alsamixer -Dhw

    I found a "mic booster" channel. As soon as I dropped the fader on this channel, Presto! Annoying sound gone!
    Last edited by woodbrick; June 18th, 2009 at 12:33 PM. Reason: spelling

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •