Page 1 of 71 1231151 ... LastLast
Results 1 to 10 of 702

Thread: How To: Install Xgl/compiz with Dapper, ATI, Gnome

  1. #1
    Join Date
    Nov 2004
    Location
    Charlotte, NC
    Beans
    Hidden!
    Distro
    Ubuntu 8.04 Hardy Heron

    How To: Install Xgl/compiz with Dapper, ATI, Gnome

    HEY: Ignore this... it's too outdated and no longer really relevant. Besides, there are far newer packages than what's in Dapper right now and this thread won't get you there. THIS, however, worked perfectly for me: http://www.compiz.net/viewtopic.php?id=389




    Many people have contributed to this, some more than others as I've picked up the pieces I needed to make this work from through-out these forums.
    But, in particular: terrax, JoWilly, and poofyhairguy

    1. Get your xorg.conf setup properly. The main thread has more than enough information on this. Follow it paying attention to the ATI differences that are well noted.

    Just to be clear however, these instructions are targeted for those people using the ATI Proprietary Driver ("fglrx"). This is configured in your xorg.conf. If you're using "ati" that's not going to work for you. If you're using "radeon" then this is theoretically possible (radeon is the OSS driver targeted more - for now - for your lower end Radeon cards, in particular the 9000/9200/9250)... but I wasn't able to get it to work with my lower end PC that uses the 9200. In both cases, there are known/outstanding bugs with both sets of drivers that require work arounds described below.

    To make sure you are "accelerated", running with the new driver, try typing fglrxinfo in a terminal and see what you get. If it talks about ATI then awesome... if it talks about Mesa, you still don't have your driver setup properly (xorg.conf).

    **For ATI do not enable composite in xorg.conf, xgl does not need it.

    2. Install all the new stuff from the Dapper universe repository... this includes xserver-xgl, compiz, libgl1-mesa, libgl1-mesa-dri, libglitz1, libglitz-glx1 and any dependencies.

    3. Modify /etc/gdm/gdm.conf-custom - For most this file is generally full of empty stubs. Look for the one called [servers] and do this:

    Code:
    [servers] 
    # Override display 1 to use Xgl (DISPLAY 1 IMPORTANT FOR ATI FGLRX). 
    1=Xgl 
    
    [server-Xgl] 
    name=Xgl server 
    command=/usr/bin/Xgl :1 -fullscreen -ac -accel glx:pbuffer -accel xv:pbuffer
    flexible=true
    4. Modify /etc/gdm/gdm.conf to change your display:
    Code:
    #0=Standard
    1=Standard
    ** You may have noticed in both steps 3 and 4 that we're using Display 1 instead of 0... this is due to a bug in the current proprietary ATI driver and this is the workaround.

    5. Another bug in the driver... And for video, there is a bug with xv, so we want to start "gstreamer-properties" and tell it not to use xv for video. (This is the same as starting "Multimedia Systems Selector", a Preferences application that is currently hidden in your menu system)

    6. Modify your session ("Menu System" -> "Preferences" -> "Sessions") by adding in the following two items:
    Code:
    gnome-window-decorator (must be on top, start first) 
    compiz --replace gconf
    7. Start gconf-editor and go to "apps/compiz/general/all screens/options", and adjust "plugins" in the following order:
    Code:
    gconf decoration wobbly fade minimize cube rotate zoom scale move resize place menu switcher
    It MUST be in this order as there are dependencies between them. If you've already been playing with this from earlier debs - maybe from battlehorse, or maybe you rolled your own - this is an important step because it's very likely in the wrong order. Most people that are missing certain plugins or are missing things like "alt-switch" will find they need to correct this and restart.

    8. To get around the problem with <Shift> and <Backspace> enter this in your terminal whenever you login:
    Code:
    xmodmap /usr/share/xmodmap/xmodmap.<language>
    where <language> refers to your country's code. For the US, it would be:
    Code:
    xmodmap /usr/share/xmodmap/xmodmap.us
    Once everything is running along happily, this is a good appendix for the commands for using the nifty stuff compiz gives you:
    http://en.opensuse.org/Compiz

    That's about as easy as I can make it. Good luck.

    Some Issues
    • This is a wonderful resource for looking into your video card/driver: http://en.opensuse.org/Xgl
    • It appears that you might need a 9800 or better ATI right now.
    • It appears there may be problems with Mobility users (laptops)
    • The latest compiz package may have a bug that doesn't put the necessary gconf settings in place. One possible work-around is to install the battlehorse v1 deb for compiz, then update to the universe deb.


    UPDATES:
    I just got this tip for slightly lower end Radeon's like this user's 9600se:

    1) sudo gedit /etc/gdm/gdm.conf
    2) Go to line 198 and change:
    GdmXserverTimeout=10
    to
    GdmXserverTimeout=50
    Last edited by mattisking; June 13th, 2006 at 01:38 AM. Reason: updated title / revisions

  2. #2
    Join Date
    Nov 2004
    Location
    Texas
    Beans
    2,434

    Re: How To: Install Xgl/compiz with Dapper, ATI, Gnome

    Excellent. I will make one for Nvidia. Thanks!
    Those folks who try to impose analog rules on digital content will find themselves on the wrong side of the tidal wave.
    - Mark Shuttleworth

  3. #3
    Join Date
    Nov 2005
    Location
    Valencia, Spain
    Beans
    622
    Distro
    Hardy Heron (Ubuntu Development)

    Re: How To: "Simple" Install Xgl/compiz for Dapper, ATI, Gnome

    Quote Originally Posted by mattisking
    To make sure you are "accelerated", running with the new driver, try typing fglrxinfo in a terminal and see what you get. If it talks about ATI then awesome... if it talks about Mesa, you still don't have your driver setup properly (xorg.conf).
    OK, I did a fresh install just to follow this guide from the ground up so... I installed the fglrx driver and set it to xorg.conf

    Section "Device"
    Identifier "ATI Technologies, Inc. RV280 [Radeon 9200 PRO]"
    Driver "fglrx"
    BusID "PCI:1:0:0"
    EndSection
    I installed the packages, too, though I can't find either libgl-mesa nor libgl-mesa-dri at the repos: I do find libgl1-mesa and libgl1-mesa-dri... are those the correct names?

    I modified gdm.conf-custom too:

    [servers]
    # Override display 1 to use Xgl (DISPLAY 1 IMPORTANT FOR ATI FGLRX).
    1=Xgl

    [server-Xgl]
    name=Xgl server
    command=/usr/bin/Xgl :1 -fullscreen -ac -accel glxbuffer -accel xvbuffer
    flexible=true
    And gdm.conf as well:

    [servers]
    # These are the standard servers. You can add as many you want here and they
    # will always be started. Each line must start with a unique number and that
    # will be the display number of that server. Usually just the 0 server is
    # used.
    #0=Standard
    1=Standard
    Last edited by Bou; February 16th, 2006 at 11:23 AM.

  4. #4
    Join Date
    Nov 2005
    Location
    Valencia, Spain
    Beans
    622
    Distro
    Hardy Heron (Ubuntu Development)

    Re: How To: "Simple" Install Xgl/compiz for Dapper, ATI, Gnome

    But then, when I try to reboot, I get the following messages:





    I didn't even add the dnome-window-manager and compiz stuff to the session startup. Why can this be caused?
    Last edited by Bou; February 16th, 2006 at 11:23 AM.

  5. #5
    Join Date
    Oct 2004
    Location
    Ontario
    Beans
    263
    Distro
    Ubuntu Development Release

    Re: How To: Install Xgl/compiz with Dapper, ATI, Gnome

    I have a Radeon 9200 SE 128Mb card with acceleration enabled. I followed your instructions up until Step 6. Xgl is running, I'm in gnome but it is sooo slow. I do step 6 and my screen goes black (although I can still see/move my mouse cursor). Also, both Xgl AND Xorg appear to be running. Is this normal? And is my card too low-end for this maybe? I'm on a P4 3GHz with 512 Mb RAM.
    Last edited by vaskark; February 16th, 2006 at 11:38 AM.


  6. #6
    Join Date
    Dec 2005
    Location
    Finland
    Beans
    339
    Distro
    Ubuntu Development Release

    Re: How To: Install Xgl/compiz with Dapper, ATI, Gnome

    You should change your name to mattisGOD, thank you (and the credited others). Got it finally working on my R9500

    My keyboard layout seems to have changed from FI to US. How can I switch back?

  7. #7
    Join Date
    Feb 2005
    Location
    Italy
    Beans
    34
    Distro
    Dapper Drake Testing/

    Re: How To: Install Xgl/compiz with Dapper, ATI, Gnome

    I can't get Xgl to work. I get the following error:

    Couldn't open RGB_DB '/usr/share/X11/rgb'

    any ideas?

  8. #8
    Join Date
    Sep 2005
    Beans
    8

    Re: How To: Install Xgl/compiz with Dapper, ATI, Gnome

    Like all previous times I tried: Can someone give me the final answer how to handle this problem. I installed the latest fglrx driver from the ati site.

    And with fglrxinfo I get:
    display: :0.0 screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: MOBILITY RADEON 9700 Generic
    OpenGL version string: 2.0.5642 (8.22.5)

    So that's ok. But when I want to run compiz I always get this error message:

    compiz.real: GLX_EXT_texture_from_pixmap is missing
    compiz.real: Failed to manage screen: 0
    compiz.real: No managable screens found on display :1.0

    I also got them from the self-compiled version. But with the packages from the repos I still get this message. When I type glxinfo i get:

    name of display: :0.0
    display: :0 screen: 0
    direct rendering: Yes
    server glx vendor string: SGI
    server glx version string: 1.2
    server glx extensions:
    GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_EXT_import_context, GLX_OML_swap_method, GLX_SGI_make_current_read,
    GLX_SGIS_multisample, GLX_SGIX_hyperpipe, GLX_SGIX_swap_barrier,
    GLX_SGIX_fbconfig
    client glx vendor string: ATI
    client glx version string: 1.3
    client glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_ATI_pixel_format_float,
    GLX_ATI_render_texture
    GLX version: 1.2
    GLX extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    GLX_ARB_multisample
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: MOBILITY RADEON 9700 Generic
    OpenGL version string: 2.0.5642 (8.22.5)
    OpenGL extensions:
    GL_ARB_multitexture, GL_EXT_texture_env_add, GL_EXT_compiled_vertex_array,
    GL_S3_s3tc, GL_ARB_depth_texture, GL_ARB_fragment_program,
    GL_ARB_fragment_program_shadow, GL_ARB_fragment_shader,
    GL_ARB_multisample, GL_ARB_occlusion_query, GL_ARB_point_parameters,
    GL_ARB_point_sprite, GL_ARB_shader_objects, GL_ARB_shading_language_100,
    GL_ARB_shadow, GL_ARB_shadow_ambient, GL_ARB_texture_border_clamp,
    GL_ARB_texture_compression, GL_ARB_texture_cube_map,
    GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
    GL_ARB_texture_env_crossbar, GL_ARB_texture_env_dot3,
    GL_ARB_texture_mirrored_repeat, GL_ARB_transpose_matrix,
    GL_ARB_vertex_blend, GL_ARB_vertex_buffer_object, GL_ARB_vertex_program,
    GL_ARB_vertex_shader, GL_ARB_window_pos, GL_ARB_draw_buffers,
    GL_ATI_draw_buffers, GL_ATI_element_array, GL_ATI_envmap_bumpmap,
    GL_ATI_fragment_shader, GL_ATI_map_object_buffer, GL_ATI_separate_stencil,
    GL_ATI_texture_env_combine3, GL_ATI_texture_float,
    GL_ATI_texture_mirror_once, GL_ATI_vertex_array_object,
    GL_ATI_vertex_attrib_array_object, GL_ATI_vertex_streams,
    GL_ATIX_texture_env_combine3, GL_ATIX_texture_env_route,
    GL_ATIX_vertex_shader_output_point_size, GL_EXT_abgr, GL_EXT_bgra,
    GL_EXT_blend_color, GL_EXT_blend_func_separate, GL_EXT_blend_minmax,
    GL_EXT_blend_subtract, GL_EXT_clip_volume_hint,
    GL_EXT_draw_range_elements, GL_EXT_fog_coord, GL_EXT_framebuffer_object,
    GL_EXT_multi_draw_arrays, GL_EXT_packed_pixels, GL_EXT_point_parameters,
    GL_EXT_rescale_normal, GL_EXT_secondary_color,
    GL_EXT_separate_specular_color, GL_EXT_shadow_funcs, GL_EXT_stencil_wrap,
    GL_EXT_texgen_reflection, GL_EXT_texture3D,
    GL_EXT_texture_compression_s3tc, GL_EXT_texture_cube_map,
    GL_EXT_texture_edge_clamp, GL_EXT_texture_env_combine,
    GL_EXT_texture_env_dot3, GL_EXT_texture_filter_anisotropic,
    GL_EXT_texture_lod_bias, GL_EXT_texture_mirror_clamp,
    GL_EXT_texture_object, GL_EXT_texture_rectangle, GL_EXT_vertex_array,
    GL_EXT_vertex_shader, GL_HP_occlusion_test, GL_NV_blend_square,
    GL_NV_occlusion_query, GL_NV_texgen_reflection, GL_SGI_color_matrix,
    GL_SGIS_generate_mipmap, GL_SGIS_texture_border_clamp,
    GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod, GL_SUN_multi_draw_arrays
    glu version: 1.3
    glu extensions:
    GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

    visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
    id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
    ----------------------------------------------------------------------
    0x23 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
    0x24 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
    0x25 24 tc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
    0x26 24 tc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
    0x27 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 1 0 None
    0x28 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 1 0 None
    0x29 24 tc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 1 0 None
    0x2a 24 tc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 1 0 None
    0x2b 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
    0x2c 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
    0x2d 24 dc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
    0x2e 24 dc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
    0x2f 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 1 0 None
    0x30 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 1 0 None
    0x31 24 dc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 1 0 None
    0x32 24 dc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 1 0 None

    And no GLX_EXT_texture_from_pixmap? I saw more people have this problem, but how can it be solved, since also many people have compiz working on their ati card. My card is actually a ATI Mobility Radeon 9700?

  9. #9
    Join Date
    Jul 2005
    Location
    France
    Beans
    133

    Re: How To: Install Xgl/compiz with Dapper, ATI, Gnome

    Also, both Xgl AND Xorg appear to be running. Is this normal?
    Yes it is, Xgl runs on top of Xorg. Nothing to worry about

  10. #10
    Join Date
    Jul 2005
    Location
    France
    Beans
    133

    Re: How To: Install Xgl/compiz with Dapper, ATI, Gnome

    To everybody and in order to answer faster to your problems, it would be useful to provide also:

    1 your graphic card model and which driver are you using (really using, check with glxinfo which driver is loaded)
    2 where did you install from ? (compile, internet deb, repo?)
    3 how do you run Xgl ? (in a terminal, from modification in gdm?)
    4 copy your Xgl launch command
    5 copy your compiz launch command

    Thanks in advance!

Page 1 of 71 1231151 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •