Quote Originally Posted by draggy View Post
Nice guide, I just wish it would work for me.

I have a eee 900HA using NBR, with an Intel 945GME

I've followed the safe method and after rebooting performance was faaaaarr worse then when using the exa acceleration. I checked the fixmtrr.sh and it said that it was already applied.

I started reading through the massive amounts of threads here, and found a post that said I needed to upgrade to kernel 2.6.28-11.43 because of the bug mentioned here: https://bugs.launchpad.net/linux/+bug/349314
I applied the kernel mentioned at the bottom, and rebooted.

I made sure the new kernel was running, and I checked the xorg log for errors but there were none. According to the log, uxa loaded and was running with no errors, but the performance is so bad I can barely navigate the menu on NBR. Switching back to exa puts the performance back to the way it was. I have also tried it with tiling enabled and disabled, but it makes no difference. According to the log, Tiling is enabled without problems.

I seem to be out of ideas, does anyone have suggestions?
My computer also uses the i945GME. I just got my Dell Vostro A90 (mini 9 clone) and immediately installed the latest Ubuntu 9.04 Netbook Remix. To my disappointment, with or without compiz, some graphics performance is awful. I tried everything mentioned in the Ubuntu Forums, Launchpad, Blogs, etc. Nothing helps. I even tried installing Ubuntu 9.10 because it includes the new kernel that suposily fixes the problems, it didn't help, and I lost wireless (Broadcom). Currently I'm using this PPA http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu which installs version 2:2.7.1-0ubuntu1~xup~1 with Option "AccelMethod" "exa", Option "EXAOptimizeMigration" "true", Option "MigrationHeuristic" "greedy", and Option "Tiling" "true". I tried UXA too, but every 30-60 seconds my screen would glitch, so I switched to EXA (which doesn't it default to that). The delayed scrolling in Firefox is the main graphics issue I'm having and it is slightly worse with compiz. I use Flashblock, so it can't be that. The animations in compiz are fine though, no glitches, and very smooth. I don't have smooth scrolling enabled either. Any clues for us i945GME users?